469,645 Members | 1,127 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,645 developers. It's quick & easy.

How To Copy The File To The Windows NT? Filesys::SmbClientParser

Hello,

I'm trying to put the file into the Windows NT server using the Perl
script but it doesn't work. Just look at the following script:

use Filesys::SmbClientParser;

my $fl = '/temp/file.txt';

my $smb = new Filesys::SmbClientParser
(undef, (user => 'user', password => 'pass'));

$smb -> Host ('191.254.1.1');
$smb -> Share ('tdsa_b$');
$smb -> cd ('IN');
$smb -> put ($fl);

The only message I get looks like this:

sh: -c: line 1: unexpected EOF while looking for matching `''
sh: -c: line 2: syntax error: unexpected end of file

What could be wrong here? Is there any other way to put this file into
the Windows NT server? I cannot mount the file share under using the
'system' or 'exec' function because it doesn't work.

When I use

smbmount //191.254.1.1/tdsa_b$ /mnt/test -o user=user,password=pass

under the Linux command prompt it works fine. But if I put that command
into `` or Perl 'system' function it shows me the following message:

Could not resolve mount point

Any ideas? Thanks for any advice.

...:: fabio

Jul 19 '05 #1
2 5731
dw

"Fabio" <fa***@anti-spam.inet.alpha.pl> wrote in message
news:bs**********@nemesis.news.tpi.pl...
smbmount //191.254.1.1/tdsa_b$ /mnt/test -o user=user,password=pass

under the Linux command prompt it works fine. But if I put that command
into `` or Perl 'system' function it shows me the following message:

Could not resolve mount point

Any ideas? Thanks for any advice.


are you losing the $.... would this work:
system ("smbmount", '//191.254.1.1/tdsa_b$', '/mnt/test', '-o',
'user=user,password=pass');


Jul 19 '05 #2
dw wrote:
smbmount //191.254.1.1/tdsa_b$ /mnt/test -o user=user,password=pass

under the Linux command prompt it works fine. But if I put that command
into `` or Perl 'system' function it shows me the following message:

Could not resolve mount point


are you losing the $.... would this work:
system ("smbmount", '//191.254.1.1/tdsa_b$', '/mnt/test', '-o',
'user=user,password=pass');


Yes, that's it! I've fixed the dollar sign problem and it works properly
now. Thanks for advice!

...:: fabio

Jul 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Grey | last post: by
9 posts views Thread by MAF | last post: by
3 posts views Thread by MAF | last post: by
5 posts views Thread by Standist | last post: by
1 post views Thread by Irrigho5 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.