473,218 Members | 1,495 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 473,218 software developers and data experts.

Stumped with a CPAN/CPANPLUS failure

I'm trying to get CPAN or, preferably CPANPLUS working on a dual-CPU
FreeBSD 4.8 server (with plenty of free memory), and have ran into a
problem that I don't appear to resolve. Either of the utilities
experiences a core dump during it's operation:

Output from CPAN:
---
cpan shell -- CPAN exploration and modules installation (v1.61)
ReadLine support enabled

cpan> get Net::DNS
CPAN: Storable loaded ok
CPAN: LWP::UserAgent loaded ok
Fetching with LWP:
ftp://ftp.funet.fi/pub/languages/per...1mailrc.txt.gz
Going to read /root/.cpan/sources/authors/01mailrc.txt.gz
CPAN: Compress::Zlib loaded ok
Segmentation fault (core dumped)
---
and CPANPLUS (both 0.043 and 0.045 behave the same way):
---
CPANPLUS::Shell::Default -- CPAN exploration and modules installation
(v0.03)
*** Please report bugs to <cp***********@lists.sourceforge.net>.
*** Using CPANPLUS::Backend v0.045. ReadLine support enabled.

CPAN Terminal> m Net::DNS
Checking if source files are up to date
Gunzipping /root/.cpanplus/01mailrc.txt.gz
Segmentation fault (core dumped)
---

Since the problem often appears to occur when CPAN/CPANPLUS is
gunzipping files, I upgraded gzip to the latest version in ports,
`gzip --version' produces...

---
gzip 1.3.5
(2002-09-30)
Copyright 2002 Free Software Foundation
Copyright 1992-1993 Jean-loup Gailly
This program comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of this program
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING.
Compilation options:
DIRENT UTIME STDC_HEADERS HAVE_UNISTD_H HAVE_MEMORY_H HAVE_STRING_H
HAVE_LSTAT ASMV
Written by Jean-loup Gailly.
---

The system has Perl 5.8 (installed from the ports collection) that
appears to be working otherwise. I've tried with numerous combinations
of configuration options including "-j3" for CPANPLUS for dual CPUs,
internal MALLOC for Perl, etc.

On the parallel server with largely the same configuration (though
FreeBSD 4.6.3) both CPAN and CPANPLUS work ok. The system that is
experiencing problems with the utilities was recently upgraded from
4.7 to 4.8 as one of the attempts to resolve this problem, but it had
no effect (Perl was recompiled afterwards; `make test' produced no
errors).

After CPANPLUS has been configured, `make test' yields the following
result, ending in an error while probing dependencies:

---
Skip blib/lib/CPANPLUS/Backend/RV.pm (unchanged)
Skip blib/lib/CPANPLUS/Shell/Default.pm (unchanged)
Skip blib/lib/CPANPLUS/Tools/Module.pm (unchanged)
Skip blib/lib/CPANPLUS/Internals.pm (unchanged)
Skip blib/lib/CPANPLUS/Tools/Load.pm (unchanged)
Skip blib/lib/CPANPLUS.pm (unchanged)
Skip blib/lib/CPANPLUS/Backend.pm (unchanged)
Skip blib/lib/CPANPLUS/Styleguide.pod (unchanged)
Skip blib/lib/CPANPLUS/Internals/Report.pm (unchanged)
Skip blib/lib/CPANPLUS/I18N/CPANPLUS.pot (unchanged)
Skip blib/lib/CPANPLUS/FAQ.pod (unchanged)
cp lib/CPANPLUS/Config.pm blib/lib/CPANPLUS/Config.pm
Skip blib/lib/CPANPLUS/Tools/Cmd.pm (unchanged)
Skip blib/lib/CPANPLUS/Tools/Term.pm (unchanged)
Skip blib/lib/CPANPLUS/Internals/Utils.pm (unchanged)
Skip blib/lib/CPANPLUS/Shell.pm (unchanged)
Skip blib/lib/CPANPLUS/Internals/Module.pm (unchanged)
Skip blib/lib/CPANPLUS/Internals/Install.pm (unchanged)
Skip blib/lib/CPANPLUS/Internals/Source.pm (unchanged)
Skip blib/lib/CPANPLUS/Configure/Setup.pm (unchanged)
Skip blib/lib/CPANPLUS/Internals/Fetch.pm (unchanged)
Skip blib/lib/CPANPLUS/Internals/Module/Status.pm (unchanged)
Skip blib/lib/CPANPLUS/Shell/Classic.pm (unchanged)
Skip blib/lib/CPANPLUS/Tools/Check.pm (unchanged)
Skip blib/lib/CPANPLUS/Configure.pm (unchanged)
Skip blib/lib/CPANPLUS/Config.pm-orig (unchanged)
Skip blib/lib/CPANPLUS/I18N.pm (unchanged)
Skip blib/lib/CPANPLUS/Internals/Make.pm (unchanged)
Skip blib/lib/CPANPLUS/Internals/Search.pm (unchanged)
Skip blib/lib/CPANPLUS/Internals/Extract.pm (unchanged)
Skip blib/lib/CPANPLUS/Internals/Author.pm (unchanged)
Skip blib/lib/CPANPLUS/Internals/System.pm (unchanged)
Skip blib/lib/CPANPLUS/Error.pm (unchanged)
Skip blib/lib/CPANPLUS/TesterGuide.pod (unchanged)
Skip blib/lib/CPANPLUS/I18N/fr.po (unchanged)
/usr/local/bin/perl Makefile.PL
--config=-skiptest,1,-prereqs,1,-do_once,1
--installdeps=File::RsyncP,0,CPANPLUS::Shell::Curses ,0.02,CPANPLUS::Shell::Tk,0.02
*** Installing dependencies...
Checking if source files are up to date
Gunzipping /root/.cpanplus/01mailrc.txt.gz
Segmentation fault (core dumped)
*** Error code 139

Stop in /usr/local/src/CPANPLUS-0.045.
---

Installing any of the modules from the ports seems to work without any
problems, only CPAN/CPANPLUS shell interfaces fail.

Any ideas as to what I could try next? Also, if this is not the right
place to ask this question, please point me to the right direction.

Thanks for any advice!

Ville Walveranta
Jul 19 '05 #1
1 2465
ne**@astronfortis.com (Ville Walveranta) wrote in message news:<26**************************@posting.google. com>...
I'm trying to get CPAN or, preferably CPANPLUS working on a dual-CPU
FreeBSD 4.8 server (with plenty of free memory), and have ran into a
problem that I don't appear to resolve. Either of the utilities
experiences a core dump during it's operation: .... CPAN Terminal> m Net::DNS
Checking if source files are up to date
Gunzipping /root/.cpanplus/01mailrc.txt.gz
Segmentation fault (core dumped)
---


I'm answering to my own question since this problem was solved...
maybe the answer will help someone. As the port for the new version of
Perl (5.8.1) appeared in FreeBSD ports collection update, I installed
it and... CPAN and CPAN++ shells started working, too! I'm not sure
whether there was an actual bug with 5.8.0 since I had the shells
working ok on a parallel system running 5.8.0. Maybe the fact that I
reinstalled Perl helped (though I had done so few times using 5.8.0 on
the system that was having problems).

// Ville
Jul 19 '05 #2

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

3
by: p cooper | last post by:
router root # perl -MCPAN -e 'install Net::SMTP' CPAN: Storable loaded ok LWP not available CPAN: Net::FTP loaded ok Fetching with Net::FTP: ftp://ftp.perl.org/pub/CPAN/authors/01mailrc.txt.gz...
0
by: blupp | last post by:
Hi, I am trying to install the package, but get the following error: cpan> install Date::Manip Running install for module Date::Manip Running make for S/SB/SBECK/DateManip-5.42a.tar.gz LWP...
0
by: krigare | last post by:
CPAN 1.76 ncftp 3.1.7 Redhat 9 I am behind a firewall. I do have ncftp configured to handle the firewall settings. In fact I can manually (from the command line) do: #> ncftpget...
1
by: Brian McGonigle | last post by:
I'm trying to use cpanp behind a firewall and I'm not having any luck. However, cpan works fine with my proxy configs (I've set http_proxy and ftp_proxy in my shell environment). I've tried just...
0
by: simon | last post by:
Hi I am trying to install MIME::Base64 and MIME::QuotedPrint using CPAN on Suse 9.1. Suse comes with Perl v5.8.3 already installed. The error message I receive is as follows: ...
7
by: chandru1782 | last post by:
Dear friends, I am trying to use CPAN for installing some perl modules. i am using a ubuntu system, which has internet connection through lan and authenticated proxy. when trying to install...
1
numberwhun
by: numberwhun | last post by:
Ok, I have an issue and I am not sure what is causing it. I am working on a Fedora Core 7 Linux machine (my laptop). I have not had any problems with installing modules via CPAN. All has...
1
by: spatro | last post by:
Hi, I am trying to install DBD::mysql using the CPAN and I am facing the following error: cpan> install DBD::mysql CPAN: Storable loaded ok Going to read /root/.cpan/Metadata Warning:...
1
isladogs
by: isladogs | last post by:
The next online meeting of the Access Europe User Group will be on Wednesday 6 Dec 2023 starting at 18:00 UK time (6PM UTC) and finishing at about 19:15 (7.15PM). In this month's session, Mike...
0
by: veera ravala | last post by:
ServiceNow is a powerful cloud-based platform that offers a wide range of services to help organizations manage their workflows, operations, and IT services more efficiently. At its core, ServiceNow...
3
isladogs
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 3 Jan 2024 starting at 18:00 UK time (6PM UTC) and finishing at about 19:15 (7.15PM). For other local times, please check World Time Buddy In...
0
by: mar23 | last post by:
Here's the situation. I have a form called frmDiceInventory with subform called subfrmDice. The subform's control source is linked to a query called qryDiceInventory. I've been trying to pick up the...
0
by: abbasky | last post by:
### Vandf component communication method one: data sharing ​ Vandf components can achieve data exchange through data sharing, state sharing, events, and other methods. Vandf's data exchange method...
0
by: fareedcanada | last post by:
Hello I am trying to split number on their count. suppose i have 121314151617 (12cnt) then number should be split like 12,13,14,15,16,17 and if 11314151617 (11cnt) then should be split like...
0
Git
by: egorbl4 | last post by:
Скачал я git, хотел начать настройку, а там вылезло вот это Что это? Что мне с этим делать? ...
1
by: davi5007 | last post by:
Hi, Basically, I am trying to automate a field named TraceabilityNo into a web page from an access form. I've got the serial held in the variable strSearchString. How can I get this into the...
0
by: MeoLessi9 | last post by:
I have VirtualBox installed on Windows 11 and now I would like to install Kali on a virtual machine. However, on the official website, I see two options: "Installer images" and "Virtual machines"....

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.