473,544 Members | 1,972 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Hmmm... problems with CPAN (MakeMaker?) on Win32+MSYS or Win32+UnixUtils and others

I've been using ActiveState's PPM3 to install most of my modules, but I've
found it doesn't have many very useful modules. This was mostly forced,
since I could never get the CPAN module to actually build the modules. This
morning, I finally had enough, and decided to try and figure out exactly
what was wrong, and try to fix it.

Nomatter what I do, when running just a plain "make" after it runs
"MakeFile.P L," it gives me something like the following error, for any
module, any distribution:

Writing Makefile for [InsertModuleNam eHere]
Makefile:[SomeLine]: *** missing separator. Stop.
[APathToMake]/make.exe -- NOT OK

I've tried using Cygwin, MSYS, UnixUtils, and MSVC++7's make.exe utilities.
With CygWin and MSYS, I tried both thier own shells, and the base windows
command line. The only one that does anything different is MSVC++7's, which
fails much earlier than the others, for reasons I'm not really sure of --
I'll assume because Microsoft wrote it. All the others give the same line
number and reason for the fail.

I'm not really sure if it's the CPAN module's fault or MakeMaker's, since
I've never really used either seperate from the other before.

Does anyone have any suggestions, or have any clues to what's wrong?

---

=cut JAPH

$_="aa4e0a827b1 4150960910ca030 5691";$_=
unpack("b*",pac k("H*",$_));s/([01]{5})/
pack("b*",$1)/gex;$_=join('', map{chr(
ord($_)+96)}spl it'');s/`/ /gx;print;

=head1 AUTHOR

Alex Lyman ("Silicon") is the Lead Programmer,
among other things, for LAO Gaming.

Alex also is a Web Designer/Programmer in his
spare time. If you need a website designed,
or just need programming done for one, contact
him at Al*******@Earth link.net

=cut
---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.594 / Virus Database: 377 - Release Date: 2/24/2004
Jul 19 '05 #1
0 1652

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

3
12587
by: p cooper | last post by:
router root # perl -MCPAN -e 'install Net::SMTP' CPAN: Storable loaded ok LWP not available CPAN: Net::FTP loaded ok Fetching with Net::FTP: ftp://ftp.perl.org/pub/CPAN/authors/01mailrc.txt.gz Couldn't fetch 01mailrc.txt.gz from ftp.perl.org Trying with "/usr/bin/lynx -source" to get ftp://ftp.perl.org/pub/CPAN/authors/01mailrc.txt.gz
0
1565
by: Vitaliy | last post by:
I've installed perl 5.8.0 on my FreeBSD 4.8. The installation ran smoothly and without any problems. After I've tried to upgrade CPAN from shell (cpan> install Bundle::CPAN) as it was suggested I've stumbled upon Segmentation fault and core dump. Now, everytime I try to install something through the CPAN shell, I get the same error. I can't...
0
6420
by: blupp | last post by:
Hi, I am trying to install the package, but get the following error: cpan> install Date::Manip Running install for module Date::Manip Running make for S/SB/SBECK/DateManip-5.42a.tar.gz LWP not available Fetching with Net::FTP: ftp://ftp.perl.org/pub/CPAN/authors/id/S/SB/SBECK/DateManip-5.42a.tar.gz
2
5180
by: Glenn | last post by:
Hi, I'm using cygwin and am trying to install DBI-mSQL and am getting errors on make .. any idea how to fix this (TIA): cpan> install DBD::mSQL Running install for module DBD::mSQL Running make for J/JW/JWIED/Msql-Mysql-modules-1.2219.tar.gz LWP not available Fetching with Net::FTP:
0
3550
by: simon | last post by:
Hi I am trying to install MIME::Base64 and MIME::QuotedPrint using CPAN on Suse 9.1. Suse comes with Perl v5.8.3 already installed. The error message I receive is as follows: MOOSE:/usr/local/cpanSGH # perl -MCPAN -e "install 'MIME::Base64'" CPAN: Storable loaded ok Going to read /usr/local/cpanSGH/Metadata Database was generated on...
3
7778
by: Jesse | last post by:
Hi all, I have a problem using wget and Popen. I hope someone can help. -- Problem -- I want to use the command: wget -nv -O "dir/cpan.txt" "http://search.cpan.org" and capture all it's stdout+stderr. (Note that option -O requires 'dir' to be existing before wget is executed) Popen doesn't work, while os.system and shell do. Popen will...
3
1710
by: TheWalWorker | last post by:
Hi everyone! I'm working on an RSA project that has to communicate with ASP.NET. Here's my problem: I'm following the code here: http://cpan.uwinnipeg.ca/htdocs/Crypt-RSA/Crypt/RSA.html This code by itself runs fine. However, when I start trying to push out the key to an external file (for later use of course) things start to get a little...
7
40945
by: chandru1782 | last post by:
Dear friends, I am trying to use CPAN for installing some perl modules. i am using a ubuntu system, which has internet connection through lan and authenticated proxy. when trying to install cpan.pm , it gives the following error, can any one help, You have no /root/.cpan/sources/MIRRORED.BY I'm trying to fetch one CPAN: LWP::UserAgent...
1
4323
by: spatro | last post by:
Hi, I am trying to install DBD::mysql using the CPAN and I am facing the following error: cpan> install DBD::mysql CPAN: Storable loaded ok Going to read /root/.cpan/Metadata Warning: Found only 0 objects in /root/.cpan/Metadata CPAN: LWP::UserAgent loaded ok
0
7362
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language...
0
7602
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. ...
0
7764
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that...
1
7368
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For...
0
5904
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then...
0
4911
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert...
0
3404
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
1
983
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.
0
657
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.