471,306 Members | 848 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,306 software developers and data experts.

Ora 1033 Error

Sir

Backend Oracle 9i
Front end VB.Net
O/s Windows 2003 Server

Server Crashed due to power failure

then the following error
displays when connect to oracle database

ORA 1033-Oracle intialization or shutdown in progress

I have search a lot of blogs But I have not yet get the suitable answer

Karikalacholan
[email removed - against site rules]
Oct 5 '07 #1
4 15102
debasisdas
8,127 Expert 4TB
The problem is because the instance of the databse has been shut down. At this time u can't log in,

Open SQL*Plus and connect sys as sysdba and start the database again to work with it.
or
start the services of Oracle Listener, Oracle Agent and the Oracleservice containint the SID of the database.
Oct 6 '07 #2
ora 1033

from your c:\ prompt type

sqlplus /nolog

from sqlplus prompt type

>connect /as sysdba

>shutdown

>startup mount

>alter database recover database until cancel;

if the above command fails try
>recover database using backup controlfile until cancel;"

on success type
>ALTER DATABASE OPEN RESETLOGS;

stop and restart oracle service

from

Andrew and Bixon the Ora Gurus
May 7 '09 #3
Hi

I had this error too and tried using the solution you told above. first command
sql> alter database recover database until cancel;
It didn't work and gave this error - ORA-00279: change 4736266 generated at 03/19/2011 09:06:24 needed for thread 1
ORA-00289: suggestion :

and then I gave second command
sql> recover database using backup controlfile until cancel;
and then I got this error
ORA-00275: media recovery has already been started

Now what should I do?

I am new to Oracle and have never worked on it before ...

Thanks in advance for your help.

PS- I had a virus in my computer few months back and I got it cleaned , is it something related to any program in my computer which is not running or had been deleted while removing the virus ?? As other basic stuff is not working after removing virus ... like audio and video system not working.
Apr 27 '11 #4
first off all check the status of your instance,its started or mount
,i guess its not open according to your post..by issue this comm
select status from v$instance;
if it is mount then try to open it by
alter databse open;


might be is there any problem with datafiles.
and check the alert log file ...tell me the detail info from the alter log file..so that i can figer out the actual problem
Sep 29 '11 #5

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

5 posts views Thread by Tony Wright | last post: by
1 post views Thread by =?Utf-8?B?a2VuIHM=?= | last post: by
3 posts views Thread by =?Utf-8?B?VmFuZXNzYQ==?= | last post: by
4 posts views Thread by naveenkongati | last post: by
reply views Thread by rosydwin | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.