By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,454 Members | 1,803 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,454 IT Pros & Developers. It's quick & easy.

Oracle to SQL Server using JDBC

P: n/a
I need to be able to connect Oracle to SQL Server using JDBC and
loadjava.

I have written a java class that I can execute on the platform fine. I
need to be able to put this into a wrapper in Oracle.

My problem is in the SQLServer.jar(or any) driver. None seem to work
in oracle.

Any help PLEASE!!!!

Jul 19 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
FOR ANYONE WITH THE SAME PROBLEM

After 2 days, I've finally been able to solve the problem. As I've
said in an earlier post, the error was happenening sometimes on load of
the driver. It said it couldn't resolve many of the classes within the
jar. This is the command I did to solve that

loadjava -user sys/password@system2 -resolve jtds-0.8.1.jar --I found
this from metalink user

I then had to run the following PL SQL Commands:

BEGIN
dbms_java.grant_permission('userName', 'SYS:java.net.SocketPermission',
'ServerName', 'resolve');
END;

BEGIN
dbms_java.grant_permission('WJWOLF', 'SYS:java.net.SocketPermission',
'000.000.000.000:1433', 'connect,resolve');
END;

It now works beautifully!!!

Jul 19 '05 #2

P: n/a
FOR ANYONE WITH THE SAME PROBLEM

After 2 days, I've finally been able to solve the problem. As I've
said in an earlier post, the error was happenening sometimes on load of
the driver. It said it couldn't resolve many of the classes within the
jar. This is the command I did to solve that

loadjava -user sys/password@system2 -resolve jtds-0.8.1.jar --I found
this from metalink user

I then had to run the following PL SQL Commands:

BEGIN
dbms_java.grant_permission('userName', 'SYS:java.net.SocketPermission',
'ServerName', 'resolve');
END;

BEGIN
dbms_java.grant_permission('userName', 'SYS:java.net.SocketPermission',
'000.000.000.000:1433', 'connect,resolve');
END;

It now works beautifully!!!

Jul 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.