469,090 Members | 1,124 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,090 developers. It's quick & easy.

error linking oci7 with oracle9i on AIX 4.3

I am having a problem linking an oci 7 application with oracle9i on
AIX 4.3.

The makefile has the following line:

-L/home/oracle/product/9.0.1/lib -lclntsh

This was working in oracle 8, however on oracle 9i, there are many
unresolved symbols:
orlon
oclose
oopen
oparse
ologoff
etc.

Are oci7 calls still supported under 9i? if so which libraries are
they located In?

any help would be greatly appreciated.

thanks
Hesam
Jul 19 '05 #1
1 2890
Hesam Shamshiri wrote:
I am having a problem linking an oci 7 application with oracle9i on
AIX 4.3.

The makefile has the following line:

-L/home/oracle/product/9.0.1/lib -lclntsh

This was working in oracle 8, however on oracle 9i, there are many
unresolved symbols:
orlon
oclose
oopen
oparse
ologoff
etc.

Are oci7 calls still supported under 9i? if so which libraries are
they located In?

I guess no, as SQL*Net for Oracle 7 is not working with
9i RDBMS; 8i SQL*Net does work with 9i RDBMS, though
any help would be greatly appreciated.

thanks
Hesam

--

Regards,
Frank van Bortel

Jul 19 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Kelly Carrigan | last post: by
reply views Thread by Oracle Instructor | last post: by
4 posts views Thread by Sanjay Kumar | last post: by
1 post views Thread by Hesam Shamshiri | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by kglaser89 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.