469,923 Members | 1,245 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,923 developers. It's quick & easy.

os_authent_prefix

Hi!

Where running Oracle database 9.2.0.1.0 on Sun Solaris 8 7/01 (SPARC
platform). I'm trying to use the OS authentication method for a user
owning objects in the database. I've started the instance with an
spfile with the os_authent_prefix='':

oracle@S0232119 # grep os spfileftgdb.ora
*.os_authent_prefix=''
oracle@S0232119 # pwd
/opt/oracle/product/9.2.0.1.0/dbs
oracle@S0232119 #

I've also create a user to be "identified externally" called ftgadm:

SQL> select username,password from dba_users where username =
'FTGADM';

USERNAME PASSWORD
------------------------------ ------------------------------
FTGADM EXTERNAL

Then when I login to Unix as ftgadm I still cant connect with only
"sqlplus /":

ftgadm@S0232119 # sqlplus /

SQL*Plus: Release 9.2.0.1.0 - Production on Tis Jul 6 23:33:47 2004

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

ERROR:
ORA-01034: ORACLE not available
ORA-27121: unable to determine size of shared memory segment
SVR4 Error: 13: Permission denied
Enter user-name:

Any ideas?

Regards Christian Eriksson
Jul 19 '05 #1
4 11529
c-*****@algonet.se (Christian Eriksson) wrote in message news:<d0**************************@posting.google. com>...
Hi!

Where running Oracle database 9.2.0.1.0 on Sun Solaris 8 7/01 (SPARC
platform). I'm trying to use the OS authentication method for a user
owning objects in the database. I've started the instance with an
spfile with the os_authent_prefix='':

oracle@S0232119 # grep os spfileftgdb.ora
*.os_authent_prefix=''
oracle@S0232119 # pwd
/opt/oracle/product/9.2.0.1.0/dbs
oracle@S0232119 #

I've also create a user to be "identified externally" called ftgadm:

SQL> select username,password from dba_users where username =
'FTGADM';

USERNAME PASSWORD
------------------------------ ------------------------------
FTGADM EXTERNAL

Then when I login to Unix as ftgadm I still cant connect with only
"sqlplus /":

ftgadm@S0232119 # sqlplus /

SQL*Plus: Release 9.2.0.1.0 - Production on Tis Jul 6 23:33:47 2004

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

ERROR:
ORA-01034: ORACLE not available
ORA-27121: unable to determine size of shared memory segment
SVR4 Error: 13: Permission denied
Enter user-name:

Any ideas?

Regards Christian Eriksson

Incorrect permissions on the Oracle directories and/or on the Oracle
executable or the setuid bit not set on the Oracle executable.
Connecting using an ordinary account will result in the same error.
This has nothing to do with O/S authentication.

Sybrand Bakker
Senior Oracle DBA
Jul 19 '05 #2
sy******@yahoo.com wrote in message news:<a1**************************@posting.google. com>...
c-*****@algonet.se (Christian Eriksson) wrote in message news:<d0**************************@posting.google. com>...
Hi!

Where running Oracle database 9.2.0.1.0 on Sun Solaris 8 7/01 (SPARC
platform). I'm trying to use the OS authentication method for a user
owning objects in the database. I've started the instance with an
spfile with the os_authent_prefix='':

oracle@S0232119 # grep os spfileftgdb.ora
*.os_authent_prefix=''
oracle@S0232119 # pwd
/opt/oracle/product/9.2.0.1.0/dbs
oracle@S0232119 #

I've also create a user to be "identified externally" called ftgadm:

SQL> select username,password from dba_users where username =
'FTGADM';

USERNAME PASSWORD
------------------------------ ------------------------------
FTGADM EXTERNAL

Then when I login to Unix as ftgadm I still cant connect with only
"sqlplus /":

ftgadm@S0232119 # sqlplus /

SQL*Plus: Release 9.2.0.1.0 - Production on Tis Jul 6 23:33:47 2004

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

ERROR:
ORA-01034: ORACLE not available
ORA-27121: unable to determine size of shared memory segment
SVR4 Error: 13: Permission denied
Enter user-name:

Any ideas?

Regards Christian Eriksson

Incorrect permissions on the Oracle directories and/or on the Oracle
executable or the setuid bit not set on the Oracle executable.
Connecting using an ordinary account will result in the same error.
This has nothing to do with O/S authentication.

Sybrand Bakker
Senior Oracle DBA


I don't know for shure what you mean by an ordinary account but:

ftgadm@S0232119 # sqlplus ftgweb@ftgdb

SQL*Plus: Release 9.2.0.1.0 - Production on Tor Jul 8 11:02:03 2004

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

Enter password:

Connected to:
Oracle9i Enterprise Edition Release 9.2.0.1.0 - 64bit Production
With the Partitioning, OLAP and Oracle Data Mining options
JServer Release 9.2.0.1.0 - Production

SQL> show user
USER is "FTGWEB"
SQL>

connecting as the user FTGWEB is possible.

Regards Christian Eriksson
Jul 19 '05 #3
GQ
c-*****@algonet.se (Christian Eriksson) wrote in message news:<d0**************************@posting.google. com>...
sy******@yahoo.com wrote in message news:<a1**************************@posting.google. com>...
c-*****@algonet.se (Christian Eriksson) wrote in message news:<d0**************************@posting.google. com>...
Hi!

Where running Oracle database 9.2.0.1.0 on Sun Solaris 8 7/01 (SPARC
platform). I'm trying to use the OS authentication method for a user
owning objects in the database. I've started the instance with an
spfile with the os_authent_prefix='':

oracle@S0232119 # grep os spfileftgdb.ora
*.os_authent_prefix=''
oracle@S0232119 # pwd
/opt/oracle/product/9.2.0.1.0/dbs
oracle@S0232119 #

I've also create a user to be "identified externally" called ftgadm:

SQL> select username,password from dba_users where username =
'FTGADM';

USERNAME PASSWORD
------------------------------ ------------------------------
FTGADM EXTERNAL

Then when I login to Unix as ftgadm I still cant connect with only
"sqlplus /":

ftgadm@S0232119 # sqlplus /

SQL*Plus: Release 9.2.0.1.0 - Production on Tis Jul 6 23:33:47 2004

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

ERROR:
ORA-01034: ORACLE not available
ORA-27121: unable to determine size of shared memory segment
SVR4 Error: 13: Permission denied
Enter user-name:

Any ideas?

Regards Christian Eriksson

Incorrect permissions on the Oracle directories and/or on the Oracle
executable or the setuid bit not set on the Oracle executable.
Connecting using an ordinary account will result in the same error.
This has nothing to do with O/S authentication.

Sybrand Bakker
Senior Oracle DBA


I don't know for shure what you mean by an ordinary account but:

ftgadm@S0232119 # sqlplus ftgweb@ftgdb

SQL*Plus: Release 9.2.0.1.0 - Production on Tor Jul 8 11:02:03 2004

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

Enter password:

Connected to:
Oracle9i Enterprise Edition Release 9.2.0.1.0 - 64bit Production
With the Partitioning, OLAP and Oracle Data Mining options
JServer Release 9.2.0.1.0 - Production

SQL> show user
USER is "FTGWEB"
SQL>

connecting as the user FTGWEB is possible.

Regards Christian Eriksson


You are not quite connecting the same way ... indicating that the
problem may be with the way you identify the database, and if it is
local or not.
Can you connect successfully without specifying the @SID (sqlplus
ftgweb<cr>).
Or try setting both ORACLE_SID and TWO_TASK (export TWO_TASK=<Oracle
SID>) before calling sqlplus.
If this doesn't work, confirm the value of ORACLE_SID (echo
$ORACLE_SID),
and confirm that it's a local database (tnsping $ORACLE_SID).
If it is on another server, then you must export TWO_TASK=$ORACLE_SID.

HTH
Guy.
Jul 19 '05 #4
db********@yahoo.com (GQ) wrote in message news:<aa**************************@posting.google. com>...
c-*****@algonet.se (Christian Eriksson) wrote in message news:<d0**************************@posting.google. com>...
sy******@yahoo.com wrote in message news:<a1**************************@posting.google. com>...
c-*****@algonet.se (Christian Eriksson) wrote in message news:<d0**************************@posting.google. com>...
> Hi!
>
> Where running Oracle database 9.2.0.1.0 on Sun Solaris 8 7/01 (SPARC
> platform). I'm trying to use the OS authentication method for a user
> owning objects in the database. I've started the instance with an
> spfile with the os_authent_prefix='':
>
> oracle@S0232119 # grep os spfileftgdb.ora
> *.os_authent_prefix=''
> oracle@S0232119 # pwd
> /opt/oracle/product/9.2.0.1.0/dbs
> oracle@S0232119 #
>
> I've also create a user to be "identified externally" called ftgadm:
>
> SQL> select username,password from dba_users where username =
> 'FTGADM';
>
> USERNAME PASSWORD
> ------------------------------ ------------------------------
> FTGADM EXTERNAL
>
> Then when I login to Unix as ftgadm I still cant connect with only
> "sqlplus /":
>
> ftgadm@S0232119 # sqlplus /
>
> SQL*Plus: Release 9.2.0.1.0 - Production on Tis Jul 6 23:33:47 2004
>
> Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.
>
> ERROR:
> ORA-01034: ORACLE not available
> ORA-27121: unable to determine size of shared memory segment
> SVR4 Error: 13: Permission denied
>
>
> Enter user-name:
>
> Any ideas?
>
> Regards Christian Eriksson
Incorrect permissions on the Oracle directories and/or on the Oracle
executable or the setuid bit not set on the Oracle executable.
Connecting using an ordinary account will result in the same error.
This has nothing to do with O/S authentication.

Sybrand Bakker
Senior Oracle DBA
I don't know for shure what you mean by an ordinary account but:

ftgadm@S0232119 # sqlplus ftgweb@ftgdb

SQL*Plus: Release 9.2.0.1.0 - Production on Tor Jul 8 11:02:03 2004

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

Enter password:

Connected to:
Oracle9i Enterprise Edition Release 9.2.0.1.0 - 64bit Production
With the Partitioning, OLAP and Oracle Data Mining options
JServer Release 9.2.0.1.0 - Production

SQL> show user
USER is "FTGWEB"
SQL>

connecting as the user FTGWEB is possible.

Regards Christian Eriksson


You are not quite connecting the same way ... indicating that the
problem may be with the way you identify the database, and if it is
local or not.
Can you connect successfully without specifying the @SID (sqlplus
ftgweb<cr>).

No!

ftgadm@S0232119 # sqlplus ftgadm

SQL*Plus: Release 9.2.0.1.0 - Production on Lör Jul 10 00:03:19 2004

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

Enter password:
Or try setting both ORACLE_SID and TWO_TASK (export TWO_TASK=<Oracle
SID>) before calling sqlplus. ftgadm@S0232119 # export TWO_TASK=ftgdb
ftgadm@S0232119 # env | grep TWO_TASK
TWO_TASK=ftgdb
ftgadm@S0232119 # sqlplus ftgadm

SQL*Plus: Release 9.2.0.1.0 - Production on Lör Jul 10 00:04:55 2004

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

Enter password:
ftgadm@S0232119 # sqlplus /

SQL*Plus: Release 9.2.0.1.0 - Production on Lör Jul 10 00:05:06 2004

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

ERROR:
ORA-01004: default username feature not supported; logon denied
Enter user-name: ^C If this doesn't work, confirm the value of ORACLE_SID (echo
$ORACLE_SID), ftgadm@S0232119 # echo $ORACLE_SID
ftgdb and confirm that it's a local database (tnsping $ORACLE_SID). ftgadm@S0232119 # tnsping $ORACLE_SID

TNS Ping Utility for Solaris: Version 9.2.0.1.0 - Production on
10-JUL-2004 00:06:16

Copyright (c) 1997 Oracle Corporation. All rights reserved.

Used parameter files:
/opt/oracle/product/9.2.0.1.0/network/admin/sqlnet.ora

Used TNSNAMES adapter to resolve the alias
Attempting to contact (DESCRIPTION = (ADDRESS_LIST = (ADDRESS =
(PROTOCOL = TCP)
(HOST = S0232119)(PORT = 1521))) (CONNECT_DATA = (SERVER = DEDICATED)
(SERVICE_NAME = ftgdb)))
OK (10 msec)

I'll guess the above does not resolve as a local database. Is that
required for OS authentication to work? If it is on another server, then you must export TWO_TASK=$ORACLE_SID.

HTH
Guy.


Regards Christian Eriksson
Jul 19 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

By using this site, you agree to our Privacy Policy and Terms of Use.