By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,569 Members | 1,422 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,569 IT Pros & Developers. It's quick & easy.

sqlplus "Input is too long (>2499 char)" error

P: n/a
I'm getting this error using sql plus
Input is too long (> 2499 characters) - line ignored

This is my command line on linux:
/home/oracle/product/8.1.6/bin/sqlplus -s loader/loader@ecrmdb
@/mp3/generated/listpullmon/sql/5485_de.sql

And I set line size in the file:

set pagesize 0
set heading off
set trimspool on
set term off
set feedback off
whenever sqlerror exit FAILURE;
spool /mp3/generated/ecrm/data_export/5485_20040414201752.txt
set linesize 12893
set escape on
Anything I should do?
Jul 19 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I found this, but how would I do this on Linux??
Solution Description
--------------------

Open the file in a text editor and then resave the
file as a different file type. In Microsoft Word,
you click on File, Save As, then select file type
'text only with line breaks' and save the file. Once
this is done, you can successfully run the script
from SQL*Plus or Server Manager.

Explanation
-----------
The output file that comes directly from SQLBacktrack
doesnot have the proper type of carriage returns that
SQL*Plus or Server Manager recognizes. As a result,
the SQL statement is read by SQL*Plus or Server
Manager as being all on one line and you get the above
error message. Once you save the file as 'text only
with line breaks' it reformats the carriage returns in
the file so that SQL*Plus or Server Manager can
recognize it and run the statement successfully.

"Krusty276" <da*******@hotmail.com> wrote in message
news:f8******************************@news.meganet news.com...
I'm getting this error using sql plus
Input is too long (> 2499 characters) - line ignored

This is my command line on linux:
/home/oracle/product/8.1.6/bin/sqlplus -s loader/loader@ecrmdb
@/mp3/generated/listpullmon/sql/5485_de.sql

And I set line size in the file:

set pagesize 0
set heading off
set trimspool on
set term off
set feedback off
whenever sqlerror exit FAILURE;
spool /mp3/generated/ecrm/data_export/5485_20040414201752.txt
set linesize 12893
set escape on
Anything I should do?

Jul 19 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.