By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,502 Members | 1,878 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,502 IT Pros & Developers. It's quick & easy.

data base link

P: n/a
I have oracle 8.1.7.
the tnsnames.ora is ok .
With the connect function I can connect to the remote database.
BUT when I use the create database link command then it goes wrong.

I can create the database link but when I try a simple select * from
....@databaselink , I
recieve following error : tns servicename could not be resolved.

But that is not true because I configured the tnsnames.ora well and that
works.

Could it be the the database link uses another file then tnsnames.ora ?

How could I fix this problem?
rgds
Gerry

Jul 19 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Search wrote:
I have oracle 8.1.7.
the tnsnames.ora is ok .
With the connect function I can connect to the remote database.
BUT when I use the create database link command then it goes wrong.

I can create the database link but when I try a simple select * from
...@databaselink , I
recieve following error : tns servicename could not be resolved.

But that is not true because I configured the tnsnames.ora well and that
works.

Could it be the the database link uses another file then tnsnames.ora ?

How could I fix this problem?
rgds
Gerry

Your tnsnames is NOT ok - you are looking at the wrong
one (assumption made - not enough details).
Check your tnsnames on the SERVER, not the client

--

Regards,
Frank van Bortel

Jul 19 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.