By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,501 Members | 1,861 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,501 IT Pros & Developers. It's quick & easy.

Mandrake Oracle 9i Installation Problems (netmgr, netca)

P: n/a
Si
Hi,

I am having trouble with an install of Oracle 9i Release 2 on Linux
Mandrake 9.1. I have 512 MB DDR RAM and a Duron 850 CPU.

The install appeared to run fairly seamlessly except for a handful of
problems :

1) Oracle complained that it could not set the file permissions on
four files. They were

/u01/app/oracle/jre/1.3.1/bin/.java_wrapper
/u01/app/oracle/jre/1.1.8/bin/.java_wrapper
/u01/app/oracle/jre/1.1.8/bin/i686/green_threads/.extract_args
/u01/app/oracle/jre/1.1.8/bin/i686/native_threads/.extract_args

None of the four files were present and so I created empty files to
force the installation to continue (was this the seed of my
downfall?).

2) During the linking stage, Oracle reported the following error :

"Error in invoking target install of makefile [whatever the path
was]/ins_ctx.mk"

I fixed this by adding "${LDLIBFLAG} dl" to the line in the
"$ORACLE_HOME/ctx/lib/env_ctx.mk" that began "INSO_LINK=".
(I got that solution off the web)

The installation and linking completed successfully. However, when the
installer tried to start the four services that it does at the end of
the installation, three of them failed :

a) Oracle Net Configuration Assistant appeared as "cancelled".
b) Agent Configuration Assistant appeared as "cancelled".
c) The HTTP server came up with the error :

"Configuration tool Starting HTTP Server failed
Syntax error on line 92 of
/home/oracle/OraHome1/sqlplus/admin/isqlplus.conf:
FastCgiServer: redefinition of a previously defined FastCGI server
"/home/oracle/OraHome1/bin/isqlplus"
/home/oracle/OraHome1/Apache/Apache/bin/apachectl startssl: httpd
could not be started"

Nevertheless, I completed the installation to see if I could run the
failed tools from the command line and determine what was wrong. I
have tried runing netmgr, netca, oidadmin and in evry case they just
return to the command prompt without, apparently, doing anything. I
had a look at the netmgr code (shell script) and at the bottom it
executes the java VM on a particular file. However, the Java VM is
stored in the variable $JRE. I tried installing the Sun JRE 1.4.2 and
altering $JRE to "java" in the netmgr file. I then executed netmgr
again and it appeared to be doing something (albeit without output)
when it crashed with a Java Exception (see link below).

I am guessing that the Java VM is at the root of my problems but I do
not have the knowledge to confidently take this investigation any
further without trashing what could possibly be a salvagable install.

Incidentally, although Mandrake is an unusual platform to install
Oracle on, I have successfully done it before but this time I have a
freshly installed OS and so perhaps there are parts of the OS not
installed now that were present the last time I did this (mind you, it
was a nightmare that time as well :-) ).

I have posted the full log file at :
http://www.sicom-systems.co.uk/oracl...03-02PM.log.gz

and the java exception details at :
http://www.sicom-systems.co.uk/oracl...eption_details

Thanks in advance for your help,

Simon Oldham
<si**********@sicom-systems.co.uk>
Jul 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.

Browse more Oracle Database Questions on Bytes