By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,463 Members | 3,115 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,463 IT Pros & Developers. It's quick & easy.

Oracle 9i Qs: URL contains extra characters and how to maximize servelet

P: n/a
Q1. Whenever I run my form, it starts MSIE OK, but puts the characters
http://%%20" in front of the URL, like this:

http://%%20"http://W18670:8888/forms90/f90servlet?form=C:\ANPR\Source_v2\Forms\Frmmain&us erid=user/password@database&buffer_records=NO&debug_messages =NO&array=YES&query_only=NO&quiet=NO&RENDER=YES"

Every time I run the form, I have to delete these 12 characters from
the front of the URL and hit enter and it runs fine. Why? I have
checked all the set up options I can find, and I have searched the
registry and in every Oracle file on the system for 'http:/' and I
can't find it anywhere.

Can anybody suggest some things to try?

Q2. When the Java servelet runs, there is a grey bar across the top of
the applet with the Oracle logo on the right hand side. Some of my
forms are bigger than the applet window, in which case I get scroll
bars. Does anybody know whether I can maximize the applet to take up
the full web browser screen? Alternatively, can I run the servlet not
using MSIE but just in a window?

I have been trying to find some good books on Forms 9i or information
on the net. Can anybody recommend some resources? I have the Oracle
Press Oracle 9i Complete Reference, but it only covers SQL and PL/SQL
which is not so much use to me. There doesn't seem to be much around
eg. on Amazon about Forms 9i.

Thank you very much for any help you can give.
Jul 19 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
go****@m-streeter.demon.co.uk (Michael) wrote in message news:<a8*************************@posting.google.c om>...
Q1. Whenever I run my form, it starts MSIE OK, but puts the characters
http://%%20" in front of the URL, like this:

http://%%20"http://W18670:8888/forms90/f90servlet?form=C:\ANPR\Source_v2\Forms\Frmmain&us erid=user/password@database&buffer_records=NO&debug_messages =NO&array=YES&query_only=NO&quiet=NO&RENDER=YES"

Every time I run the form, I have to delete these 12 characters from
the front of the URL and hit enter and it runs fine. Why? I have
checked all the set up options I can find, and I have searched the
registry and in every Oracle file on the system for 'http:/' and I
can't find it anywhere.

Can anybody suggest some things to try?


I should add to what I have put above that I have the form open in
Oracle Forms Builder to begin with. I am pressing F5 (or click on
Programs, Run Form) in order to run it, and that is how MSIE gets
started.

Thanks for any help.
Jul 19 '05 #2

P: n/a
Q1: unknown

Q2: Try the following

in formsweb.cfg file in /OraHome1/Form90/server Directory.
-width is 720
-height is 700
adapt these parameter & bounce Apache (start & stop)

Regards,
Cedric Vonck
go****@m-streeter.demon.co.uk (Michael) wrote in message news:<a8*************************@posting.google.c om>...
Q1. Whenever I run my form, it starts MSIE OK, but puts the characters
http://%%20" in front of the URL, like this:

http://%%20"http://W18670:8888/forms90/f90servlet?form=C:\ANPR\Source_v2\Forms\Frmmain&us erid=user/password@database&buffer_records=NO&debug_messages =NO&array=YES&query_only=NO&quiet=NO&RENDER=YES"

Every time I run the form, I have to delete these 12 characters from
the front of the URL and hit enter and it runs fine. Why? I have
checked all the set up options I can find, and I have searched the
registry and in every Oracle file on the system for 'http:/' and I
can't find it anywhere.

Can anybody suggest some things to try?

Q2. When the Java servelet runs, there is a grey bar across the top of
the applet with the Oracle logo on the right hand side. Some of my
forms are bigger than the applet window, in which case I get scroll
bars. Does anybody know whether I can maximize the applet to take up
the full web browser screen? Alternatively, can I run the servlet not
using MSIE but just in a window?

I have been trying to find some good books on Forms 9i or information
on the net. Can anybody recommend some resources? I have the Oracle
Press Oracle 9i Complete Reference, but it only covers SQL and PL/SQL
which is not so much use to me. There doesn't seem to be much around
eg. on Amazon about Forms 9i.

Thank you very much for any help you can give.

Jul 19 '05 #3

P: n/a
va**********@ping.be (Cedric Vonck) wrote in message news:<71**************************@posting.google. com>...
Q1: unknown
<snip>
Regards,
Cedric Vonck
Thanks very much, Cedric, your solution works perfectly.


go****@m-streeter.demon.co.uk (Michael) wrote in message news:<a8*************************@posting.google.c om>...
Q1. Whenever I run my form, it starts MSIE OK, but puts the characters
http://%%20" in front of the URL, like this:


OK, I have the answer to that one:
In Oracle Forms, click on Edit, Preferences.
Click on the Runtime tab and completely specify
the Application Server URL (e.g. http://W18670:8888/forms90.f90servlet)
and the Web Browser Location (e.g. C:\Program Files\Internet Explorer\IEXPLORE.EXE).
Jul 19 '05 #4

P: n/a
No problemo mate! :-)
Btw, I looked this up at Metalink.
Unfortunately I cannot distributed my login // pwd or my company could
loose his oracle support.

If you have any questions, don't hesitate to post them!.

I have thought a bit about Q1:
I think that is related to IE.
Login as Administrator
goto the dos prompt
cd "Documents and settings"
cd "<user>"
cd "Local Settings"

delete "History" & Temporary Internet Folder

and reboot.

You have also be carefull with the directory you put your forms in!!
Make sure that there are NO spaces tabs or other control characters
in..
Otherwise you will bump into another 9000 error.

And thirdly, if you wish to use the forms in another language, like
me, in Dutch.

Go to the register,
Go the Oracle Home of Forms
Add or adapt the NLS_LANGUAGE parameter
Reboot is prefferred.

Fourthly,
To work convienently with menus, you have to set the correct path
to your forms directory:

Register
Oracle Home of forms
Add or adapt the following parameter: forms_path
edit the key and reboot (always be on the safe side)

forms_path => c:\oracle.....\;c:\my_forms_directory

go****@m-streeter.demon.co.uk (Michael) wrote in message news:<a8**************************@posting.google. com>...
va**********@ping.be (Cedric Vonck) wrote in message news:<71**************************@posting.google. com>...
Q1: unknown

<snip>

Regards,
Cedric Vonck


Thanks very much, Cedric, your solution works perfectly.


go****@m-streeter.demon.co.uk (Michael) wrote in message news:<a8*************************@posting.google.c om>...
Q1. Whenever I run my form, it starts MSIE OK, but puts the characters
http://%%20" in front of the URL, like this:


OK, I have the answer to that one:
In Oracle Forms, click on Edit, Preferences.
Click on the Runtime tab and completely specify
the Application Server URL (e.g. http://W18670:8888/forms90.f90servlet)
and the Web Browser Location (e.g. C:\Program Files\Internet Explorer\IEXPLORE.EXE).

Jul 19 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.