By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,501 Members | 1,861 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,501 IT Pros & Developers. It's quick & easy.

Help requested ! Protocol Adapters Missing oracle 9i...

P: n/a
Greetings Everyone:

Oracle 9i installed on a sun solaris box. No protocol adapters
available.
I would greatly appreciate any help from the db gurus on this forum.

after bringing up the database, i am using the netca (Oracle Net
Services Configuration assistant). When i try to create a listener and
configure the protocol for that listener, i do not see any available
protocols (the available protocols box is empty!!) but, the selected
protocols box/list shows TCP. so anyway i go ahead and use the TCP to
create a listener. next i select the local net service name
configuration and try to add a net service name, and again the there
are no available protocols to select from.

when i issue a 'adapters' command in the OraHome1 directory i get this
result:

Installed Oracle Net transport protocols are:

IPC
BEQ
TCP/IP
SSL
RAW

Installed Oracle Net naming methods are:

Local Naming (tnsnames.ora)
Oracle Directory Naming
Oracle Host Naming
Oracle Names Server Naming
NIS Naming

and when i issue a 'adapters sqlplus' the result is :

Oracle Net transport protocols linked with sqlplus are:
Oracle Net naming methods linked with sqlplus are:
Although i am very new in this DB admin area, after googling I *think*
that the protocols are installed properly. Can someone please help me
to figure out why the protocols do not show up for selection when i
try to configure a protocol for a listener and again when i try to add
a service name to that listener.

I will greatly appreciate any help/hints/suggestions/advice in this
regard.
Jul 19 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Crowe wrote:
Greetings Everyone:

Oracle 9i installed on a sun solaris box. No protocol adapters
available.
I would greatly appreciate any help from the db gurus on this forum.


I've been doing DBA duties on Solaris for the last 5+ years.
I have NEVER used netca.

I start with a working listener.ora file (as below)
and then modify it as necessary for any new system.

###########
# FILENAME: listener.ora
# SERVICE.: TCP LISTENER
###########
#
LISTENER =
(ADDRESS_LIST =
(ADDRESS =
(PROTOCOL = TCP)
(HOST = prod)
(PORT = 1529)
)
)

SID_LIST_LISTENER =
(SID_LIST =
(SID_DESC =
(SID_NAME = MWH)
(ORACLE_HOME=/u01/app/oracle/product/7.3.4)
(ENVS='EPC_DISABLED=TRUE')
)
(SID_DESC =
(SID_NAME = STG)
(ORACLE_HOME=/u01/app/oracle/product/7.3.4)
(ENVS='EPC_DISABLED=TRUE')
)
(SID_DESC =
(ORACLE_HOME= /u01/app/oracle/product/9.0.1)
(SID_NAME = WRK)
)
(SID_DESC =
(ORACLE_HOME= /u03/app/oracle/product/9.2.0)
(SID_NAME = HDCR)
)
(SID_DESC =
(ORACLE_HOME= /u01/app/oracle/product/9.0.1)
(SID_NAME = CTI)
)
)
HTH & YMMV

Jul 19 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.