By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,456 Members | 1,742 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,456 IT Pros & Developers. It's quick & easy.

816 proC on debian linux; mathcalls.h issue?

P: n/a
ehlo all

I'm trying to compile an app over from sol26 to a recent debian x86
system and I'm not having much luck with getting the precompiler to
build some logic we require.

I've seen posts of similar issues with an apparent fix from metalink or
from suse's oracle docs. Our dba won't share her metalink login w/ me
and the suse doc seems to be long gone.

Basically the system has issues with mathcalls.h which in an archived
post was fixed with this magical pcscfg.cfg from suse or metalink.

config:

debian stable, gcc version 2.95.4, binutils 2.14.90, oracle's stub
glibc libs and it's 816 as you can see from the proC output below.

errors:

-[derrick@Rater8:~/Phase1b/zone/Rater 1 $]-
/home/oracle/app/oracle/product/816/bin/proc SQLCHECK=FULL
USERID=xxxx/xxxx dbms=v6_char iname=rdt_copy.pc

Pro*C/C++: Release 8.1.6.0.0 - Production on Tue Nov 25 15:52:01 2003

(c) Copyright 1999 Oracle Corporation. All rights reserved.

System default option values taken from:
/home/oracle/app/oracle/product/816/precomp/admin/pcscfg.cfg

PCC-W-02110, DBMS=V6_CHAR is deprecated. Use CHAR_MAP=VARCHAR2, DBMS=V7
instead
Syntax error at line 55, column 1, file /usr/include/bits/mathcalls.h:
Error at line 55, column 1 in file /usr/include/bits/mathcalls.h
__MATHCALL (acos,, (_Mdouble_ __x));
1
PCC-S-02201, Encountered the symbol "f" when expecting one of the
following:

; , = ( [

Syntax error at line 55, column 1, file
/usr/include/bits/mathcalls.h:
Error at line 55, column 1 in file /usr/include/bits/mathcalls.h
__MATHCALL (acos,, (_Mdouble_ __x));
1
PCC-S-02201, Encountered the symbol "f" when expecting one of the
following:

; , = ( [

[many similar snipped]

PCC-S-02201, Encountered the symbol "f" when expecting one of the
following:

; , = ( [
The symbol "," was substituted for "f" to continue.

Segmentation fault
-[derrick@Rater8:~/Phase1b/zone/Rater 139 $]-
-[derrick@Rater8:~/Phase1b/zone/Rater 1 $]- cat
/home/oracle/app/oracle/product/816/precomp/admin/pcscfg.cfg
sys_include=($ORACLE_HOME/precomp/public,
$ORACLE_HOME/precomp/syshdr,
/usr/lib/gcc-lib/i386-linux/2.95.4/include,
/usr/include)
include=($ORACLE_HOME/precomp/public)
include=($ORACLE_HOME/precomp/syshdr)
include=($ORACLE_HOME/rdbms/demo)
include=($ORACLE_HOME/rdbms/public)
include=($ORACLE_HOME/network/public)
include=($ORACLE_HOME/plsql/public)
ltype=short

(sys_include line wrapped to aide readability)

if anyone has any idea how I can get this recognized, I'd sincerely
appreciate it.

Thanks for your time,
^Derrick

--
I like patterns
Jul 19 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
for the archives....

* Derrick D. Daugherty <or*********@blinky-lights.org>:
ehlo all
[snip]
I've seen posts of similar issues with an apparent fix from metalink or
from suse's oracle docs. Our dba won't share her metalink login w/ me
and the suse doc seems to be long gone.

Basically the system has issues with mathcalls.h which in an archived
post was fixed with this magical pcscfg.cfg from suse or metalink.
[snip]
-[derrick@Rater8:~/Phase1b/zone/Rater 1 $]- cat
/home/oracle/app/oracle/product/816/precomp/admin/pcscfg.cfg
sys_include=($ORACLE_HOME/precomp/public,
$ORACLE_HOME/precomp/syshdr,
/usr/lib/gcc-lib/i386-linux/2.95.4/include,
/usr/include)
include=($ORACLE_HOME/precomp/public)
include=($ORACLE_HOME/precomp/syshdr)
include=($ORACLE_HOME/rdbms/demo)
include=($ORACLE_HOME/rdbms/public)
include=($ORACLE_HOME/network/public)
include=($ORACLE_HOME/plsql/public)
ltype=short

(sys_include line wrapped to aide readability)


yeeesh, finaly found a clue in a german post. the pcscfg.cfg won't expand
the variables out. so you can't use $ORACLE_HOME, it must be the full
path. this did the trick. (sys_include should be all one line)

-[oracle@Rater8:~/app/oracle/product/816/precomp/admin $]- cat
pcscfg.cfg
sys_include=(/home/oracle/app/oracle/product/816/precomp/syshdr,
/home/oracle/app/oracle/product/816/precomp/public,
/usr/lib/gcc-lib/i386-linux/2.95.4/include, /usr/include,
/usr/include/linux)
include=(/home/oracle/app/oracle/product/816/precomp/public)
include=(/home/oracle/app/oracle/product/816/precomp/syshdr)
include=(/home/oracle/app/oracle/product/816/rdbms/demo)
include=(/home/oracle/app/oracle/product/816/rdbms/public)
include=(/home/oracle/app/oracle/product/816/network/public)
include=(/home/oracle/app/oracle/product/816/plsql/public)
ltype=short

take care,
^D

--
I like patterns
Jul 19 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.