By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,323 Members | 1,216 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,323 IT Pros & Developers. It's quick & easy.

Oracle Intermedia / Image Import

P: n/a
Hello.

I'm having trouble importing images. I have the following procedure :

declare
Image ORDSYS.ORDImage;
ctx RAW(4000) := null;

begin
insert into bilde_test values (
4, null, ORDSYS.ORDImage.init(), ORDSYS.ORDImageSignature.init());

SELECT PHOTO into Image FROM bilde_test WHERE photo_id = 4 for update;

Image.SetSource('file', 'LARSDIR', 'logo_phpBB.gif');
Image.importFrom(ctx, 'file', 'LARSDIR', 'logo_phpBB.gif');

UPDATE bilde_test SET photov = Image where photo_id = 4;
commit;
End;

When I try to execute the procedure, I get the following error report.
(It's in Norwegian, so I've tried to translate the norwegian text) :

declare
*
ERROR on linj 1:
ORA-06510: PL/SQL: untreated useddefined exception
ORA-06512: at "ORDSYS.ORDSOURCE", line 266
ORA-22288: file- or LOB-operation FILEOPEN failed
The data is invalid.
ORA-06512: at "ORDSYS.ORDIMG_PKG", line 701
ORA-06512: at "ORDSYS.ORDIMAGE", line 223
ORA-06512: at line 12

---
I've tried several other procedures, with the same result. Seems like
the trouble occurs around the "import" statement.

Jul 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.