469,090 Members | 1,085 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,090 developers. It's quick & easy.

I cannot install emca anymore on oradb10g which runs o.k. after upgrade mac osX 10.4.2

max
RDBMS Version:: 10.1.0.3.0
Operating System and Version:: MAC OS X 10.4.2
Product Version:: ORACLE Db10g Version 10.1.0.3.0
OEM Console Operating System and Version::

I cannot install emca anymore on my database which runs o.k.
emca -x dataqual

I did erase the enterprisemanager and tried to reinstall it again.

Is there another way to manage the oracle instance on my MAC graphically?

I cannot install the emctl anymore on my database .I always get the
following error
messages:
-----
bossa-nova:~ oracle$ emca -f emca.config

STARTED EMCA at Tue Sep 06 11:48:01 CEST 2005
Password for dbsnmp:
Password for sysman:
Password for sys: :
Password for sys:
java.lang.UnsatisfiedLinkError: no OsUtils in java.library.path
at java.lang.ClassLoader.loadLibrary(ClassLoader.java :1517)
at java.lang.Runtime.loadLibrary0(Runtime.java:788)
at java.lang.System.loadLibrary(System.java:834)
at oracle.sysman.assistants.util.OsUtilsUnix.<init>(O sUtilsUnix.java:659)
at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInsta nce
(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance
(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Construc tor.java:274)
at java.lang.Class.newInstance0(Class.java:308)
at java.lang.Class.newInstance(Class.java:261)
at
oracle.sysman.assistants.util.OsUtilsBase.construc tInstance(OsUtilsBase.java
:1362)
at
oracle.sysman.assistants.util.OsUtilsBase.getOsUti ls(OsUtilsBase.java:134)
at
oracle.sysman.assistants.util.sqlEngine.SQLEngine. getEnvParams(SQLEngine.jav
a:
402)
at
oracle.sysman.assistants.util.sqlEngine.SQLEngine. initialize(SQLEngine.java:
229)
at
oracle.sysman.assistants.util.sqlEngine.SQLEngine. <init>(SQLEngine.java:214)
at
oracle.sysman.assistants.util.sqlEngine.SQLPlusEng ine.<init>(SQLPlusEngine.j
ava:
104)
at
oracle.sysman.assistants.util.sqlEngine.SQLEngine. getSQLEngine(SQLEngine.jav
a:
358)
at oracle.sysman.emcp.EMConfig.initSQLEngine(EMConfig .java:5608)
at oracle.sysman.emcp.EMConfig.checkConfiguration(EMC onfig.java:1022)
at oracle.sysman.emcp.EMConfig.perform(EMConfig.java: 263)
at
oracle.sysman.emcp.EMConfigAssistant.invokeEMCA(EM ConfigAssistant.java:691)
at
oracle.sysman.emcp.EMConfigAssistant.performSetup( EMConfigAssistant.java:640
)
at
oracle.sysman.emcp.EMConfigAssistant.statusMain(EM ConfigAssistant.java:339)
at oracle.sysman.emcp.EMConfigAssistant.main(EMConfig Assistant.java:179)

my emctl.config file looks like:

bossa-nova:~ oracle$ cat emca.config
PORT=1521
SID=dataqual
HOST=localhost
DBSNMP_PWD=mysekretpassword
SYSMAN_PWD=mysekretpassword

-----------
before my upgrade to osX 10.4 it did work.

Any idea?
maximilian
Sep 6 '05 #1
1 6716
HI,

I am Darshan,

I am getting the same error while running dbca.

no OsUtils in java.library.path


Pls help me if you got the solution

my email is darshan_mungekar@rediffmail.com

thanks,bye
Oct 13 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by Leslie Lim | last post: by
reply views Thread by Paul Nguyen | last post: by
3 posts views Thread by Mark Oliver | last post: by
1 post views Thread by LEE | last post: by
3 posts views Thread by Anthony Smith | last post: by
reply views Thread by Erwin Moller | last post: by
reply views Thread by kglaser89 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.