471,076 Members | 1,264 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,076 software developers and data experts.

Question about installing wireless router for new laptop to existing cable modem

Hi - I just bought an Asus laptop with wireless capabilities. I have a desktop that I've used for years that is hooked up to Cox cable for high speed internet through a Motorola SG5120 cable modem. The modem is ethernet / USB compatible, but it currently hooks to my desktop with a USB cable.

I bought a Linksys wireless router last night and tried to install. The first problem was that I couldn't hook the USB cable from the desktop computer into the Ethernet port on the router. I tried hooking the ethernet cable from router to computer, and another cable from router to modem - but nothing was recognized. I tried all sorts of configurations - ethernet from laptop to router then router to modem, modem to new laptop, etc. I couldn't get the router to register on the laptop or the desktop.

Should I buy a USB adapter so I can hook the computer to into the router? And how should the laptop work to be wireless? Do I set up the router with the desktop?

I'm sorry - I'm a novice as you can tell. Any help is greatly appreciated.

Jan 11 '10 #1
3 3416
4,677 Expert Mod 4TB
What OS is your desktop? If it's WinXP you can enable Internet Connection Sharing, and probably hook it up through there, though I've only seen that done with chained PC's - not with access points. It might be a bit difficult to configure.

If you have the Ethernet cable, why not connect the access point to the modem? Are you lacking a second cable for the wired connection to the PC?

Ideally, it should go (starting from the internet) cable modem, access point, and then the wired and wireless connections will connect to the access point.

Have you tried it that way? If so, what was the issue?
Jan 11 '10 #2
Hi - thanks for the reply. I have Windows 7 Pro. Last night I took home another Ethernet cable (yes I was lacking the other to make 2). So it went from the wall to the modem (coaxial cable) then Ethernet cable from Modem to Router (tried both Ethernet port and Internet Port) and Ethernet cable from Router into Laptop. Strangely, the only time the internet registered on the router is when the computer was plugged into the Internet port - and the Ethernet port went into the modem. Now I'm wondering if it has something to do with the IP address the modem knows from the existing desktop. It seems like such a simple connection but it's been so hard to connect. The desktop only communicates with the modem via USB connection - so I can't simply take out the connection from the computer and put into the router - like they tell you in the first step. Thanks again for your time!
Jan 12 '10 #3
7,435 Expert 4TB
You were doing it correctly. wall->cable->modem->ethernet->router->desktop.

Let's get this working first. The trickiest part that usually solves all these problems is resetting everything once it's connected and the order of doing so. 1) Turn everything off 2) Turn on the modem 3) Wait one minute 4) Turn on the router 5) Wait one minute 6) Turn on the computer 7) On Windows, wait forever.

Windows doesn't poll the network connections constantly so it takes a while for it to discover the network if it hasn't found it in the past. I've seen this take 5 minutes on XP and Vista, too, I think.

Again, the order of reset is important as is the waiting for everything to discover each other.
Jan 12 '10 #4

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

21 posts views Thread by joelbyrd | last post: by
2 posts views Thread by Luke | last post: by
1 post views Thread by Strider1066 | last post: by
reply views Thread by leo001 | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.