468,554 Members | 1,418 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,554 developers. It's quick & easy.

Connecting a PoE device to the Internet using a USB Modem

Hello all,

I have a USB modem stick and a PoE network device. I want to connect the device to the Internet using the USB stick. The device has no other interfaces, so I must use its RJ-45 port. I tried The following:

Plugged the device into a PoE injector on the data-out port and using a USB-to-Ethernet adapter I connected the USB stick onto the data-in port of the injector.

This has failed. The USB stick doesn't even light up.

Could you please help me with this?

Thank in advance.
Dec 12 '09 #1
4 4078
Banfa
9,056 Expert Mod 8TB
USB devices generally pull power from the USB port but it sounds like you aren't plugging the USB device into a USB port.

Which USB device is it? Does its technical specification indicate that it can be powered via its Enternet port?
Dec 12 '09 #2
Yes I am not plugging it into a USB port. I tried to plug it into each other following (through a USB-to-Ethernet adapter):

- the data-in port of the PoE injector
- computer NIC
- PoE switch port

I thought it might work in the first two cases because of the adapter but it didn't. In the third case, because it is connected to a PoE, power seemed not the problem. But I guess it is a problem now.

The USB modem is ZTE MF636 USB modem. The other PoE device is a network camera. The camera is only powered on by PoE. There is no other way to power it on.
Dec 12 '09 #3
Banfa
9,056 Expert Mod 8TB
If your only pieces of hardware are

1 ZTE MF636 USB 3G/GPRS modem
1 PoE Injector (to put power onto the Ethernet cable)
1 Network Camera using PoE for power

It sounds like you are trying to wirelessly connect your IP camera to a network (or make it available.

However you are don't going to be able to do it with this equipment, the ZTE MF636 is designed for connecting laptops (to desktops) wirelessly to the internet. The laptop has aUSB stack and a driver for the ZTE MF636, none of the pieces of equipment you have have a USB stack and even if they do they certainly don't have a ZTE MF636 driver.

You are trying to connect several peripherals together with no computer but on the whole USB peripherals are unusable without a computer containing drivers (except for memory sticks).

You probably need something like HR4110 from Digi. Although they are not cheap (200 - 300) so you may want to hunt around for something cheaper.

If your PoE switch port has a USB port then it is likely that it is for firmware upgrades and only supports USB memory sticks unless the data sheet/user manual for the product says differently.
Dec 12 '09 #4
Thank you so much, Banfa. I appreciate it. I concluded so too. If the ZTE MF636 was writeable/programmable, I would have injected a USB stack. But I don't think so. Please correct me if I am wrong. I have browsed the page you sent me. Thank you for that too. I am after industrial equipment, it looks like Digi's stuff are from how they look but I need to read the specs.

Thank you very much
Dec 12 '09 #5

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

1 post views Thread by Mark Smith | last post: by
reply views Thread by Mark Smith | last post: by
1 post views Thread by Paras Sharma | last post: by
reply views Thread by Paul Johnson | last post: by
3 posts views Thread by chethana | last post: by
reply views Thread by coaxfiber | last post: by
1 post views Thread by UniDue | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.