469,964 Members | 1,712 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,964 developers. It's quick & easy.

Ping local computers by name fails - tried all the common things

4
So...here we go. I'm having an issue with one computer on a network not being able to ping other computers by name. I've spent the last day searching similar issues and I've tried all the steps recommended. If anyone has some suggestions, I'd love to give them a try - this is driving me nuts!!

I am connected via wired-LAN to a Linksys WRT-600N router; there are 4 other computers on the network. The other 3 computers are working perfectly - they can browse the network neighborhood and ping other computers by name.

The problem computer is set to the same workgroup and cannot browse My Network Places ("Workgroup is not accessible") and cannot ping the others by name. When I try, I receive "Ping request could not find host COMPUTER1. Please check the name and try again." It does not even attempt a ping. It can, however, ping by IP address. I can also ping internet sites by name and it correctly resolves to the IP address.

Here's some info, and steps that I've tried:

1. The TCP/IP settings are set exactly like the other computers (DHCP, default NETBIOS setting, and Enable LMHosts is checked).

2. The HOSTS file is present and contains only the typical single entry (as do the others)

3. I have tried "Enable NETBIOS over TCP/IP" with no luck

4. I have tried static settings with no luck

5. I have done a full virus scan and spyware scan and everything is clean. The computer also has no other "weird" issues.


That's all I can think of. Any help would be really appreciated. Thank you!

-Brian
Mar 2 '09 #1
6 3895
ShaneA
19
What OS are you running?

I am going to assume it is XP.

This might sound like a stupid question but have you tried changing the workgroup and then changing it back?

If you have and it still does not work i would flush the DNS.
The command should be as follows: ipconfig/flushdns

I hope this works for you!
Mar 2 '09 #2
belias
4
Hi - thanks for the suggestion. I tried both suggestions (with reboots) and no success.

Any other ideas?

Thank you!
Mar 2 '09 #3
belias
4
Solved! So...I downloaded a utility called browstat.exe and it was reporting no master browser could be found. In addition, IPCONFIG was reporting a node type of "Peer-Peer". A bit of Googling led me to this KB article:

http://support.microsoft.com/kb/903267/

I made the registry change and it now works once a again.

Any idea on how this could have changed?

Thanks!
Mar 2 '09 #4
ShaneA
19
That is actually very interesting, thank you for imputing your solution.

The only thing i can think of that would make sense to me is if you ran a registry repair from 3rd party software or a malicious intrusion occurred that manipulated the registry.

Either way I'm glad you got the problem fixed, sorry i was of no assistance.
Mar 2 '09 #5
belias
4
You might be on to something...I ran TuneUp utilities a few days back. That might have been it....
Mar 3 '09 #6
ShaneA
19
That sounds like what happened. When you run the tune-up type of utilities it modifies the registry for "optimum performance" whether it does or not is up to debate.

Glad everything is all well and good though!
Mar 3 '09 #7

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

14 posts views Thread by Alexandre Plennevaux | last post: by
13 posts views Thread by Adam | last post: by
1 post views Thread by Michael Hetrick | last post: by
9 posts views Thread by Mantorok | last post: by
6 posts views Thread by Michael | last post: by
5 posts views Thread by Sonda | last post: by
6 posts views Thread by Dave Marden | last post: by
1 post views Thread by rainxy | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.