467,136 Members | 1,393 Online
Bytes | Developer Community
Ask Question

Home New Posts Topics Members FAQ

Post your question to a community of 467,136 developers. It's quick & easy.

Windows XP VPN Peer-toPeer Networks

I hatve 2 peer to peer networks which I am triying to connect via the Windows XP VPN application. I have achieved the following:

1. Connect to Remote Office
2. Ping all Computer IP Addresses in remote office
3. Use Terminal Services (Remote Desktop) on the Server computer- please note the server is also running windows XP.

I would like to achieve the following but have been unsuccessfull and am confused on what I am doing wrong.

1. Browse the Remote Office's local network, on "My Network Places"
A. The Subnet Mask for both local networks is
B. Every computer has a different IP address
C. Both Local Networks have the Primary DNS Server as
D. For both offices I have gone to the Server and Client PC and set IPEnableRouter in Regedit to 1.
I.Do I need to do this on all the Machines or just the Server.
E. I have set up a separate User Logon on all the Remote Office PC's with passwords.
2. I Would also like to establish remote desktop with the other PC's on the remote network but I can only establish it with the Server. The thing is that when I connect to the VPN it gives the Server 2 IP Addresses one which the VPN allocates and one which it has for it's local network connection I Use the VPN Allocated IP for remote desktop I have not tried its local IP.

Your help would be greatly greatly appreaciated
Oct 20 '08 #1
  • viewed: 7455
10 Replies
Expert Mod 4TB
Hmm, what VPN solution are you using?
Oct 21 '08 #2
Hmm, what VPN solution are you using?
Well, it is Windows VPN.

For the Remote PC:
I have basically gone into Network Connections in Window-> New Connection Wizard-> Set Up an Advanced Connection -> Accept Incoming Connections -> Allow virtual private connections -> Chose A user and created a password for him and that's it, the remote computer allows my pc to connect via the VPN.

For My PC:
I have basically gone into Network Connections in Window-> New Connection Wizard-> Connect to the network at my workplace-> Virtual Private Network Connection-> Gave A Name to the Connection -> Do Not Dial The initial Connection-> Entered the IP Address.

P.S. Just one more item was suggest by the Troubleshooting guide I have followed which I had implemented:
Right Click Properties on The VPN Connection->Networking Tab->TCPIP Properties->Advanced->Untick Use Default Gateway on Remote Network
Oct 21 '08 #3
I can now also browse the network drives by their IP Addresses, but not by computer names if I type them into the exploer address bar as like this : e.g. "\\" (without the quotes). That's alright I don't mind not being able to browse by computer name, but the issue is that I still cannot see them in my network places. When I log on to the workgroup from memory an error message pops up saying ..."not accessable you may not be authorised to access this network resource contact your administrator". I am the administrator so the resoulution provided by windows is useless to me.

I need your help
Oct 30 '08 #4
Expert 256MB
It's probally a DNS related issue. Take a look at this site and you should find a solution to your problem there

Nov 1 '08 #5
Just to update, I have given up on setting up a VPN, its to hard. I have succesfully been able to acheive my objective of merging databases, via text files. So The branch offices export the text files, the head office imports the text files. If there is data that has been changed there are queries that take the latest information and delete the old information.
Nov 24 '08 #6
I have been able to connect to the other offices using Windows VPN. I just can't figure out how to get access to the other computers on the remote offices network using Remote Desktop. When I ping their IP addresses, (LAN IP addresses) I get no response. There is no clash between any ip address either, all the IP Address ranges in the different offices as well as the vpn connection settings are different.

Feb 27 '09 #7
Expert Mod 16PB
If the PCs use the Windows default firewall, they will not respond to ICMP packets (pings). It's a real pain I know :(
Feb 27 '09 #8
Ok I will have a look, our router has a firewall so I will see what happens when I disable the Windows firewall
Feb 27 '09 #9
Expert Mod 16PB
While it makes sense for a hardware firewall (generally external facing) to drop the ICMP packets as a default (this is rarely the case in my experience), it makes little to no sense for this to be the default for a PC firewall (generally internal facing). Unfortunately, it does cover the producer's *rse better, so obviously that is the default setting.
Feb 27 '09 #10
I am now trying out a product called Himachi in conjunction with LogMeIn, they seem to be quite good, and no VPN expertise is required
Mar 3 '09 #11

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

4 posts views Thread by Donnal Walter | last post: by
1 post views Thread by Daniel Danilin | last post: by
2 posts views Thread by William Wisnieski | last post: by
2 posts views Thread by Daniel Danilin | last post: by
2 posts views Thread by Michael Bauer | last post: by
reply views Thread by EoRaptor013 | last post: by
reply views Thread by Dom Rout | last post: by
5 posts views Thread by Steve McKewen | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.