468,291 Members | 1,571 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,291 developers. It's quick & easy.

Access the IP Camera over Internet

1,584 Expert 1GB

I need a big favour from you guys.Need to know how to set up a IP camera to access that using Internet.

Before I start need to say, I am not from the same stream as you guys. Just a web application developer.

My Company purchased some IP cameras and currently It has set on our LAN and all can access through browser(IE) over LAN.

Now we need to access those IP camera(s) over Internet.

we have a ADSL connection from our ISP and its not a (Static IP address How ever)

Is it possible to Access this IP camera(s) over Internet with the Current resources we have. If yes plase say how, If not what we need to fly with this thing?

Jul 9 '07 #1
13 87720
4,677 Expert Mod 4TB
Well, I have to ask, with the ability to use google to search for open devices, do you want to

1) connect these so that everyone on the internet can use/see them


2) set up a VPN connection to get inside your network and use a local tool to operate/view the cameras?
Jul 9 '07 #2
1,584 Expert 1GB
we are using Acti IP camera and there is a user Authentication system with the Application Software of the product.So It won't be a public device any how.

Please refer to this link under Acti FAQ.
Why is it so important to have DDNS support in IP camera?
Here they have mentioned that without a Fixed IP address we can access our IP cameras over Internet.we are using U.S.Robotics ADSL2+4-Port Router. and we are using ADSL connection(shared IP).

With these stuffs can we do it.
Jul 9 '07 #3
113 100+
Here is a link to ACTi's support on the issue:
ACTi Support: Enabling IP Camera to be viewed through the internet (PDF Warning)

What you are wanting to do sounds feasible. Do you have port forwarding enabled on your router? For example, if you have DDNS service, and navigate to your camera's webpage, the router/switch should be forwarding that port 80 traffic through to the camera typically at
Jul 12 '07 #4
1,584 Expert 1GB
Here is a link to ACTi's support on the issue:
ACTi Support: Enabling IP Camera to be viewed through the internet (PDF Warning)

What you are wanting to do sounds feasible. Do you have port forwarding enabled on your router? For example, if you have DDNS service, and navigate to your camera's webpage, the router/switch should be forwarding that port 80 traffic through to the camera typically at
Hi archonmagnus,
Thanks for coming here.

Do you have port forwarding enabled on your router?
This is the place that we got stuck I think.

Let me clear up the things that we have done so far.
  1. Setting up IP camera
    LAN IP has set to and can view the camera over LAN using the IP.

    (I used the static IP address for the LAN IP is that Correct or should I use Dynamic)
  2. Registered with DynDns
    Addthe DDNS accounts to the web configurator

  3. Now I think port forwading..

    This is the place i got stuck. do you have any idea how to do a port forwading on U.S. robotics Model 9107
    Do you think this is the correct place for that.
Jul 13 '07 #5
1,584 Expert 1GB

I figured it out.

Only thing I did Just Added the virtual server after the settings that i made ealier . Didn't use the Port forwading.

Over Internet Anyone can Access the camera now.
But I cant Access from my LAN using the same URL as Internet users.

What might be the reason for this.?
Jul 13 '07 #6
113 100+
First let me say that I've never done this, but as an IP camera is just another internet device, it should follow the same connectivity setup as printers,computers, etc. With this caveat, everything looks good through step two.

What you actually want to use is the "Virtual Server" rather than "Port Triggering". Below is the USR reference:

PortForward.com has an additional reference (for the 9106) here . They didn't have a guide for ACTi's particular application, so please ignore the information at the top of the page regarding the set-up of another application. You are only concerned with interfacing the router at this point.

When you log into your router, look for the setting "Virtual Server". According to the USR guide, this option is under "Security".
Under the "Virtual Server" page, click the "Add" button to add a new port into the forwarding list. The PDF linked in my post above has a list of ports that the camera uses. Basically these are 80, 6000-6005. So add each of the these to the list (one at a time). They belong to the "ACTi" application (you can usually name this anything you want), and use the TCP protocol. The server address to enter is the camera's address, One you enter each line, click the apply button.

As I previously said, this should be just like any other IP device so port forwarding should solve the problem. If not post back, and we'll try to think of another way. I hope this helps.

[Edited to add: ]
Darn, a minute late. sorry, Ajax. :)

I'm not sure why you can't view it with the same URL. You should be able to view it. Can you still access it using the LAN address?
Jul 13 '07 #7
1,584 Expert 1GB
Sorry for the late reply archonmagnus !

Using my LAN IP I can Access the Camera.

will get the web configurator page.

But when I try to call it over my WAN IP,

The router Control panel is getting.So exacly it will act like this url (Roter Admin panel)

Need to find out a way to fix this.

Next thing

Virtual server setting for as follows,You can see how the adminpage looks here

Expand|Select|Wrap|Line Numbers
  2. ServerName ExternalPortStart ExternalPortEnd Protocol InternalPortStart InternalPortEnd ServerIPAddress
  3. OutSide-Cam 80 6001 TCP/UDP 80 6001 
  4. OutSide-Cam 80 6002 TCP/UDP 80 6002

Screen hot (click on image if not clear)

You have mentioned the ports as 6000-6005. do I have to add up to 6005 to the above list.?

When I try http://124.43.xxx.xxx by default web configurator page is getting, that means the IP cam webserver is running under port 80.
and the router is forwarding this to 6001-6002.is that correct?

One more thing Under router-admin-panel >> Security menu >> I can find Port Triggering. what does it exacly do.
You can find it here.

Lots of questions isn't it.
Thanks a lot for your time.

kind regards,
Jul 18 '07 #8
113 100+
I'm still not sure why you can't access the camera through the WAN address. According to your post and the screenshot, however, I would recommend that you alter your port forwarding options to the following (for security sake):
ServerName ExternalPortStart ExternalPortEnd Protocol InternalPortStart InternalPortEnd ServerIPAddress

OutSide-Cam 80 80 TCP/UDP 80 80
OutSide-Cam 6001 6005 TCP/UDP 6001 6005

You have a very wide range of ports leaking through your router with your current setup. Basically, you want any incoming traffic for port 80 to pass through your router to port 80 on the server you specify ( in your case.) Likewise, you want the router to forward any port 6002 traffic to port 6002 on the camera. ad infinitum until all the required ports are forwarded to their respective services.

A better explanation would be that you want http://124.43.xxx.xxx to forward to which is what you would see if you typed in into a browser. The camera's built-in server is using ports 80. Ports 6001-6005 are apparently used by the installed camera administration software (I would think).

As for your query regarding port-triggering; it is basically like using an NPN transistor as a switch. You use the activity of one port to "turn-on" or "turn-off" another port. There is a much better and more thorough definition on PortForward.com

I will have to ponder the anomalous WAN/LAN addressing issue, however.
Jul 19 '07 #9
1,584 Expert 1GB
heya archonmagnus,

Thanks a bunch!

I made the changes to virtual server settings, as you said.
Thanks for showing the mistakes I made when configuring the virtual server ports.I think now its fixed well.

Credits goes to you :) ....If i am doing it well here.

Expand|Select|Wrap|Line Numbers
  2. OutSide-Cam 80 80 TCP/UDP 80 80
  3. OutSide-Cam 6001 6005 TCP/UDP 6001 6005
See, now outsider can access my cam over Internet. But still I am the poor guy who didn't see my own cam over Internet.

Still couldn't find out way to access my cam using the WAN IP but outsiders can do that http://124.43.xxx.xxx.
If I am doing the same thing as they did in the browser my bad luck goes to my router admin page instead of IP camera.

Once I could fixed it, we are ready to fly.

Thanks for your time.
Jul 20 '07 #10
113 100+
Since it appears that outsiders (or anybody not on the same node as you) can see the camera, I believe it is safe to assume that your ISP doesn't block port 80 traffic. Some ISPs (in attempt to get more money out of you, I'm sure) block port 80 to prevent people from running their own webserver.

What I believe is happening is that the router is doing a kind of "loopback" in response to port 80 traffic from within its collision domain. In other words, NAT isn't correctly parsed by the router to a server when both you and the server are behind the router.

Can you still get to the camera's setup via its LAN IP? If so, I believe everything is working (with caveats). Those outside of your network node can view the camera through the WAN address, and those behind the router can view it through its LAN address. It could be that the router fouls up the network address translation for LAN-to-WAN-back to-LAN traffic.

You could (as a cheat) edit the HOSTs file or change a local DNS entry to redirect http://124.43.xxx.xxx to for those computers behind the router to get around the NAT issue.

I'm still trying to find out if it could be anything else.
Jul 20 '07 #11
1,584 Expert 1GB
Here are the Video SettingS on my IP cam, please go through it to find out, if something is there that i should use to enhance the video streaming to the Internet users.currently it is some what slow over our ADSL line(for LAN its a absolutely fine LOL).

I'll Bold the all Options here there at web configurator panel.
Currently Selected values in italic bold

Streaming Method

TCP Only
Multicast Only
RTP Over Multicast
RTP Over UDP & Multicast

Audio In

Multicast IP . . . ( ~

Multicast TTL (1 ~ 255)


Analog Video

P720x576 P640x480 P352x288 P176x144

28K 56K 128K 256K 384K 500K 750K 1M 1.2M 1.5M 2M 2.5M 3M

Frame Rate Mode

Frame Rate
25 12 8 6 5 4 3 2 1

Serial Port Baud Rate
2400 4800 9600 19200 38400 57600 115200

Serial Port Control

Video RTP Over Multicast
Audio RTP Over Multicast
Video Control Port
Video Streaming Port
Video Multicast Port

As I can remember,I have used port 6001-6005 only.do we have to use the other ports also in the virtual server settings.?

You could (as a cheat) edit the HOSTs file or change a local DNS entry to redirect http://124.43.xxx.xxx to for those computers behind the router to get around the NAT issue.
And its sorry to say that I didn't get this yet!

Jul 20 '07 #12
1,584 Expert 1GB
I'd like to reopen the thread, because here we have some issues that we couldn't get through with a solution yet.

Now when we accessing the LAN cameras over the Internet, the video streaming rate is not that much good. what I would like to know from you guys is there anyway, to improve up the video streaming. So far we have done the product level customizations for this.
I have heard about media servers is this the thing we can use for this or anything else?
Please feel free to ask, if you couldn't get what I said.Thanks for your time.
Aug 31 '07 #13
thx for your valuable information friends ....
To check camera recording live on WAN you have to do port forwarding or you can say that NAT Ing should be done...
if you are using DVR(Digital Video Recording) and ur DVR ip is for ex then you can use check that recording on WAN with you WAN IP.....
Mar 5 '13 #14

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

3 posts views Thread by le_mo_mo | last post: by
1 post views Thread by =?Utf-8?B?VGVjaGVlaw==?= | last post: by
1 post views Thread by =?Utf-8?B?am9lIHNsdW5r?= | last post: by
reply views Thread by NPC403 | last post: by
reply views Thread by Teichintx | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.