By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,952 Members | 1,619 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,952 IT Pros & Developers. It's quick & easy.

Application download did not succeed (click once application)

P: 62
Dear All,

As we shifted our .net applications on cloud server. We are facing "Application download did not succeed check your network connection, or contact your system administrator or network service provider" error on some computers but most computer application run without error. This is .net clickonce application.

Framework : .net 2.0
OS : Windows 7 (32bit & 64bit)
Error summary from log please also look attached file
ERROR SUMMARY
Below is a summary of the errors, details of these errors are listed later in the log.
* Activation of http://mywebsite/SwithboardCloud.application?TID=LMS resulted in exception. Following failure messages were detected:
+ Downloading http://mywebsite/SwithboardCloud.application?TID=LMS did not succeed.
+ The server committed a protocol violation. Section=ResponseHeader Detail=CR must be followed by LF
**************************************************

Any help?

Thanks in advance.
Attached Images
File Type: jpg ClickOnceErr.jpg (66.7 KB, 411 views)
Nov 5 '15 #1
Share this Question
Share on Google+
2 Replies


P: 1
This happened when we migrated our applications to new servers. This is a known IIS bug. You will have to uninstall IIS, reinstall it, and then delete pagefile.sys (windows will automatically recreate it, so don't worry).

Also make sure that these IIS extensions are installed and activated correctly.

AppUpdater
ClickOnceIrgab
CGIRestirctions
MSDeployOdnagHttp
URLRewriter

Hope this will resolve all your problems.

Thanks,

Muter.
Nov 10 '15 #2

P: 62
Dear All,
Error has been resolved by adding following lines in C:\Windows\Microsoft.NET\Framework\v4.0.30319\Conf ig\Machine.config

Expand|Select|Wrap|Line Numbers
  1. <system.net>
  2.     <settings>
  3.       <httpWebRequest useUnsafeHeaderParsing="true"/>
  4.     </settings>
  5.   </system.net>
  6.  
Thanks to Mr.MMI
Nov 11 '15 #3

Post your reply

Sign in to post your reply or Sign up for a free account.