By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,899 Members | 1,230 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,899 IT Pros & Developers. It's quick & easy.

VS2010 keeps asking Discovery Credentials while adding Web-Services

100+
P: 121
Hi,

We have 1 reporting server where we have all the reports, now i need to show some reports in my Visual Studio project and for that i am trying to add Reporting server web services which will send me back the report and i'll display that report in pdf in my browser.

Problem i am facing is, when i try to add web-service through Visual Studio. It keeps asking me 'Discovery Credentials', i have tried entering these 20 times but it keeps asking again and again. I have even tried putting wrong password but nothing changes. So it seems their is something which i dont know maybe about connecting reporting web services with Visual Studio 2010.

Can anybody help with any guidance on where i can look. The webservices URL, if pasted in browser does show you web service stuff. This makes me think that their is some problem in a way i am trying to connect or i am doing it in completely wrong way?

Any help will be appreciated.

Regards
Jay
Aug 10 '12 #1
Share this Question
Share on Google+
2 Replies


100+
P: 121
Get this when i try to connect

Metadata contains a reference that cannot be resolved: 'http://servername/ReportServer/ReportExecution2005.asmx'.
The HTTP request is unauthorized with client authentication scheme 'Anonymous'. The authentication header received from the server was 'Negotiate,NTLM'.
The remote server returned an error: (401) Unauthorized.
If the service is defined in the current solution, try building the solution and adding the service reference again.

Is it some Reporting server setuip issue?
Sep 3 '12 #2

P: 1
Struggled with this one a lot yesterday & google was not much help other than finding others running into the same confusion.

I could browse the wsdl just fine in IE, so IE was passing credentials just fine. So after like 5 hours of "wtf" decided that the add reference for discovery dialog in VS2010 just was not passing credentials.... evidenced by the error msg indicating the server doesnt permit anonymous authentication.

"well so wouldn't it provide my credentials the same way IE does?"

Um, so maybe not. maybe I was assuming that it would. Maybe VS2010 ONLY wanted anonymous authentication for discovery.

Checking the SSRS services I was trying to "discover", found anonymous was not permitted.

So in my case VS2010 wanted to authenticate anonymously for discovery and didn't seem to want to supply credentials in the same fashion IE did.

So I opened IIS on the hosting server, enabled anonymous authentication for the SSRS services and VS2010 stopped presenting the useless login prompts.

Service reference dropped in & the proxies were generated.

I haven't tried disabling anonymous access, but I have the sense that since I'm going to pass ClientCredentials to the proxy when I use it, that it will be safe to disable anonymous access on the host.

VS2010 just needed to authenticate anonymously from that dialog, I am guessing.
Feb 19 '13 #3

Post your reply

Sign in to post your reply or Sign up for a free account.