469,271 Members | 1,713 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,271 developers. It's quick & easy.

XSL:FO page break problem

I have been dealing with the page-break problem for long, and have not
been able to come to a solution.
I am using XSL:FO to generate PDF report for my XML, generating it in
tables.
I want that tables should completely be at one place, if there is a
page break , all the contents of the table should move to the next
page.
I implemented <keep-together.within-page="always"> in <fo:table row>
as FOP0.20.5 does not support it in any other place.
So, i created a virtual table with one row and one column,
and in that row i used <keep-together>.

but still, it is not serving the purpose.
can any one suggest a way out?

<fo:table>
--
--
<fo:table-row keep-together.within-page="always>
<fo:table-cell>
<fo:table>
</fo:table>
</fo:table-cell>
<fo:table-cell>
<fo:table>
</fo:table>
</fo:table-cell>
</fo:table-row>
<fo:table>

this is the kind of code i am using?
Jul 20 '05 #1
2 11362
I don't know about FOP, but if keep-together is not implemented on fo:table,
try:

(a) putting the table inside a fo:block which has keep-together
(b) putting keep-with-next on every fo:row except the the last one
(c) putting keep-with-previous on every fo:row except the the first one

John

Visual Programming Ltd mail PO Box 22-222, Khandallah, Wellington, New
Zealand site Level 2, 2 Ganges Road, Khandallah, Wellington, New Zealand
phone +64 4 479 1738 fax +64 4 479 1294 web http://www.xmlpdf.com
"Anshul Seth" <an*********@gmail.com> wrote in message
news:fb**************************@posting.google.c om...
I have been dealing with the page-break problem for long, and have not
been able to come to a solution.
I am using XSL:FO to generate PDF report for my XML, generating it in
tables.
I want that tables should completely be at one place, if there is a
page break , all the contents of the table should move to the next
page.
I implemented <keep-together.within-page="always"> in <fo:table row>
as FOP0.20.5 does not support it in any other place.
So, i created a virtual table with one row and one column,
and in that row i used <keep-together>.

but still, it is not serving the purpose.
can any one suggest a way out?

<fo:table>
--
--
<fo:table-row keep-together.within-page="always>
<fo:table-cell>
<fo:table>
</fo:table>
</fo:table-cell>
<fo:table-cell>
<fo:table>
</fo:table>
</fo:table-cell>
</fo:table-row>
<fo:table>

this is the kind of code i am using?

Jul 20 '05 #2
helmut fish wrote:
*I don't know about FOP, but if keep-together is not implemented o
fo:table,
try:

(a) putting the table inside a fo:block which has keep-together
(b) putting keep-with-next on every fo:row except the the last one
(c) putting keep-with-previous on every fo:row except the the firs
one

John
*


Option-A does not work with FOP. I've already tried that
B and C works just fine, thanks for the tip.. :
-
leget
-----------------------------------------------------------------------
Posted via http://www.forum4designers.co
-----------------------------------------------------------------------
View this thread: http://www.forum4designers.com/message94221.htm

Jul 20 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by David | last post: by
reply views Thread by Gilles Kuhn | last post: by
reply views Thread by sp | last post: by
reply views Thread by Rary | last post: by
reply views Thread by Nathan | last post: by
reply views Thread by jklBruin | last post: by
5 posts views Thread by cleary1981 | last post: by
1 post views Thread by cleary1981 | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.