By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,275 Members | 936 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,275 IT Pros & Developers. It's quick & easy.

Retrieving the COM class factory for component with CLSID {} ... error: 80040154

P: 6
Hi all,

I am using :
1. Windows XP-Visual Studio 2005
2. FastReport Studio Trial (www.fast-report.com)

I have used FastReport Studio Trial (FastReport3.dll) in my ASP.NET web Site project,Every thing is ok and execute my project and generate report on VS2005 BUT when i publish it in local host , the error comes as

Retrieving the COM class factory for component with CLSID {4764040E-4222-4DEC-9F2E-82D46E212B3A} failed due to the following error: 80040154i have done 2 solution

at first I registered the fastreport3.dll but the error isn't solved .
at second,
my friend said that i must change my Platform to .x86 but in web site project i can't do it so I changed my VS 2005 Web Site Projects to VS 2005 Web Application Projects and then changing my platform to .X86
BUT , The error is still present .

can you help me to solve this error i have one emergency project that it depend to this solution.....


Your quick response would be really appreciated.

Best Regards.
Aug 19 '08 #1
Share this Question
Share on Google+
4 Replies


DrBunchman
Expert 100+
P: 979
Hi mojde,

You've posted your question in the ASP Forum which is for Classic ASP only - I've moved it for you but in future please post all ASP.NET questions in the .NET Forum.

Thanks and regards,

Dr B
Aug 19 '08 #2

Curtis Rutland
Expert 2.5K+
P: 3,256
I suggest you get support from the publishers of FastReport. It is very unlikely that one of the experts here has experience supporting that specific 3rd party software.
Aug 19 '08 #3

P: 6
hi,

Thanks for your useful reply...

I want know , that this problem may happen becuse the FastReport Studio is Trial or no ???...

Best Regards
Aug 20 '08 #4

P: 4
I had the same problem running C# code with reference to a COM dll.
Changing platform from AnyCPU to x86 didn't help.
Changing the reference property "Isolated" to True inside the C# project, solved the problem.
Also, all the files created by compilation should be copied together with exe:
*.exe.manifest
*.pdb
*.dll
Interop.*.dll
Oct 25 '11 #5

Post your reply

Sign in to post your reply or Sign up for a free account.