By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,505 Members | 1,168 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,505 IT Pros & Developers. It's quick & easy.

Third Party DLL not working on Production Server

P: 2
Hi,
I have a third party dll 'Interop.DocCom.dll' which i am using to extract text from .doc files, while uploading the file from the FileUpload control.
Locally my web application is able to extract the text and store it to the database.
But after deploying the application to the Test Server and then uploading the file, it is not extracting the text.
I am using TerminalServices client to connect to the remote server.
However, when i access the test server using the terminal services client and then open the explorer there and upload the file in the application, then the dll is extracting the text fine. I am really puzzled by this behaviour.
I was suspecting it to be a security issue but then since the web server has anonymous access applied to the site, permissions should not be a problem.
This problem has been nagging me for a couple of days now.
Any help would be very much appreciated.

Regards,
Shridhar
Jul 9 '08 #1
Share this Question
Share on Google+
2 Replies


debasisdas
Expert 5K+
P: 8,127
try to manually register the DLL with the OS.
Jul 9 '08 #2

P: 2
try to manually register the DLL with the OS.
Hi debasisdas....i have registered the dll thru regasm and it did register successfull. Even then i am unable to upload and extract the text from the explorer outside.
I even tried <identity impersonate="true"...> but still it doesn't work.
Locally, we tried to access the site by having it pointed to another m/c and there the extraction works fine.It is the deployment to the test server after which it isn't working.
How does one generally handle third party dlls in the test or production server?
Jul 10 '08 #3

Post your reply

Sign in to post your reply or Sign up for a free account.