By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,157 Members | 1,001 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,157 IT Pros & Developers. It's quick & easy.

Re: Having trouble successfully deploying WCF service to public website

P: n/a
can you show me in more detail? I have same problem where on the page
it's https://service.premilance.com/Company.svc, but the svcutil tells
me to get it from https://pserver1/Company.svc?wsdl which is
incorrect.. I have no clue how to fix it and i'm struggling for two
days already :(
On Mar 13, 3:09 pm, "Tiago Halm" <th...@nospam.hotmail.comwrote:
If hosting in IIS, just set the hostheader of the website to the public
hostname. The generated WSDL/XSDs will contain the hostname with which it
was accessed.

Tiago Halm

<kiern...@yahoo.comwrote in message

news:c8**********************************@d21g2000 prf.googlegroups.com...
I'm fairly new to deploying WCF web services and am running into
problems deploying my WCF service to a public web site. I want this
web service to be accessible by clients outside my domain.
The problem I'm running into first off is that the WSDL contains the
server's name instead of the web site's name. The WSDL elements and
attributes listed below contain "http://<server_internal_name>/..."
instead of "http://<web_site_name>/...":
* xsd:import schemaLocation
* soap12:address location/@location
* wsa10:Address
The second manifestation of the problem is that when I create a client
app in VS 2008 and then add a service reference to this service (using
the Add Service Reference option in the Solution Explorer), the
endpoint address also contains the server's name instead of the web
site name. One other thing that I notice is that when I try to add the
reference to the web service, the MetadataSource address in the svcmap
file refers to the "/mex" address instead of pointing to the wsdl
(which looks like "...?wsdl").
I have tried to fix this by adding <baseaddresses>/<add
baseaddress="..." /></baseaddressesentries into the web.config for
the web service. Also added <identity><dns value="..." /></identity>
entries in an attempt to fix this. I'm hoping that all is wrong is
that I'm missing some configuration values.
Can somebody tell me what I'm doing wrong? Thanks!
Jun 27 '08 #1
Share this Question
Share on Google+
3 Replies


P: n/a
On May 1, 7:12*am, kkao77 <kka...@gmail.comwrote:
can you show me in more detail? *I have same problem where on the page
it'shttps://service.premilance.com/Company.svc, but the svcutil tells
me to get it fromhttps://pserver1/Company.svc?wsdlwhich is
incorrect.. I have no clue how to fix it and i'm struggling for two
days already :(

On Mar 13, 3:09 pm, "Tiago Halm" <th...@nospam.hotmail.comwrote:
If hosting in IIS, just set the hostheader of the website to the public
hostname. The generated WSDL/XSDs will contain the hostname with which it
was accessed.
Tiago Halm
<kiern...@yahoo.comwrote in message
news:c8**********************************@d21g2000 prf.googlegroups.com...
I'm fairly new to deploying WCF web services and am running into
problems deploying my WCF service to a public web site. I want this
web service to be accessible by clients outside my domain.
The problem I'm running into first off is that the WSDL contains the
server's name instead of the web site's name. The WSDL elements and
attributes listed below contain "http://<server_internal_name>/..."
instead of "http://<web_site_name>/...":
* xsd:import schemaLocation
* soap12:address location/@location
* wsa10:Address
The second manifestation of the problem is that when I create a client
app in VS 2008 and then add a service reference to this service (using
the Add Service Reference option in the Solution Explorer), the
endpoint address also contains the server's name instead of the web
site name. One other thing that I notice is that when I try to add the
reference to the web service, the MetadataSource address in the svcmap
file refers to the "/mex" address instead of pointing to the wsdl
(which looks like "...?wsdl").
I have tried to fix this by adding <baseaddresses>/<add
baseaddress="..." /></baseaddressesentries into the web.config for
the web service. Also added <identity><dns value="..." /></identity>
entries in an attempt to fix this. I'm hoping that all is wrong is
that I'm missing some configuration values.
Can somebody tell me what I'm doing wrong? Thanks!- Hide quoted text -

- Show quoted text -
Since you have a server certificate in IIS, you cannot set the host
header name via the UI, so IIRC you need to use adsutil.vbs for that.
Its useful to read this blog and view the webcast on setting Host
Headers with SSL in IIS 6.0.
http://agramont.net/blogs/conrad/arc.../06/26/21.aspx

Tiago Halm
Jun 27 '08 #2

P: n/a
Thanks for this post this fixes the problem for me. And here is the
detail in a nice easy to find place.

To list all the sites in IIS
C:\Inetpub\AdminScripts>adsutil.vbs enum /p w3svc

[/w3svc/1]
[/w3svc/922169312] <-the site that you want to secure using a
hostheader
[/w3svc/AppPools]
[/w3svc/Filters]
[/w3svc/Info]

C:\Inetpub\AdminScripts>adsutil.vbs get /w3svc/922169312/
serverbindings
serverbindings : (LIST) (1 Items)
":80:testddi.doverport.co.uk"

C:\Inetpub\AdminScripts>adsutil.vbs get /w3svc/922169312/
securebindings
securebindings : (LIST) (1 Items)
":443:"

C:\Inetpub\AdminScripts>adsutil.vbs set /w3svc/922169312/
securebindings ":443:host.header.com"
securebindings : (LIST) ":443:host.header.com"

Again many thanks just the right solution
Andy
On May 6, 6:13*pm, tiago.h...@gmail.com wrote:
On May 1, 7:12*am, kkao77 <kka...@gmail.comwrote:
can you show me in more detail? *I have same problem where on the page
it'shttps://service.premilance.com/Company.svc, but the svcutil tells
me to get it fromhttps://pserver1/Company.svc?wsdlwhichis
incorrect.. I have no clue how to fix it and i'm struggling for two
days already :(
On Mar 13, 3:09 pm, "Tiago Halm" <th...@nospam.hotmail.comwrote:
If hosting in IIS, just set the hostheader of the website to the public
hostname. The generated WSDL/XSDs will contain the hostname with whichit
was accessed.
>Tiago Halm
<kiern...@yahoo.comwrote in message
>news:c8**********************************@d21g200 0prf.googlegroups.com....
I'm fairly new to deploying WCF web services and am running into
problems deploying my WCF service to a public web site. I want this
web service to be accessible by clients outside my domain.
The problem I'm running into first off is that the WSDL contains the
server's name instead of the web site's name. The WSDL elements and
attributes listed below contain "http://<server_internal_name>/..."
instead of "http://<web_site_name>/...":
* xsd:import schemaLocation
* soap12:address location/@location
* wsa10:Address
The second manifestation of the problem is that when I create a client
app in VS 2008 and then add a service reference to this service (using
the Add Service Reference option in the Solution Explorer), the
endpoint address also contains the server's name instead of the web
site name. One other thing that I notice is that when I try to add the
reference to the web service, the MetadataSource address in the svcmap
file refers to the "/mex" address instead of pointing to the wsdl
(which looks like "...?wsdl").
I have tried to fix this by adding <baseaddresses>/<add
baseaddress="..." /></baseaddressesentries into the web.config for
the web service. Also added <identity><dns value="..." /></identity>
entries in an attempt to fix this. I'm hoping that all is wrong is
that I'm missing some configuration values.
Can somebody tell me what I'm doing wrong? Thanks!- Hide quoted text-
- Show quoted text -

Since you have a server certificate in IIS, you cannot set the host
header name via the UI, so IIRC you need to use adsutil.vbs for that.
Its useful to read this blog and view the webcast on setting Host
Headers with SSL in IIS 6.0.http://agramont.net/blogs/conrad/arc.../06/26/21.aspx

Tiago Halm
Jun 27 '08 #3

P: n/a
Thanks for this post this fixes the problem for me. And here is the
detail in a nice easy to find place.

To list all the sites in IIS
C:\Inetpub\AdminScripts>adsutil.vbs enum /p w3svc

[/w3svc/1]
[/w3svc/922169312] <-the site that you want to secure using a
hostheader
[/w3svc/AppPools]
[/w3svc/Filters]
[/w3svc/Info]

C:\Inetpub\AdminScripts>adsutil.vbs get /w3svc/922169312/
serverbindings
serverbindings : (LIST) (1 Items)
":80:host.header.com"

C:\Inetpub\AdminScripts>adsutil.vbs get /w3svc/922169312/
securebindings
securebindings : (LIST) (1 Items)
":443:"

C:\Inetpub\AdminScripts>adsutil.vbs set /w3svc/922169312/
securebindings ":443:host.header.com"
securebindings : (LIST) ":443:host.header.com"

Again many thanks just the right solution
Andy
On May 6, 6:13*pm, tiago.h...@gmail.com wrote:
On May 1, 7:12*am, kkao77 <kka...@gmail.comwrote:
can you show me in more detail? *I have same problem where on the page
it'shttps://service.premilance.com/Company.svc, but the svcutil tells
me to get it fromhttps://pserver1/Company.svc?wsdlwhichis
incorrect.. I have no clue how to fix it and i'm struggling for two
days already :(
On Mar 13, 3:09 pm, "Tiago Halm" <th...@nospam.hotmail.comwrote:
If hosting in IIS, just set the hostheader of the website to the public
hostname. The generated WSDL/XSDs will contain the hostname with whichit
was accessed.
>Tiago Halm
<kiern...@yahoo.comwrote in message
>news:c8**********************************@d21g200 0prf.googlegroups.com....
I'm fairly new to deploying WCF web services and am running into
problems deploying my WCF service to a public web site. I want this
web service to be accessible by clients outside my domain.
The problem I'm running into first off is that the WSDL contains the
server's name instead of the web site's name. The WSDL elements and
attributes listed below contain "http://<server_internal_name>/..."
instead of "http://<web_site_name>/...":
* xsd:import schemaLocation
* soap12:address location/@location
* wsa10:Address
The second manifestation of the problem is that when I create a client
app in VS 2008 and then add a service reference to this service (using
the Add Service Reference option in the Solution Explorer), the
endpoint address also contains the server's name instead of the web
site name. One other thing that I notice is that when I try to add the
reference to the web service, the MetadataSource address in the svcmap
file refers to the "/mex" address instead of pointing to the wsdl
(which looks like "...?wsdl").
I have tried to fix this by adding <baseaddresses>/<add
baseaddress="..." /></baseaddressesentries into the web.config for
the web service. Also added <identity><dns value="..." /></identity>
entries in an attempt to fix this. I'm hoping that all is wrong is
that I'm missing some configuration values.
Can somebody tell me what I'm doing wrong? Thanks!- Hide quoted text-
- Show quoted text -

Since you have a server certificate in IIS, you cannot set the host
header name via the UI, so IIRC you need to use adsutil.vbs for that.
Its useful to read this blog and view the webcast on setting Host
Headers with SSL in IIS 6.0.http://agramont.net/blogs/conrad/arc.../06/26/21.aspx

Tiago Halm
Jun 27 '08 #4

This discussion thread is closed

Replies have been disabled for this discussion.