By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,640 Members | 1,598 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,640 IT Pros & Developers. It's quick & easy.

... forbidden with client authentication scheme Anonymous

P: n/a
I have a client / server written in C#/VS2005 that uses WCF. Each
component exposes a secure (https:) endpoint with WCF. httpcfg was
used to secure the ports with certificates. (Both system use the same
certificate for their endpoints, in case that matters)

The client and server are on different physical systems.

The applications communicate like so:
Request: Client -----Server's endpoint ( https://172.16.26.30:8283/MyServer
)
Response: Server -----Client's endpoint ( https://172.16.26.31:40201/MyClient
)

The client works on every system I've tried it ... but one. On that
one system, when the Server tries to respond, the error the server
gets is: The HTTP request was forbidden with client authentication
scheme 'Anonymous'

This appears to be some kind of IIS setup issue on that one client
system.

I believe I've made sure that Anonymous access is enabled: Control
Panel Administrative Tools Internet Information Services Web
Services right click Properties Directory Security >
Authentication and Access Control Enable Anonymous Access is
checked.

What else could be wrong? What am I missing?

Help!
Mar 29 '08 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Let us know more details, in particular the binding (basicHttpBinding,
wsHttpBinding, netTcpBinding, etc...) and its attributes. We need to know
where the security check takes place (transport or message) and how the
server/client authenticate.

And, you say the "the error the server gets (...)". Isn't the other way
around?

note: avoid posting to multiple newsgroups please ...

Tiago Halm

<mz*******@gmail.comwrote in message
news:70**********************************@s8g2000p rg.googlegroups.com...
>I have a client / server written in C#/VS2005 that uses WCF. Each
component exposes a secure (https:) endpoint with WCF. httpcfg was
used to secure the ports with certificates. (Both system use the same
certificate for their endpoints, in case that matters)

The client and server are on different physical systems.

The applications communicate like so:
Request: Client -----Server's endpoint (
https://172.16.26.30:8283/MyServer
)
Response: Server -----Client's endpoint (
https://172.16.26.31:40201/MyClient
)

The client works on every system I've tried it ... but one. On that
one system, when the Server tries to respond, the error the server
gets is: The HTTP request was forbidden with client authentication
scheme 'Anonymous'

This appears to be some kind of IIS setup issue on that one client
system.

I believe I've made sure that Anonymous access is enabled: Control
Panel Administrative Tools Internet Information Services Web
Services right click Properties Directory Security >
Authentication and Access Control Enable Anonymous Access is
checked.

What else could be wrong? What am I missing?

Help!

Mar 29 '08 #2

P: n/a
On Mar 30, 1:13 pm, "Tiago Halm" <th...@nospam.hotmail.comwrote:
Finally, if you want to maintain the architecture you have, you need both
services to be setup on IIS with secure channel setup (HTTPS) and seems that
the service that is acting as the client is not setup as such.
Remember, the client works as-is on every other system in our lab,
even other XP systems/ This problem is isolated to *one* *system*.

I'm 99% certain this is a Windows / IIS *setup* issue on the one PC
where it doesn't work ... but I've checked everything in IIS that I
can find am don't know where to look next.

For some reason, which I'm unable to pinpoint, Anonymous connections
are not working on that one PC.
Mar 30 '08 #3

P: n/a
On Mar 30, 1:41 pm, mzarlenga <mzarle...@gmail.comwrote:
I'm 99% certain this is a Windows / IIS *setup* issue on the one PC
where it doesn't work ... but I've checked everything in IIS that I
can find am don't know where to look next.

For some reason, which I'm unable to pinpoint, Anonymous connections
are not working on that one PC.
Update: I uninstalled IIS, renamed C:\Inetpub then reinstalled IIS.

And it's working fine now. I have no idea what was wrong with the
previous installation of IIS. Everything looked just fine.

Anyway, problem solved, thanks for your feedback, Tiago.

Mar 31 '08 #4

This discussion thread is closed

Replies have been disabled for this discussion.