469,908 Members | 2,213 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,908 developers. It's quick & easy.

Visual SourceSafe (Internet) not working!


I'm having a problem accessing my dotnet projects through Visual
Studio 2008 & SourceSafe 2005 (Internet) on XP Pro.

Firstly, I've set up the Source Control in VS2008's Tools -Options
for both:
1. Current source control plug-in = Microsoft Visual SourceSafe
2. Always use SSL to connect to the server = UNTICKED

Now if I try File -Open -Project/Solution, and click on the
Microsoft Visual SourceSafe button (on the left hand side), I get to
add my SourceSafe Database. I set this up with my Address (IP Address)

But now it hits the problem. I can see the folders & projects listed
on the server. I can navigate through the folders, and get to the
project / solution that I want to open. I highlight the solution and
click the Open button, but the Open Project window just pops me back
to "My Computed" (as if I had clicked that button on the left hand
side). I'm unable to open any projects, although I can see them listed
on the server.

Aaaaargh! Any idea of what is causing this?

Thanks for your help.

Feb 24 '08 #1
2 2111
This is probably not really gonna help you, but I'm having the exact
same problem. However, I've found out some things that may help us
narrowing down the problem, and a support call to MS is on its way, too
(though I doubt it'll help us any further...)

My situation: XP Pro, SP2, Xeon Quad Core 4GB. Clean installation of
system, VS2008 (Visual Studio) and VSS2005 (Visual SourceSafe). Internet
plugin enabled through the steps outlined in Alin's blog:
http://alinconstantin.homeip.net/web...S_Internet.htm, using the
SSL method.

Exactly like in your situation, I see the "My Computer" default location
when I try to open a solution file from my VSS database (which I can
browse through).

Now, the interesting (and worrying) part is that there are 5 alike
systems (XP Pro, SP2, VS2008/VSS2005) where it works well.

I've written down the whole story, including screenshots, at
Experts-Exchange, hoping someone can shed some light in there:

So far, the only differences I have found between this and the other
systems are:

1. This is a Quad Core CPU, others are Dual Core or Single Core

2. This system crosses the 2GB memory limit (4GB installed, system
shows, as is normal, 3.25GB available).

3. This system is "clean". With it I mean that, besides it is a new
installation of everything, there has not been an upgrade from VS2005 to
VS2008. On the other systems there has been.

I doubt if any of these really narrow down the problem, but perhaps, if
you are still experiencing this very problem and you find similar
differences, we may come closer to a cause...

Hope you'll read this comment. If you did find a solution to your
problem, I'd ver very happy to hear it from you.

-- Jan Janszen --

*** Sent via Developersdex http://www.developersdex.com ***
Apr 3 '08 #2
Just found a solution. Thanks to
http://tiredblogger.wordpress.com/ca...indows-server/ mentioning a
VSS hotfixes pack. Microsoft apparently has never find it necessary to
log the issue mentioned in this thread and on Experts-Exchange, but it
does fix the problem to download and install the hotfixes on the client
machine using VSS and VS2008.

Hotfixes rollup package: http://support.microsoft.com/kb/943847
Long list of bugs fixed (not mentioning this one):

Thanks to all the bloggers who led me to this solution.

-- Abel Braaksma --

*** Sent via Developersdex http://www.developersdex.com ***
Apr 3 '08 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Job Lot | last post: by
reply views Thread by . . | last post: by
4 posts views Thread by Jason Shohet | last post: by
2 posts views Thread by Bob Garbados | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.