By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,626 Members | 2,202 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,626 IT Pros & Developers. It's quick & easy.

.NET windows service fails to start when digitally signed

P: n/a
Situation: .NET windows service

All works fine until we digitally signed the service exe. After that
starting the service often fails (A timeout was reached (30000 milliseconds)
while waiting for the ... service to connect.). I can reproduce this
behaviour with XP x64.

Looks like windows tries to verify the signature and this take too much
time. When I disconnect the computer from the internet, the service starts.

I am not the only one having this problem:

http://www.codeprof.com/dev-archive/...4-2099945.shtm

http://www.msnewsgroups.net/group/mi...topic2033.aspx

Any solutions?

Thanks for your help
Ralf

Jan 25 '08 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Does the system user have access to the Internet?

--
Browse http://connect.microsoft.com/VisualStudio/feedback/ and vote.
http://www.peterRitchie.com/blog/
Microsoft MVP, Visual Developer - Visual C#
"Ralf" wrote:
Situation: .NET windows service

All works fine until we digitally signed the service exe. After that
starting the service often fails (A timeout was reached (30000 milliseconds)
while waiting for the ... service to connect.). I can reproduce this
behaviour with XP x64.

Looks like windows tries to verify the signature and this take too much
time. When I disconnect the computer from the internet, the service starts.

I am not the only one having this problem:

http://www.codeprof.com/dev-archive/...4-2099945.shtm

http://www.msnewsgroups.net/group/mi...topic2033.aspx

Any solutions?

Thanks for your help
Ralf

Jan 25 '08 #2

This discussion thread is closed

Replies have been disabled for this discussion.