By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,709 Members | 839 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,709 IT Pros & Developers. It's quick & easy.

Problem dragging & dropping toolbox items onto form

P: n/a
Hey folks;

I've got a weird problem... whenever I try to drag and drop a toolbox
item onto a form in the Window Forms editor, the control is
automatically added on the first click.

This gives me very little control over where it ends up, and as you
can imagine, is somewhat inconvenient.

Anyone know a fix for this? My work system doesn't do this.

(VS 2005 SP1 Pro on both systems).

Thanks,
Simon

Nov 8 '07 #1
Share this Question
Share on Google+
4 Replies


P: n/a
*prod* Any Microsoft support people around? Or do I have to start
emailing people I know on the .NET team?

On Nov 8, 1:51 am, specte...@gmail.com wrote:
Hey folks;

I've got a weird problem... whenever I try to drag and drop a toolbox
item onto a form in the Window Forms editor, the control is
automatically added on the first click.

This gives me very little control over where it ends up, and as you
can imagine, is somewhat inconvenient.

Anyone know a fix for this? My work system doesn't do this.

(VS 2005 SP1 Pro on both systems).

Thanks,
Simon

Nov 14 '07 #2

P: n/a
sp*******@gmail.com's wild thoughts were released on Tue, 13
Nov 2007 23:14:59 -0800 bearing the following fruit:
>*prod* Any Microsoft support people around? Or do I have to start
emailing people I know on the .NET team?

On Nov 8, 1:51 am, specte...@gmail.com wrote:
>Hey folks;

I've got a weird problem... whenever I try to drag and drop a toolbox
item onto a form in the Window Forms editor, the control is
automatically added on the first click.

This gives me very little control over where it ends up, and as you
can imagine, is somewhat inconvenient.

Anyone know a fix for this? My work system doesn't do this.

(VS 2005 SP1 Pro on both systems).

Thanks,
Simon
I think the reason you didn't get any replies is that your
post was a little confusing, I know I couldn't work out
exactly what you were getting at.

--
Jan Hyde

https://mvp.support.microsoft.com/profile/Jan.Hyde
Nov 15 '07 #3

P: n/a
On Nov 15, 4:42 am, "Jan Hyde (VB MVP)"
<StellaDrin...@REMOVE.ME.uboot.comwrote:
specte...@gmail.com's wild thoughts were released on Tue, 13
Nov 2007 23:14:59 -0800 bearing the following fruit:


*prod* Any Microsoft support people around? Or do I have to start
emailing people I know on the .NET team?
On Nov 8, 1:51 am, specte...@gmail.com wrote:
Hey folks;
I've got a weird problem... whenever I try to drag and drop a toolbox
item onto a form in the Window Forms editor, the control is
automatically added on the first click.
This gives me very little control over where it ends up, and as you
can imagine, is somewhat inconvenient.
Anyone know a fix for this? My work system doesn't do this.
(VS 2005 SP1 Pro on both systems).
Thanks,
Simon

I think the reason you didn't get any replies is that your
post was a little confusing, I know I couldn't work out
exactly what you were getting at.
What I'm seeing with most controls is something like this:
Open a blank form in Winforms.
Try to drag a splitter panel over.
When I click on the toolbox item to start dragging (drag is click and
hold, then move and finally release), the initial click (even though
I'm still holding the mouse button) immediately adds the control to
the Form.

With panels etc. this is infuriating, because you need to be able to
drag them into the right parent panel.

Others have seen something similar; this issue goes back a while, but
it seems pretty rare. I've tried nuking my VIsual Studio settings, but
it doesn't fix it.
Nov 16 '07 #4

P: n/a
Hey Jan... just checking - did that help at all?

On Nov 15, 4:24 pm, Simon Cooke <specte...@gmail.comwrote:
On Nov 15, 4:42 am, "Jan Hyde (VB MVP)"

<StellaDrin...@REMOVE.ME.uboot.comwrote:
specte...@gmail.com's wild thoughts were released on Tue, 13
Nov 2007 23:14:59 -0800 bearing the following fruit:
>*prod* Any Microsoft support people around? Or do I have to start
>emailing people I know on the .NET team?
>On Nov 8, 1:51 am, specte...@gmail.com wrote:
>Hey folks;
>I've got a weird problem... whenever I try to drag and drop a toolbox
>item onto a form in the Window Forms editor, the control is
>automatically added on the first click.
>This gives me very little control over where it ends up, and as you
>can imagine, is somewhat inconvenient.
>Anyone know a fix for this? My work system doesn't do this.
>(VS 2005 SP1 Pro on both systems).
>Thanks,
>Simon
I think the reason you didn't get any replies is that your
post was a little confusing, I know I couldn't work out
exactly what you were getting at.

What I'm seeing with most controls is something like this:
Open a blank form in Winforms.
Try to drag a splitter panel over.
When I click on the toolbox item to start dragging (drag is click and
hold, then move and finally release), the initial click (even though
I'm still holding the mouse button) immediately adds the control to
the Form.

With panels etc. this is infuriating, because you need to be able to
drag them into the right parent panel.

Others have seen something similar; this issue goes back a while, but
it seems pretty rare. I've tried nuking my VIsual Studio settings, but
it doesn't fix it.- Hide quoted text -

- Show quoted text -
Nov 19 '07 #5

This discussion thread is closed

Replies have been disabled for this discussion.