472,811 Members | 1,183 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,811 software developers and data experts.

ERROR: The type 'frm_data.frm_data' is defined in an assembly that is not referenced.

Language :: VS.NET/ C#

The type 'frm_data.frm_data' is defined in an assembly that is not referenced. You must add a reference to assembly

I have a Frm_sol solution, which consists on 2 projects
FRM_Business and frm_Data.

I build the 2 projects and copied the dlls created from them, to another Solution having a Sample_website, sample_business and Sample_Data.

So now
Sample_bl is having reference of Sample_dl project
and in
Sample_dl project i added a reference for frm_data.dll and made a function call to a method of frm_data.dll from inside a method of sample_dl. It works.

But, as soon as i try to inherit from a class in frm_data.dll to sample_bl projects class. it builds.
But, Sample_bl on build gives an error ::

Error 1 The type 'frm_data.frm_data' is defined in an assembly that is not referenced. You must add a reference to assembly 'framework_dl, Version=, Culture=neutral, PublicKeyToken=72fb7114fd4e6ef7'. C:\Temp\Test_Project\Sample\Sample_bl\components\S amplecomponent_bl.cs 16 13 Sample_bl

Please help. Basically i want to create dll's for the layered projects and want to use in another layered application.

Sep 30 '07 #1
0 1193

Sign in to post your reply or Sign up for a free account.

Similar topics

by: Jean Stax | last post by:
Hi ! I created a sample library project. In my second project I reference this library and make the following call, which returns "undefined value": Type myType =...
by: Raterus | last post by:
I'm just throwing this error out for my sanity, I've seen posts about this, but never solutions. I'm using VS.NET 2003, Framework 1.1, and I'm getting a random error about every 1 out of 10 times...
by: JTrigger | last post by:
When I compile my project using the IDE on a development machine it works just fine. When I compile it on the server using csc.exe, I get the following error when I try to bring it up in the web...
by: Paul van Brenk | last post by:
Hi, after installing sp1 on windows 2003 I get the following error when accessing an aspx page in an otherwise asp application: error: Unable to generate a temporary class (result=1). error...
by: Vish | last post by:
Hi all, I am having a build error in one of the overloaded functions in my class. The function takes either a string as a parameter or a type referenced in another dll as a parameter. My class...
by: Omatase | last post by:
Here is my code: CDO.Message iMessage = new CDO.MessageClass(); string sFrom; string sDate; iMessage.DataSource.Open(bstrURLItem,null, ADODB.ConnectModeEnum.adModeRead,...
by: erik.erikson | last post by:
I am getting a compiler error that I can't well explain or even understand the origin of (though I boiled it down close...). Below is a bare-bones example. What I am doing is defining the...
by: rautsmita | last post by:
hello friends , i am using to jdk6 and JAXB2.0, i have geomtry.xsd file i am trying to compile this file using jaxb but i got some error i.e.The particle of the type is not a valid restriction of...
by: ma79ash | last post by:
Language :: VS.NET/ C# The type 'frm_data.frm_data' is defined in an assembly that is not referenced. You must add a reference to assembly I have a Frm_sol solution, which consists on 2...
by: linyimin | last post by:
Spring Startup Analyzer generates an interactive Spring application startup report that lets you understand what contributes to the application startup time and helps to optimize it. Support for...
by: erikbower65 | last post by:
Here's a concise step-by-step guide for manually installing IntelliJ IDEA: 1. Download: Visit the official JetBrains website and download the IntelliJ IDEA Community or Ultimate edition based on...
by: kcodez | last post by:
As a H5 game development enthusiast, I recently wrote a very interesting little game - Toy Claw ((http://claw.kjeek.com/))。Here I will summarize and share the development experience here, and hope it...
by: Taofi | last post by:
I try to insert a new record but the error message says the number of query names and destination fields are not the same This are my field names ID, Budgeted, Actual, Status and Differences ...
by: DJRhino1175 | last post by:
When I run this code I get an error, its Run-time error# 424 Object required...This is my first attempt at doing something like this. I test the entire code and it worked until I added this - If...
by: Rina0 | last post by:
I am looking for a Python code to find the longest common subsequence of two strings. I found this blog post that describes the length of longest common subsequence problem and provides a solution in...
by: DJRhino | last post by:
Private Sub CboDrawingID_BeforeUpdate(Cancel As Integer) If = 310029923 Or 310030138 Or 310030152 Or 310030346 Or 310030348 Or _ 310030356 Or 310030359 Or 310030362 Or...
by: lllomh | last post by:
How does React native implement an English player?
by: DJRhino | last post by:
Was curious if anyone else was having this same issue or not.... I was just Up/Down graded to windows 11 and now my access combo boxes are not acting right. With win 10 I could start typing...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.