By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,564 Members | 834 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,564 IT Pros & Developers. It's quick & easy.

Oracle 10g connection with .NET OLEDB Provider TNS Protocol Adapter Error

P: 1
A unique issue has cropped up today in a .NET program I developed. It has been working fine for over an year until now.

The program makes 2 connections total - one to a UNIT instance and another to TEST instance. Both instances are running Oracle 10g. The program is able to connect (using OLEDB provider) to both the instances separately one-at-a-time. However, when attempting to open the second connection while the first is already open, it throws an Oledb error: TNS could not resolve service name. The order in which the connections are opened is not significant i.e. if UNIT is connected to successfully, it does not connect to TEST and vice-versa.

The sqlnet.log created due to this reports this error: ORA-12560: TNS:protocol adapter error.

Point to note is that the issue is specific to the combination of TEST and UNIT instances. Program works fine with other combination of instances e.g. one connection to UNIT and another to STAGE .

Appreciate any help to resolve this.
Jul 21 '07 #1
Share this question for a faster answer!
Share on Google+

Post your reply

Sign in to post your reply or Sign up for a free account.