By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,247 Members | 871 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,247 IT Pros & Developers. It's quick & easy.

RequiredFieldValidator disables LinkButton

P: 1
At least someone is reading this, thanks ;-)


I am working in VWD 2005 Express - ASP.NET 2.0 - FrameWork 2.0 - XP Pro - IE 6.0 all with the latest ServicePacks.

I have a form with RequiredFieldValidator for a TextBox, and a LinkButton.

The RequiredFieldValidator prevents firering the Linkbutton even if LinkButton RequiresValidation = False.
and even if I placed the RequiredFieldValidator in Validation-Groeps they still wont let Linkbutton do his job.

The fieldvalidators dit not fire the error-message at all !? Just gave in the status bar 'error on the page'

I added a simple test at http://www.yebbee.com/test2.aspx, with 1 RequiredFieldValidator next to the textbox.
The linkbutton does not require validation.

I wonder why this does not happen in IE7 or in the DebugMode.
There must be a fix or workaround for this (I hope)

I search further ...
or does anyone (you maybe ?) know how to fix this.

Have a nice day

Bonaparte
Jul 6 '07 #1
Share this Question
Share on Google+
1 Reply


TRScheel
Expert 100+
P: 638
Assuming I understand your problem,

A LinkButton forces a postback. If anything on the form requires validation, it will not allow the postback to fire, effectively disabling your link button. You could disable the validation if its not being used, and that would let the LinkButton postback.
Jul 6 '07 #2

Post your reply

Sign in to post your reply or Sign up for a free account.