469,350 Members | 1,830 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,350 developers. It's quick & easy.

[IIS 7.0]Handler for asmx page ?

Hi there,

When I try to access a Web service running on my default Web site, on Vista
and IIS 7.0, I get an error message : "the MIME type is not recognized". So
I guess that the asmx handler is not configured ???

Regards
Jun 18 '07 #1
7 11005

"Oriane" <or****@guermantes.frwrote in message
news:58**********************************@microsof t.com...
Hi there,

When I try to access a Web service running on my default Web site, on
Vista and IIS 7.0, I get an error message : "the MIME type is not
recognized". So I guess that the asmx handler is not configured ???
Well, go check the MIME types on the Web server and see if .asmx is in
there.

Jun 18 '07 #2
The .asmx extension is automatically recognized by the ASP.NET runtime. So I
think what you really need to check is whether ASP.NET is "enabled". In IIS
7.0, nothing is enabled by default - you have to "turn it on".
Peter

--
Site: http://www.eggheadcafe.com
UnBlog: http://petesbloggerama.blogspot.com
Short urls & more: http://ittyurl.net


"Oriane" wrote:
Hi there,

When I try to access a Web service running on my default Web site, on Vista
and IIS 7.0, I get an error message : "the MIME type is not recognized". So
I guess that the asmx handler is not configured ???

Regards

Jun 18 '07 #3
On Jun 18, 11:10 am, "Oriane" <ori...@guermantes.frwrote:
Hi there,

When I try to access a Web service running on my default Web site, on Vista
and IIS 7.0, I get an error message : "the MIME type is not recognized". So
I guess that the asmx handler is not configured ???

Regards
There is a chance that ASP.NET is not registered properly with IIS.
This has happened to me and I had to run asp_regiis.exe to re-register
it.

1. Open a command prompt and go to the Microsoft.Net Framework version
directory,
e.g. cd C:\Winnt\Microsoft.net\Framework\v2.0.50727\

2 Run the asp_regiis.exe program with -i
e.g. asp_regiis -i

Not sure if you have to restart IIS or not

Another test is to create a simple aspx web page and see if you can
access it. Possibly it will give you a better error message than a
web service method does.

Ron

Jun 18 '07 #4
Hi Peter,
"Peter Bromberg [C# MVP]" <pb*******@yahoo.yabbadabbadoo.coma écrit dans
le message de news: 7A**********************************@microsoft.com...
The .asmx extension is automatically recognized by the ASP.NET runtime. So
I
think what you really need to check is whether ASP.NET is "enabled". In
IIS
7.0, nothing is enabled by default - you have to "turn it on".
So how do I do that ?

Regards
Jun 18 '07 #5

"Oriane" <or****@guermantes.frwrote in message
news:ew**************@TK2MSFTNGP06.phx.gbl...
Hi Peter,
"Peter Bromberg [C# MVP]" <pb*******@yahoo.yabbadabbadoo.coma écrit dans
le message de news: 7A**********************************@microsoft.com...
>The .asmx extension is automatically recognized by the ASP.NET runtime.
So I
think what you really need to check is whether ASP.NET is "enabled". In
IIS
7.0, nothing is enabled by default - you have to "turn it on".
So how do I do that ?
Your friend is Google.
http://intersoftpt.wordpress.com/200...-in-vista-rtm/

Jun 19 '07 #6
Hi Ron,
<ro*************@yahoo.coma écrit dans le message de
news:11**********************@q69g2000hsb.googlegr oups.com...
On Jun 18, 11:10 am, "Oriane" <ori...@guermantes.frwrote:
>Hi there,

When I try to access a Web service running on my default Web site, on
Vista
and IIS 7.0, I get an error message : "the MIME type is not recognized".
So
I guess that the asmx handler is not configured ???

Regards

There is a chance that ASP.NET is not registered properly with IIS.
This has happened to me and I had to run asp_regiis.exe to re-register
it.
It would be a shame as Asp.Net is preinstalled on Vista !!!

Oriane

Jun 19 '07 #7
Hi Mr Arnold,

"Mr. Arnold" <MR. Ar****@Arnold.coma écrit dans le message de
news:Ow**************@TK2MSFTNGP05.phx.gbl...
>
"Oriane" <or****@guermantes.frwrote in message
news:ew**************@TK2MSFTNGP06.phx.gbl...
>Hi Peter,
"Peter Bromberg [C# MVP]" <pb*******@yahoo.yabbadabbadoo.coma écrit
dans le message de news:
7A**********************************@microsoft.com...
>>The .asmx extension is automatically recognized by the ASP.NET runtime.
So I
think what you really need to check is whether ASP.NET is "enabled". In
IIS
7.0, nothing is enabled by default - you have to "turn it on".
So how do I do that ?

Your friend is Google.
http://intersoftpt.wordpress.com/200...-in-vista-rtm/
I don't understand why "IIS 7.0 help" is not my friend.
Thanks for the link, it works now :-))

Oriane

Jun 19 '07 #8

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Erik Lindeblom | last post: by
reply views Thread by jeff | last post: by
1 post views Thread by Nalaka | last post: by
18 posts views Thread by =?Utf-8?B?Tm9ybUQ=?= | last post: by
7 posts views Thread by Oriane | last post: by
2 posts views Thread by =?Utf-8?B?YW5vbg==?= | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
1 post views Thread by Marylou17 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.