By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
458,013 Members | 1,167 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 458,013 IT Pros & Developers. It's quick & easy.

Disabling WS-Addressing in a WS client

P: n/a
We have a client that uses .Net that needs to work against our Java (xfire)
based WS.
My question is: how can a .Net (C#) WS client be configured to not send
WS-Addressing headers? The client in particular mentions having tried WSE
2.0, and WSE 3.0, and says there is no way to turn off WS-Addressing in a WS
client, using those frameworks. I find that very hard to believe.

There appears to be a problem w/ WS-Addressing headers in the requests they
send us. In particular, i had to get rid of the following headers to be able
to re-play their request.
wsa:Action
wsa:MessageID
wsa:ReplyTo
wsa:To
wsu:Timestamp (also appears to be a problem)
Where
xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/03/addressing"
xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd"

On our end, WS-Addressing is not enabled by the WS framework by default,
unless a handler is added in the WS config, and we haven't added one, because
we don't need to use it.

Thanks.
Jun 11 '07 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I have the same issue to remove the ws-addressing from the soap header,
If you have got the answer, please tell me.
Thanks in advance.

xy***@compositesw.com
Philip

"ultranet" wrote:
We have a client that uses .Net that needs to work against our Java (xfire)
based WS.
My question is: how can a .Net (C#) WS client be configured to not send
WS-Addressing headers? The client in particular mentions having tried WSE
2.0, and WSE 3.0, and says there is no way to turn off WS-Addressing in a WS
client, using those frameworks. I find that very hard to believe.

There appears to be a problem w/ WS-Addressing headers in the requests they
send us. In particular, i had to get rid of the following headers to be able
to re-play their request.
wsa:Action
wsa:MessageID
wsa:ReplyTo
wsa:To
wsu:Timestamp (also appears to be a problem)
Where
xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/03/addressing"
xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd"

On our end, WS-Addressing is not enabled by the WS framework by default,
unless a handler is added in the WS config, and we haven't added one, because
we don't need to use it.

Thanks.
Jun 16 '07 #2

This discussion thread is closed

Replies have been disabled for this discussion.