469,327 Members | 1,335 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,327 developers. It's quick & easy.

Visual Studio 2005 ASP NET 2.0 Publish Website issues.

Hi

Hi someone can help me please.

I have a ASP NET 2.0 website with more than 10 web page (aspx).

When I do debug, anything working fine.
Then I publish, it is fine too, and I upload to server.

It is many error about precompiled items in my aspx.

Then I re-publish again WITHOUT CHECK the checkbox ->allow this precompiled site to be updatable.

Anything working fine now.

CHECK or UNCHECK this option, what is the concern?
Jun 4 '07 #1
27 10322
Frinavale
9,735 Expert Mod 8TB
Hi

Hi someone can help me please.

I have a ASP NET 2.0 website with more than 10 web page (aspx).

When I do debug, anything working fine.
Then I publish, it is fine too, and I upload to server.

It is many error about precompiled items in my aspx.

Then I re-publish again WITHOUT CHECK the checkbox ->allow this precompiled site to be updatable.

Anything working fine now.

CHECK or UNCHECK this option, what is the concern?
Seems like a strange problem to me. Everything should work fine without allowing the site to be updateable.

When you publish the site and allow the it to be updatable your source code is copied to the publish destination. If you uncheck this option, Visual Studio does a compile and objects that do not contain your code are copied to the destination.

Checking or un-checking this option should not make a difference to how your website works.

-Frinny
Jun 4 '07 #2
Plater
7,872 Expert 4TB
Well what bothers me is the "then i upload it to my server".
That's not how this game works.
Your website must be installed/published to the place where it's going to be running. The IIS server has to know about it and it has to know how to run the backend. The "Publish" should be doing the uploading to your server.
Jun 4 '07 #3
Frinavale
9,735 Expert Mod 8TB
Well what bothers me is the "then i upload it to my server".
The "Publish" should be doing the uploading to your server.
I've never been able to get this to work properly..I've always had to publish the website and the move it to my server manually. I've never had any problems, but then again I've always set up the web server exactly the same as my development server.

How do you get this to work??
Jun 4 '07 #4
Plater
7,872 Expert 4TB
I've never been able to get this to work properly..I've always had to publish the website and the move it to my server manually. I've never had any problems, but then again I've always set up the web server exactly the same as my development server.

How do you get this to work??
The publish option lets you pick where to publish to. I chose my IIS server (the other computer that actually hosts the website) You have to be sure to setup the FrontPage Extenions (SharePoint) in order for the deploy to work.

(as a side note, they tell you installing the frontpage extensions changes file permisions and might screw up ftp, just a warning)
Jun 4 '07 #5
Frinavale
9,735 Expert Mod 8TB
You have to be sure to setup the FrontPage Extenions (SharePoint) in order for the deploy to work.
That's probably my problem.
I'll try this out! Thanks!
Jun 4 '07 #6
maghi85
28
hi,

i too just downloaded microsoft visual studio 2005
i've just put one page on my ASP website

its got a bit of text and a few textboxes with a button
all ASP.NET controls
when i build it the website runs fine
but when i publish it to my website i keep getting this error

it looks like below


Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
Jun 11 '07 #7
Frinavale
9,735 Expert Mod 8TB
hi,

i too just downloaded microsoft visual studio 2005
i've just put one page on my ASP website

its got a bit of text and a few textboxes with a button
all ASP.NET controls
when i build it the website runs fine
but when i publish it to my website i keep getting this error

it looks like below

...
Hi Maghi!
Welcome to TDSN.

Your error message is really vague.
Could you possibly change your web.config file so that
Expand|Select|Wrap|Line Numbers
  1. <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
  2.  
is changed to
Expand|Select|Wrap|Line Numbers
  1. <customErrors mode="Off" defaultRedirect="mycustompage.htm"/>
  2.  
Then re-publish your website and run it.
This will let you see a more descriptive error message...post it here so that we can help you out :)

Thanks,

-Frinny
Jun 11 '07 #8
nateraaaa
663 Expert 512MB
Maghi85 it sounds like there may be a problem with your web.config file. Try adding the following to your web.config file

<identity impersonate="true" />

I usually add this line above <authentication mode="Windows" />

Save your web.config file and try running your application again.

Nathan
Jun 11 '07 #9
Plater
7,872 Expert 4TB
That is telling you there is an error in your code, however, instead of telling you all the details it is hiding them for security reasons. For developement purposes, you cna change the settings they tell you to so that you can see what the error details are.
Jun 11 '07 #10
Frinavale
9,735 Expert Mod 8TB
Maghi85 it sounds like there may be a problem with your web.config file. Try adding the following to your web.config file

<identity impersonate="true" />

I usually add this line above <authentication mode="Windows" />

Save your web.config file and try running your application again.

Nathan
Impersonation changes the web user to be a different user...there are security issues that must be taken into consideration when you use this.

I don't think this is necessary to use impersonation yet seeing as we don't even know what the error really is.

-Frinny
Jun 11 '07 #11
maghi85
28
i'm running on a Vista with an IIS 7.0
updating the web.config file and publishing it on to the ftp website gave me the same error
but then i hosted it on to an IIS server on my machine and its working
how do you transfer the website from IIS server on my machine to an ftp website?
Jun 11 '07 #12
Frinavale
9,735 Expert Mod 8TB
i'm running on a Vista with an IIS 7.0
updating the web.config file and publishing it on to the ftp website gave me the same error
but then i hosted it on to an IIS server on my machine and its working
how do you transfer the website from IIS server on my machine to an ftp website?
You can just use an ftp client like CuteFTP or WSFTP etc. Just transfer all of the files to your web server.
Jun 11 '07 #13
maghi85
28
You can just use an ftp client like CuteFTP or WSFTP etc. Just transfer all of the files to your web server.

just did that
and it gives the initial error
Jun 11 '07 #14
Plater
7,872 Expert 4TB
If you want to see your errors, in your web.config file change the lines to be
Expand|Select|Wrap|Line Numbers
  1. <customErrors mode="Off"/>
  2.  
Jun 11 '07 #15
Frinavale
9,735 Expert Mod 8TB
just did that
and it gives the initial error
How did you upload your project before?
Jun 11 '07 #16
maghi85
28
the same way but without publishing on IIS application first
Jun 11 '07 #17
maghi85
28
If you want to see your errors, in your web.config file change the lines to be
Expand|Select|Wrap|Line Numbers
  1. <customErrors mode="Off"/>
  2.  
did that but it gives me the first error
Jun 11 '07 #18
Frinavale
9,735 Expert Mod 8TB
did that but it gives me the first error
Are you in control of the webserver?
I'd suggest rebooting it if you are.
Once you change that line in your web.config your error message should change.
Jun 11 '07 #19
Frinavale
9,735 Expert Mod 8TB
the same way but without publishing on IIS application first
Wait a sec.
Make sure that you publish your website to your web server directly after making the changes to your web.config file.
If you can't publish directly, then publish it the same way you did before and move the whole thing to your web server using an ftp client.

-Frinny
Jun 11 '07 #20
maghi85
28
same error
i suppose its the hosting site...
i'll confirm with them if they actually do support ASP.NET
Jun 11 '07 #21
maghi85
28
is there a freeweb website with ASP.NET support so that i could test it on?
like yahoopages
Jun 11 '07 #22
Frinavale
9,735 Expert Mod 8TB
is there a freeweb website with ASP.NET support so that i could test it on?
like yahoopages

Are you sure they are using the same .NET Framework version as you have coded in? If you've used Visual Studio 2003 make sure the server supports .NET Framework 1.1. If you used Visual Studio 2005 make sure the server supports .NET Framework 2.
Jun 11 '07 #23
When I upload my ASP.NET 2.0 apps I usually have to go into the server and find the virtual folder containing my application and change the settings so it is registered as an ASP.NET 2.0 instead of ASP.Net 1.1

If you have both ASP 2.0 and 1.1 framework installed then you might have to specify which technology this application should use.
Jun 11 '07 #24
maghi85
28
sorry folks
i just registered with a new host and have confirmed that they do provide .net framework 2.0
now atleast i see the error
and this is it =)

Server Error in '/' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:


Line 49: ASP.NET to identify an incoming user.
Line 50: -->
Line 51: <authentication mode="None" />
Line 52: <!--
Line 53: The <customErrors> section enables configuration


Source File: E:\web\tarimsoluti\htdocs\fss\web.config Line: 51


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.210


what to do what to do ??
Jun 14 '07 #25
Frinavale
9,735 Expert Mod 8TB
Try changing
Expand|Select|Wrap|Line Numbers
  1. <authentication mode="None" />
  2.  
to
Expand|Select|Wrap|Line Numbers
  1. <authentication mode="Windows" />
  2.  
in your web.config.

Hopefully that works!

-Frinny
Jun 14 '07 #26
maghi85
28
it works now
thanks all you folks
Jun 14 '07 #27
Frinavale
9,735 Expert Mod 8TB
it works now
thanks all you folks
Good Stuff!

:)

-Frinny
Jun 14 '07 #28

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

6 posts views Thread by Mark Sandfox | last post: by
8 posts views Thread by WT | last post: by
3 posts views Thread by DBLWizard | last post: by
5 posts views Thread by cj | last post: by
10 posts views Thread by =?Utf-8?B?UmljaGFyZA==?= | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by listenups61195 | last post: by
reply views Thread by Purva khokhar | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.