469,288 Members | 2,357 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,288 developers. It's quick & easy.

2.0: "Debugging failed because integrated Windows authentication in not enabled."

Hello,
I am writing my first ASP.NET application (I use .NET 2.0, Visual Web
Developer 2005 Express Edition and SQL Server 2005 Express Edition).
The application builds successfully but when I try to start debugging from
Visual Web Developer I receive message box:

Unable to start debugging on the web server. Debugging failed because
integrated Windows authentication in not enabled.

But I want to use forms authentication! Here is my web.config (I use Polish
language so some letters look strange):
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

<appSettings>

<add key="ApplicationName" value="MIMMagazyn"/>

<add key="Wersja" value="0.1"/>

<add key="DomyślnaBaza" value="MIMMagazynDemo"/>

<add key="BazaDemo" value="MIMMagazynDemo"/>

<add key="UÁytkownikDemo" value="demo"/>

<add key="IleMiesiCcyWLogu" value="1"/>

</appSettings>

<connectionStrings>

<add name="MIMMagazyn_Demo" connectionString="Data
Source=.\SQLEXPRESS;AttachDBFileName=|DataDirector y|\MIMMagazynDemo.mdf;Initial
Catalog=MIMMagazynDemo;uid=sa;pwd=sqlserver"
providerName="System.Data.SqlClient" />

<add name="SqlServices" connectionString="Data
Source=.\SQLEXPRESS;AttachDBFileName=|DataDirector y|\aspnetdb.mdf;uid=sa;pwd=sqlserver"
/>

</connectionStrings>

<system.web>

<roleManager enabled="true" />

<compilation debug="true"/>

<profile defaultProvider="SqlProvider">

<providers>

<clear />

<add name="SqlProvider"

type="System.Web.Profile.SqlProfileProvider"

connectionStringName="SqlServices"

applicationName="MIMMagazyn" />

</providers>

<properties>

<add name="ImiCINazwisko" type="String" />

<add name="DomyślnyKodSkładu" type="String" />

<add name="DomyślnyKodGrupy" type="String" />

<add name="AdministracjaUÁytkownikami" type="Boolean" defaultValue="False"
/>

<add name="Konfiguracja" type="Boolean" defaultValue="False" />

<add name="Uwagi" type="String" />

</properties>

</profile>

<authentication mode="Forms">

<forms name="MIMMagazyn" loginUrl="Logowanie.aspx" />

</authentication>

<authorization>

<deny users="?" />

</authorization>

<customErrors mode="RemoteOnly" defaultRedirect="Błíd.aspx">

</customErrors>

<sessionState mode="InProc"

cookieless="false"

timeout="20"/>

</system.web>

</configuration>

Could you help me please? Thank you!
/RAM/
May 3 '07 #1
4 9322

"R.A.M." <r_********@poczta.onet.plwrote in message
news:u3**************@TK2MSFTNGP03.phx.gbl...
Hello,
I am writing my first ASP.NET application (I use .NET 2.0, Visual Web
Developer 2005 Express Edition and SQL Server 2005 Express Edition).
The application builds successfully but when I try to start debugging from
Visual Web Developer I receive message box:

Unable to start debugging on the web server. Debugging failed because
integrated Windows authentication in not enabled.
<snipped>

The .NET IDE and its Debugger have nothing to do with Forms authentication
being used by an ASP.NET application and authentication of a user's access
rights within said application.

You should give the .NET IDE what it wants in order to circumvent the error
condition you're having when trying to debug the solution in the IDE.
May 3 '07 #2
The .NET IDE and its Debugger have nothing to do with Forms authentication
being used by an ASP.NET application and authentication of a user's access
rights within said application.
Thanks.
You should give the .NET IDE what it wants in order to circumvent the
error condition you're having when trying to debug the solution in the
IDE.
I don't know how to solve the problem...
May 3 '07 #3

"R.A.M." <r_********@poczta.onet.plwrote in message
news:%2****************@TK2MSFTNGP04.phx.gbl...
>The .NET IDE and its Debugger have nothing to do with Forms
authentication being used by an ASP.NET application and authentication of
a user's access rights within said application.

Thanks.
>You should give the .NET IDE what it wants in order to circumvent the
error condition you're having when trying to debug the solution in the
IDE.

I don't know how to solve the problem...
I'll get you this far. It talks about it in this article.

You can use Google and (track it down/do the research) on how to set it.

Google is your friend.

http://weblogs.asp.net/rosherove/articles/3695.aspx

May 3 '07 #4
Thank you!
(My English is not perfect, I haven't understood you.)

Uzytkownik "Mr. Arnold" <MR. Ar****@Arnold.comnapisal w wiadomosci
news:76**********************************@microsof t.com...
>
"R.A.M." <r_********@poczta.onet.plwrote in message
news:%2****************@TK2MSFTNGP04.phx.gbl...
>>The .NET IDE and its Debugger have nothing to do with Forms
authentication being used by an ASP.NET application and authentication
of a user's access rights within said application.

Thanks.
>>You should give the .NET IDE what it wants in order to circumvent the
error condition you're having when trying to debug the solution in the
IDE.

I don't know how to solve the problem...

I'll get you this far. It talks about it in this article.

You can use Google and (track it down/do the research) on how to set it.

Google is your friend.

http://weblogs.asp.net/rosherove/articles/3695.aspx

May 3 '07 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Zhong Guan | last post: by
2 posts views Thread by Karun Karunakaran | last post: by
2 posts views Thread by Andrzej Magdziarz | last post: by
1 post views Thread by inungh | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.