By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
431,650 Members | 753 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 431,650 IT Pros & Developers. It's quick & easy.

Windows Application, Web Services & Session cookieless="AutoDetect

P: n/a
I'm having an issue with using web services in a web application marked with
session cookieless attribuet set to "AutoDetect". My real life scenario is
too complex to lay out but here's my situation boiled down to the nuts and
bolts...

1. Create a simple web application (not a web site) in VS 2005

2. Add a web.config and then set the Session to InProc and
cookieless="Autodetect"
<sessionState mode="InProc" cookieless="AutoDetect" timeout="15" />

3. Add a simple web service (WebService.asmx)
/// <summary>
/// Summary description for WebService1
/// </summary>
[WebService(Namespace = "http://tempuri.org/")]
[WebServiceBinding(ConformsTo = WsiProfiles.BasicProfile1_1)]
[ToolboxItem(false)]
public class WebService1 : System.Web.Services.WebService
{

[WebMethod]
public string HelloWorld()
{
return "Hello World";
}
}

4. Compile and publish to your localhost.

5. Create a simple Winforms application and try to add a web reference to
the project. When you enter the Url of the .asmx file on your localhost, it
finds the service, but in the right side of the "Add A Web Reference" dialog
you'll get the following error and can't add the web reference...

There was an error downloading
'http://localhost/webmethodcookielesstest/webservice1.asmx'.

The request failed with the error message:
--
<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a
href="/webmethodcookielesstest/webservice1.asmx?AspxAutoDetectCookieSupport=1">he re</a>.</h2>
</body></html>

--.

If I go back and mark the session cookieless attribute in the web config to
"True" or "false", it works fine. Am I the only one this is happening to?

Any help would be greatly appreciated.

Mike Goppert
mi**********@eds.com
Apr 26 '07 #1
Share this Question
Share on Google+
3 Replies


P: n/a
"mgoppert" <mi**********@integrasys.fiserv.comwrote in message
news:91**********************************@microsof t.com...
I'm having an issue with using web services in a web application marked
with
session cookieless attribuet set to "AutoDetect". My real life scenario
is
too complex to lay out but here's my situation boiled down to the nuts and
bolts...

1. Create a simple web application (not a web site) in VS 2005

2. Add a web.config and then set the Session to InProc and
cookieless="Autodetect"
<sessionState mode="InProc" cookieless="AutoDetect" timeout="15" />

3. Add a simple web service (WebService.asmx)
/// <summary>
/// Summary description for WebService1
/// </summary>
[WebService(Namespace = "http://tempuri.org/")]
[WebServiceBinding(ConformsTo = WsiProfiles.BasicProfile1_1)]
[ToolboxItem(false)]
public class WebService1 : System.Web.Services.WebService
{

[WebMethod]
public string HelloWorld()
{
return "Hello World";
}
}

4. Compile and publish to your localhost.

5. Create a simple Winforms application and try to add a web reference to
the project. When you enter the Url of the .asmx file on your localhost,
it
finds the service, but in the right side of the "Add A Web Reference"
dialog
you'll get the following error and can't add the web reference...

There was an error downloading
'http://localhost/webmethodcookielesstest/webservice1.asmx'.

The request failed with the error message:
--
<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a
href="/webmethodcookielesstest/webservice1.asmx?AspxAutoDetectCookieSupport=1">he re</a>.</h2>
</body></html>

--.

If I go back and mark the session cookieless attribute in the web config
to
"True" or "false", it works fine. Am I the only one this is happening to?

Any help would be greatly appreciated.

Mike Goppert
mi**********@eds.com
You should consider moving the web service to its own project. That's how
most people do it.
--

John Saunders [MVP]
Apr 26 '07 #2

P: n/a
I can't unfortunately. We're using a CMS system (Sitecore) that loads itself
in the same application space as our primary web. My web service needs to
access the Sitecore meta data via its API. The web service must reside in
the same application.

"John Saunders [MVP]" wrote:
"mgoppert" <mi**********@integrasys.fiserv.comwrote in message
news:91**********************************@microsof t.com...
I'm having an issue with using web services in a web application marked
with
session cookieless attribuet set to "AutoDetect". My real life scenario
is
too complex to lay out but here's my situation boiled down to the nuts and
bolts...

1. Create a simple web application (not a web site) in VS 2005

2. Add a web.config and then set the Session to InProc and
cookieless="Autodetect"
<sessionState mode="InProc" cookieless="AutoDetect" timeout="15" />

3. Add a simple web service (WebService.asmx)
/// <summary>
/// Summary description for WebService1
/// </summary>
[WebService(Namespace = "http://tempuri.org/")]
[WebServiceBinding(ConformsTo = WsiProfiles.BasicProfile1_1)]
[ToolboxItem(false)]
public class WebService1 : System.Web.Services.WebService
{

[WebMethod]
public string HelloWorld()
{
return "Hello World";
}
}

4. Compile and publish to your localhost.

5. Create a simple Winforms application and try to add a web reference to
the project. When you enter the Url of the .asmx file on your localhost,
it
finds the service, but in the right side of the "Add A Web Reference"
dialog
you'll get the following error and can't add the web reference...

There was an error downloading
'http://localhost/webmethodcookielesstest/webservice1.asmx'.

The request failed with the error message:
--
<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a
href="/webmethodcookielesstest/webservice1.asmx?AspxAutoDetectCookieSupport=1">he re</a>.</h2>
</body></html>

--.

If I go back and mark the session cookieless attribute in the web config
to
"True" or "false", it works fine. Am I the only one this is happening to?

Any help would be greatly appreciated.

Mike Goppert
mi**********@eds.com

You should consider moving the web service to its own project. That's how
most people do it.
--

John Saunders [MVP]
Apr 26 '07 #3

P: n/a
"mgoppert" <mi**********@integrasys.fiserv.comwrote in message
news:E9**********************************@microsof t.com...
>I can't unfortunately. We're using a CMS system (Sitecore) that loads
itself
in the same application space as our primary web. My web service needs to
access the Sitecore meta data via its API. The web service must reside in
the same application.
The API can't be accessed from a different application? That sounds strange.
--

John Saunders [MVP]
Apr 26 '07 #4

This discussion thread is closed

Replies have been disabled for this discussion.