By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,035 Members | 1,555 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,035 IT Pros & Developers. It's quick & easy.

System::ServiceModel problem

P: n/a
yy
when i try to compile my code with 'using namespace
System::ServiceModel' i get:
error C2039: 'ServiceModel' : is not a member of 'System'

i've installed WCF and WPF extensions for Visual Studio 2005 and after
that i see 'Net Framework 3.0' under C# new project, with WCF Service
Library... tried to Build the C# sample and it works... but in my C++/
CLI there is a problem with 'ServiceModel'...

any hints?

Apr 24 '07 #1
Share this Question
Share on Google+
3 Replies


P: n/a
when i try to compile my code with 'using namespace
System::ServiceModel' i get:
error C2039: 'ServiceModel' : is not a member of 'System'

i've installed WCF and WPF extensions for Visual Studio 2005 and after
that i see 'Net Framework 3.0' under C# new project, with WCF Service
Library... tried to Build the C# sample and it works... but in my C++/
CLI there is a problem with 'ServiceModel'...
There are no C++ plugins for WCF or WPF. If you want to use them you'd have
to manually add references to the correct assemblies. This is done
automatically in a C# W*F.
Check the C# project assembly references and add those references to your
C++ application.

--
Kind regards,
Bruno van Dooren MVP - VC++
http://msmvps.com/blogs/vanDooren
br**********************@hotmail.com
Apr 25 '07 #2

P: n/a
On Apr 25, 3:58 am, "Bruno van Dooren"
<bruno_nos_pam_van_doo...@hotmail.comwrote:
when i try to compile my code with 'using namespace
System::ServiceModel' i get:
error C2039: 'ServiceModel' : is not a member of 'System'
i've installed WCF and WPF extensions for Visual Studio 2005 and after
that i see 'Net Framework 3.0' under C# new project, with WCF Service
Library... tried to Build the C# sample and it works... but in my C++/
CLI there is a problem with 'ServiceModel'...

There are no C++ plugins for WCF or WPF. If you want to use them you'd have
to manually add references to the correct assemblies. This is done
automatically in a C# W*F.
Check the C# project assembly references and add those references to your
C++ application.

--
Kind regards,
Bruno van Dooren MVP - VC++
http://msmvps.com/blogs/vanDooren
bruno_nos_pam_van_doo...@hotmail.com
>From project property, add new reference and browse for
'system.servicemodel.dll' under
C:\WINDOWS\Microsoft.NET\Framework\v3.0\Windows Communication
Foundation.

zz

Apr 27 '07 #3

P: n/a

Ayon kay John:
On Apr 25, 3:58 am, "Bruno van Dooren"
<bruno_nos_pam_van_doo...@hotmail.comwrote:
when i try to compile my code with 'using namespace
System::ServiceModel' i get:
error C2039: 'ServiceModel' : is not a member of 'System'
i've installed WCF and WPF extensions for Visual Studio 2005 and after
that i see 'Net Framework 3.0' under C# new project, with WCF Service
Library... tried to Build the C# sample and it works... but in my C++/
CLI there is a problem with 'ServiceModel'...
There are no C++ plugins for WCF or WPF. If you want to use them you'd have
to manually add references to the correct assemblies. This is done
automatically in a C# W*F.
Check the C# project assembly references and add those references to your
C++ application.

--
Kind regards,
Bruno van Dooren MVP - VC++
http://msmvps.com/blogs/vanDooren
bruno_nos_pam_van_doo...@hotmail.com
From project property, add new reference and browse for
'system.servicemodel.dll' under
C:\WINDOWS\Microsoft.NET\Framework\v3.0\Windows Communication
Foundation.

zz
Hi John,
I've already fixed the problem by adding assembly reference.

-Netoko

Jun 17 '07 #4

This discussion thread is closed

Replies have been disabled for this discussion.