By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,994 Members | 2,090 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,994 IT Pros & Developers. It's quick & easy.

Easy question regarding console apps

P: n/a
Hi newbie here. I am learning c++/cli I by writing console apps. When my
apps finished they used to display a message at the bottom of the screen,
something like "press any key to continue" so that you could see the results
before returning to the IDE. But now they don't. I must have turned a
setting off somewhere but I can't find it. I could code it in but I would
prefer not to.

Any ideas?
Mar 27 '07 #1
Share this Question
Share on Google+
4 Replies


P: n/a
"Paul Hemans" <pa*************@laberg.com.auwrote in message
news:%2****************@TK2MSFTNGP05.phx.gbl...
Hi newbie here. I am learning c++/cli I by writing console apps. When my
apps finished they used to display a message at the bottom of the screen,
something like "press any key to continue" so that you could see the
results before returning to the IDE. But now they don't. I must have
turned a setting off somewhere but I can't find it.
Maybe. You get the prompt to close the console window when you choose to
execute your application without debugging it. When you debug it, it
executes to completion closing the console in the process.

You could choose to keep a console window open whose default directory is
the same as the location of the executable and then type its name to run it.
Ot you could add a read of the console just before you return. That will
force you to type something to quit.

Regards,
Will


Mar 28 '07 #2

P: n/a
Normally I press F5 to run the application, how do you execute an
application without debugging it? If I set the configuration to 'Release'
and press F5 the same thing happens.

"William DePalo [MVP VC++]" <wi***********@mvps.orgwrote in message
news:ON**************@TK2MSFTNGP02.phx.gbl...
"Paul Hemans" <pa*************@laberg.com.auwrote in message
news:%2****************@TK2MSFTNGP05.phx.gbl...
>Hi newbie here. I am learning c++/cli I by writing console apps. When my
apps finished they used to display a message at the bottom of the screen,
something like "press any key to continue" so that you could see the
results before returning to the IDE. But now they don't. I must have
turned a setting off somewhere but I can't find it.

Maybe. You get the prompt to close the console window when you choose to
execute your application without debugging it. When you debug it, it
executes to completion closing the console in the process.

You could choose to keep a console window open whose default directory is
the same as the location of the executable and then type its name to run
it. Ot you could add a read of the console just before you return. That
will force you to type something to quit.

Regards,
Will


Mar 28 '07 #3

P: n/a
In article <Ow**************@TK2MSFTNGP06.phx.gbl>,
Paul Hemans <pa*************@laberg.com.auwrote:
>Normally I press F5 to run the application, how do you execute an
application without debugging it? If I set the configuration to 'Release'
and press F5 the same thing happens.
Ctrl-F5 runs w/o attaching the debugger in the default key setup.
(It's in the menus as Debug -Start without Debugging if you don't
have the stock VC++ keybindings set.) Also, as English is read top to
bottom, please type your responses below what you're replying to.

Nathan Mates

--
<*Nathan Mates - personal webpage http://www.visi.com/~nathan/
# Programmer at Pandemic Studios -- http://www.pandemicstudios.com/
# NOT speaking for Pandemic Studios. "Care not what the neighbors
# think. What are the facts, and to how many decimal places?" -R.A. Heinlein
Mar 28 '07 #4

P: n/a
Ctrl-F5 runs w/o attaching the debugger in the default key setup.
(It's in the menus as Debug -Start without Debugging if you don't
have the stock VC++ keybindings set.) Also, as English is read top to
bottom, please type your responses below what you're replying to.
Thank you, I don't know how I missed that
Mar 28 '07 #5

This discussion thread is closed

Replies have been disabled for this discussion.