By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,357 Members | 1,021 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,357 IT Pros & Developers. It's quick & easy.

XML schema validation problem with XMLSpy

P: n/a
Hello,

I have the following XML schema fragment:

<xs:complexType name="type.1">
<xs:simpleContent>
<xs:restriction base="ns:type">
<xs:simpleType>
<xs:restriction base="xs:positiveInteger"/>
</xs:simpleType>
</xs:restriction>
</xs:simpleContent>
</xs:complexType>
<xs:complexType name="type">
<xs:simpleContent>
<xs:extension base="xs:anySimpleType">
<xs:attributeGroup ref="nx:att.group"/>
</xs:extension>
</xs:simpleContent>
</xs:complexType>
XMLSpy gives me the below error when I'm in the schema/WSDL view,
while the text view works fine:

File testSchema.xsd is not valid.
The content type (simpleType) of complexType "type.1" cannot restrict
simpleType 'anySimpleType'!
Is this a problem in my schema, or it's a bug in the XMLSPy validator

I'm using XMLSpy 2006 rel. 3 sp2

I tried one online schema validator, on the w3c site, and it didn't
complain.

Mar 9 '07 #1
Share this Question
Share on Google+
1 Reply


P: n/a
On Mar 9, 11:22 am, "Blue Doze" <blued...@gmail.comwrote:
Hello,

I have the following XML schema fragment:

<xs:complexType name="type.1">
<xs:simpleContent>
<xs:restriction base="ns:type">
<xs:simpleType>
<xs:restriction base="xs:positiveInteger"/>
</xs:simpleType>
</xs:restriction>
</xs:simpleContent>
</xs:complexType>
<xs:complexType name="type">
<xs:simpleContent>
<xs:extension base="xs:anySimpleType">
<xs:attributeGroup ref="nx:att.group"/>
</xs:extension>
</xs:simpleContent>
</xs:complexType>

XMLSpygives me the below error when I'm in the schema/WSDL view,
while the text view works fine:

File testSchema.xsd is not valid.
The content type (simpleType) of complexType "type.1" cannot restrict
simpleType 'anySimpleType'!

Is this a problem in my schema, or it's a bug in theXMLSPyvalidator

I'm usingXMLSpy2006 rel. 3 sp2

I tried one online schema validator, on the w3c site, and it didn't
complain.
Hello,

The Text View is correct so rely on that validation! I have reported
this issue to the development team for a fix so the error is not
raised in the Schema Design View. Please excuse us for the
inconvenience.

(http://www.altova.com )

Best regards,

.... Jerry Sheehan
.... Pre-Sales Engineer
.... Altova, Inc.
.... 978-816-1614

Mar 9 '07 #2

This discussion thread is closed

Replies have been disabled for this discussion.