469,342 Members | 5,647 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,342 developers. It's quick & easy.

Asp.net version mismatch

Hi!
I have VS.net 2003 but whenever I try to create an asp.net web application my it says "VS.net has detected that the webserver is running asp.net 1.0 if u want this application can be made compatible to asp.net 1.0 .However u will not be able to use new features of asp.net 1.1..."
I don't want to convert it into 1.0.......
I have iis 6.0 manager.
Plz help me out of this...........
Dec 25 '06 #1
21 5031
kenobewan
4,871 Expert 4TB
Which version of asp.net are you running?
Dec 25 '06 #2
Which version of asp.net are you running?
I have vs.net 2003
.net framework 1.1
so my asp.net is also 1.1 only.........
I have tried uninstalling the whole .net and iis and reinstalled both again but no gain>...........................Plz plz help me out..............All solutions provided in MSDN as in vain....................Plzzzzzzzzzzzz help me..........
Dec 26 '06 #3
Bussis
3
VS 2003 uses IIS as a webserver. Did you check the version on the virtual map for you app.

Go to IIS manager. Go to the properties of the vir. map of you app. Go to the tab "ASP.NET" what does the rule ASP.NET version row say? You can change the version of asp here.

HTH
Dec 26 '06 #4
VS 2003 uses IIS as a webserver. Did you check the version on the virtual map for you app.

Go to IIS manager. Go to the properties of the vir. map of you app. Go to the tab "ASP.NET" what does the rule ASP.NET version row say? You can change the version of asp here.

HTH
But there is no asp.net tab in my IIS........I ' v installed it may times........
Dec 27 '06 #5
Frinavale
9,735 Expert Mod 8TB
But there is no asp.net tab in my IIS........I ' v installed it may times........
Hmm, try:

1) Opening Control Pannel
2) Open Administrative Tools
3) Open Internet Information Services
4) Expand all the folders and find the "Default Web Site" folder (should look like a globe with a hand under it)
5) Right click on the "Default Web Site" and select Properties
5) Click the ASP .NET tab
6) Select the proper ASP .NET version
7) Click apply.


This might not completely solve your problem. I've run into something similar in the past and this doesn't always fix it. You will probably get rid of the error you currently have and a new one will show up. You might have to take some additional steps to re-create the ASPNET user account. If this is the case I'll help step you through that too.

Good luck.
-F
Dec 27 '06 #6
Hmm, try:

1) Opening Control Pannel
2) Open Administrative Tools
3) Open Internet Information Services
4) Expand all the folders and find the "Default Web Site" folder (should look like a globe with a hand under it)
5) Right click on the "Default Web Site" and select Properties
5) Click the ASP .NET tab
6) Select the proper ASP .NET version
7) Click apply.


This might not completely solve your problem. I've run into something similar in the past and this doesn't always fix it. You will probably get rid of the error you currently have and a new one will show up. You might have to take some additional steps to re-create the ASPNET user account. If this is the case I'll help step you through that too.

Good luck.
-F
Tat doesn't work...............
Plz help me i'm quite frustrated..........plzzzzzzzzzzzzzzzzzzzzzzzz
Dec 31 '06 #7
Frinavale
9,735 Expert Mod 8TB
Tat doesn't work...............
Plz help me i'm quite frustrated..........plzzzzzzzzzzzzzzzzzzzzzzzz

Were you able to step through the instructions I gave you?
If so, did your error message change?

I had a similar problem in the past and it took me days to solve the problem.
I'm not exactly sure how the fix works because I sort of stumbled on the solution...but I'll share my thoughts on the issue.

What I think happens is:
Upon a fresh Windows install, you do all the updates.
One of the updates installs .NET Framework 1.0.
As a result the ASPNET user is created to use this framework.
Later during the updates .NET Framework 1.1 is installed but the ASPNET user isn't updated to know how to use it.

To fix this I recreated my ASPNET user and re-registered my .NET Framework 1.1.

If you want to try this, follow the steps I posted before on how to set your IIS Server to use .NET Framework 1.1 then:
1) delete the ASPNET Windows user
2) open a cmd window
3) go to the directory where your Framework 1.1 is installed
(this is likely in your C:\Windows\Microsoft.NET\Framework\v1.1.4322)
4) type: aspnet_regiis -i
(this will re-register the Framework 1.1 and reinstall your ASPNET user so that it works properly)

After you've done this, reboot and then double check that your IIS is still set up to use the .NET Framework 1.1


I'm not sure why this type of error doesn't always happen. Only Microsoft would know the answer.


Hope this helps you.

-F
Jan 2 '07 #8
Were you able to step through the instructions I gave you?
If so, did your error message change?

I had a similar problem in the past and it took me days to solve the problem.
I'm not exactly sure how the fix works because I sort of stumbled on the solution...but I'll share my thoughts on the issue.

What I think happens is:
Upon a fresh Windows install, you do all the updates.
One of the updates installs .NET Framework 1.0.
As a result the ASPNET user is created to use this framework.
Later during the updates .NET Framework 1.1 is installed but the ASPNET user isn't updated to know how to use it.

To fix this I recreated my ASPNET user and re-registered my .NET Framework 1.1.

If you want to try this, follow the steps I posted before on how to set your IIS Server to use .NET Framework 1.1 then:
1) delete the ASPNET Windows user
2) open a cmd window
3) go to the directory where your Framework 1.1 is installed
(this is likely in your C:\Windows\Microsoft.NET\Framework\v1.1.4322)
4) type: aspnet_regiis -i
(this will re-register the Framework 1.1 and reinstall your ASPNET user so that it works properly)

After you've done this, reboot and then double check that your IIS is still set up to use the .NET Framework 1.1


I'm not sure why this type of error doesn't always happen. Only Microsoft would know the answer.


Hope this helps you.

-F
First of all thanks for ur concern......
As i hv already mentioned there is no asp.net tab in my Default web site properties window......Moreover the solutions like aspnet_regiis.exe -i don't work....... Now can u plzz help me out for this.......I'd be greatly obliged....
Regards,
-Ritu
Jan 2 '07 #9
Frinavale
9,735 Expert Mod 8TB
First of all thanks for ur concern......
As i hv already mentioned there is no asp.net tab in my Default web site properties window......Moreover the solutions like aspnet_regiis.exe -i don't work....... Now can u plzz help me out for this.......I'd be greatly obliged....
Regards,
-Ritu
Are you sure you have ASP .NET Framework 1.1 installed?
Have you tried doing a windows update to make that you have all the frameworks installed? You should have up to Framework 2.0.something.

What OS are you running?
Jan 2 '07 #10
Are you sure you have ASP .NET Framework 1.1 installed?
Have you tried doing a windows update to make that you have all the frameworks installed? You should have up to Framework 2.0.something.

What OS are you running?
Win Xp Pro.....
Yo! I' v already updated my windows.... But is Framework 2.0 needed too? I don't have tat.... Anyways I'll try installing tat too...
Jan 5 '07 #11
radcaesar
759 Expert 512MB
Remove the v1.0 frame work

Install the v1.1

use, aspnet_regiis -i in the .net command prompt

:)
Jan 5 '07 #12
Frinavale
9,735 Expert Mod 8TB
Win Xp Pro.....
Yo! I' v already updated my windows.... But is Framework 2.0 needed too? I don't have tat.... Anyways I'll try installing tat too...

I don't think you need to uninstall the older frameworks. If you've updated your windows then you should have all your .NET Frameworks installed.

In Windows Explorer, navigate to C:\WINDOWS\Microsoft.NET\Framework
you should see at least 3 folders in that folder:
v1.0.3705
v1.1.4322
v2.0.50727

If you don't see this you don't have .NET installed properly on your computer....you will have to find them online and install them then run the aspnet_regiis...

I'd be worried if these were missing from the computer because I'd be wondering what else is missing.

Maybe try reinstalling windows and IIS and running through the updates.

-F
Jan 5 '07 #13
I don't think you need to uninstall the older frameworks. If you've updated your windows then you should have all your .NET Frameworks installed.

In Windows Explorer, navigate to C:\WINDOWS\Microsoft.NET\Framework
you should see at least 3 folders in that folder:
v1.0.3705
v1.1.4322
v2.0.50727

If you don't see this you don't have .NET installed properly on your computer....you will have to find them online and install them then run the aspnet_regiis...

I'd be worried if these were missing from the computer because I'd be wondering what else is missing.

Maybe try reinstalling windows and IIS and running through the updates.

-F
Hello Sir,
Now a new problem I ' v encountered....When i write http:\\localhost it displayes the error page :"The page cannot be displayed" ..........
As far as i know it should display the "Welcome to localhost page:"
I'm thinking to format my PC..... btu i'm doubtful if tat will help either.......
Can u solve this problem....May be due to this asp.net problem is also arising...

-Regards
---Ritu
Jan 7 '07 #14
kenobewan
4,871 Expert 4TB
Should be http://localhost...
Jan 8 '07 #15
Frinavale
9,735 Expert Mod 8TB
Hello Sir,
Now a new problem I ' v encountered....When i write http:\\localhost it displayes the error page :"The page cannot be displayed" ..........
As far as i know it should display the "Welcome to localhost page:"
I'm thinking to format my PC..... btu i'm doubtful if tat will help either.......
Can u solve this problem....May be due to this asp.net problem is also arising...

-Regards
---Ritu

Yeah, I've seen that before too. Double check your firewall settings (even though its local host) before jumping to the formatting solution....can't seem to remember why I was getting that error.

It might also be the permissions set for the ASPNET user....
Were you able to run the aspnet_regiis utility?

Are you certain IIS is installed properly?

Sorry I can't be more help

-Frin
Jan 8 '07 #16
kenobewan
4,871 Expert 4TB
I agree with Frin that you most likely have an IIS problem. First double check you have the properties set up correctly. If all else fails reinstall IIS. I had a case where I had to reinstall IIS recently...

Hope that this helps.
Jan 9 '07 #17
Hello!
Thanks all for ur replies..........
But nothing worked out for me except to format my PC and reinstall evrythg and i did tat......................
Jan 14 '07 #18
Frinavale
9,735 Expert Mod 8TB
Hello!
Thanks all for ur replies..........
But nothing worked out for me except to format my PC and reinstall evrythg and i did tat......................
Is everything working now?
Jan 15 '07 #19
Is everything working now?
yaa...
evreything is compatible now...
And thx for ur help n support..

Regards
-Ritu
Jan 17 '07 #20
radcaesar
759 Expert 512MB
Hey,
It may works if u remove the iis and reinstall instead of this work around.

:)


yaa...
evreything is compatible now...
And thx for ur help n support..

Regards
-Ritu
Jan 17 '07 #21
Belaya
1
Frinavale, thank you very much! It works, wawaweeeeeewah... :)
Jan 19 '07 #22

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

1 post views Thread by Ryan Jud Hughes | last post: by
2 posts views Thread by Joe Reazor | last post: by
1 post views Thread by LJgrnl | last post: by
reply views Thread by Einstein, Daniel R | last post: by
2 posts views Thread by Chris Fonnesbeck | last post: by
reply views Thread by Sebastian Meier | last post: by
2 posts views Thread by Clark Sann | last post: by
2 posts views Thread by Paul McNett | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.