By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,706 Members | 1,105 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,706 IT Pros & Developers. It's quick & easy.

Failed to register assembly in COM+

P: n/a
I have dot net framework version 1.1, .NET VS 2002
installed on my machine and also I have the administrator
role assigned to me. I wrote a simple console application
class which I derived from the ServicedComponent. I also
signed my class with a properly generated strong name. I
compiled the code from the command prompt. When I try to
register to the existing COM+ appliction/or a new
application, the following error comes.

1: Failed to register assembly 'Class1, Version=0.0.0.0,
Culture=neutral, PublicKeyToken='78ce69832d3152'.
2: Access to the registry key is denied.

I am using Windows 2000 with service pack 3.
The same class compiles and registers fine on another
colleagues machine.
But again the problem reoccurs on yet another colleagues
machine.
I have even tried giving trust to the assembly
through "Trust an assembly" option of the .NET Framework
1.1 Wizard. It still doesn;t work.

This is quite fustrating as there is no help on this from
the MSDN. Can someone please help!

Regards

Naresh Sharma
Jul 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.