By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,207 Members | 1,065 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,207 IT Pros & Developers. It's quick & easy.

Intellisense with C# and multi-file assembly

P: n/a
Intellisense with C# and a multi-file assembly is not
working. With VB.NET it is working.
Is there a fix availible?

We're using VisualStudio 2003

Regards
Frank
Jul 19 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Hello Frank,

Thanks for your post. I think more information is needed before moving
forward:

Could you please tell me the detailed steps or post a sample project which
is able to reproduce the problem? I will be glad to check it on my side.

I look forward to your response.

Have a nice day!

Regards,

HuangTM
Microsoft Online Partner Support
MCSE/MCSD

Get Secure! C www.microsoft.com/security
This posting is provided as is with no warranties and confers no rights.
Jul 19 '05 #2

P: n/a
Hello Tian Min,

i've created a multi file assembly, containing 3 modules.
The multi file assembly contains only the manifest.
In my C# project, i reference the multi file assembly.
The intellisense for the interfaces of the 3 modules
(referenced in the manifest) is not working. Surprisingly,
the compilation is working.

If i'm using a VB.NET project and add a reference to the
same multi file assembly, the intellisense is working. So
it seems to be a bug in the C# integration in VisualStudio
2003?

Here are the statements to create the multi file assembly:

Creating Modules:
csc /out:$(TargetName).mod /target:module $(ProjectDir)
Class1.cs

csc /out:$(TargetName).mod /target:module $(ProjectDir)
Class2.cs

csc /out:$(TargetName).mod /target:module $(ProjectDir)
Class3.cs

Creating multi file assembly:
al /out:foxRay.dll /v:0.9.0.* /t:lib $(ProjectDir)(OutDir)
Class1.mod $(ProjectDir)$(OutDir)Class2.mod
$(ProjectDir$(OutDir)Class3.mod

The intellisense for foxRay.dll in a C# project is not
working, the intellisense in VB.NET project is working.

Any ideas?

Regards

Frank
-----Original Message-----
Hello Frank,

Thanks for your post. I think more information is needed before moving forward:

Could you please tell me the detailed steps or post a sample project which is able to reproduce the problem? I will be glad to check it on my side.
I look forward to your response.

Have a nice day!

Regards,

HuangTM
Microsoft Online Partner Support
MCSE/MCSD

Get Secure! C www.microsoft.com/security
This posting is provided as is with no warranties and confers no rights.

.

Jul 19 '05 #3

P: n/a
Hi Frank,

Thanks for your information. I am performing research on this issue and
will update you with my information.

Have a nice day!

Regards,

HuangTM
Microsoft Online Partner Support
MCSE/MCSD

Get Secure! C www.microsoft.com/security
This posting is provided as is with no warranties and confers no rights.
Jul 19 '05 #4

P: n/a
Hello Frank,

Thank you very much for your feedback. I reproduced the problem on my side.
After further research, I found it was caused by an known issue which has
been entered into our bug database and it is being investigated. It is
possible that this may be resolved in the next Visual Studio .NET service
pack, but I cannot guarantee a resolution of this issue at this time.

Please feel free to let me know if you have any problems or concerns.

Have a nice day!

Regards,

HuangTM
Microsoft Online Partner Support
MCSE/MCSD

Get Secure! C www.microsoft.com/security
This posting is provided as is with no warranties and confers no rights.

Jul 21 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.