By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,730 Members | 1,480 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,730 IT Pros & Developers. It's quick & easy.

How to disable regions in Visual Studio?

P: n/a
Hi everybody,

Can somebody tell me how to disable regions in Visual Studio 2005?

I've already told VS not to collapse code to regions in the settings, but
each time I open a new (existing) code file from a project, the regions are
there again (and collapsed).

This is really beginning to annoy me, so I'd really like to find a solution
to get rid of these regions. Is there another setting I've missed?

Thanks very much!

Ikke
May 12 '06 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Why don't you just remove the region statements themselves?

May 12 '06 #2

P: n/a
Also, with VS2005, you can right click in the editor and select
Outlining > Stop All Outlining.

Perhaps that will help

May 12 '06 #3

P: n/a
"Chris Dunaway" <du******@gmail.com> wrote in news:1147448464.671092.215750
@v46g2000cwv.googlegroups.com:
Also, with VS2005, you can right click in the editor and select
Outlining > Stop All Outlining.

Perhaps that will help


Thanks, it did.

May 15 '06 #4

P: n/a
Ikke <ik**@hier.com> wrote in news:Xn*****************@195.238.0.34:
"Chris Dunaway" <du******@gmail.com> wrote in
news:1147448464.671092.215750 @v46g2000cwv.googlegroups.com:
Also, with VS2005, you can right click in the editor and select
Outlining > Stop All Outlining.

Perhaps that will help


Thanks, it did.


Or to put it in other words, it did not :)

When I open a file, the regions are there again. Is there a way to get rid
of those annoying things once and for all?

Its VS2003, by the way (I have both and was running the wrong one).

Thanks!
May 15 '06 #5

P: n/a
"Ikke" <ik**@hier.com> wrote in message
news:Xn******************@195.238.0.34...
Ikke <ik**@hier.com> wrote in news:Xn*****************@195.238.0.34:
"Chris Dunaway" <du******@gmail.com> wrote in
news:1147448464.671092.215750 @v46g2000cwv.googlegroups.com:
Also, with VS2005, you can right click in the editor and select
Outlining > Stop All Outlining.

Perhaps that will help


Thanks, it did.


Or to put it in other words, it did not :)

When I open a file, the regions are there again. Is there a way to get rid
of those annoying things once and for all?

Its VS2003, by the way (I have both and was running the wrong one).


Tools->Options

Then pick Text Editor, C#, Advanced and uncheck "Enter outlining mode when
files open" and maybe "Surround generated code with #region".

This is from VS2005 but, VS2003 has a similar (if not identical) setting.
May 15 '06 #6

P: n/a
"John Vottero" <JV******@mvpsi.com> wrote in
news:#l**************@TK2MSFTNGP02.phx.gbl:
"Ikke" <ik**@hier.com> wrote in message
news:Xn******************@195.238.0.34...
Ikke <ik**@hier.com> wrote in news:Xn*****************@195.238.0.34:
"Chris Dunaway" <du******@gmail.com> wrote in
news:1147448464.671092.215750 @v46g2000cwv.googlegroups.com:

Also, with VS2005, you can right click in the editor and select
Outlining > Stop All Outlining.

Perhaps that will help

Thanks, it did.


Or to put it in other words, it did not :)

When I open a file, the regions are there again. Is there a way to
get rid of those annoying things once and for all?

Its VS2003, by the way (I have both and was running the wrong one).


Tools->Options

Then pick Text Editor, C#, Advanced and uncheck "Enter outlining mode
when files open" and maybe "Surround generated code with #region".

This is from VS2005 but, VS2003 has a similar (if not identical)
setting.


Nope. I've changed those settings for C# and VB, but I still get those
annoying regions when I open an existing file.

Is there another editor perhaps, one that does not mess with the code I
write?

Thanks,

Ikke
May 16 '06 #7

This discussion thread is closed

Replies have been disabled for this discussion.