By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,985 Members | 1,830 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,985 IT Pros & Developers. It's quick & easy.

Thread.CurrentThread.CurrentCulture()

P: n/a
Hi,

I have an ASPX app that checks the Culture of the machine.

My PC is currently set to have English(US) dates and US
Currency.

When I check the Culture it returns "en-IE".

The machine did have this original setting but I changed
it to English(US) for dates and currency.

I also removed and reinstalled VS.NET and the .NET
Framework as I thought this may be also be using the
setting of teh time it was installed.

I still had the problem.

I noticed in teh registry that he Default user settings
were set to be "en-IE" etc. So I manually changed these to
have the same settings as a machine with English(US) date
and currency.

I still have the problem. The problem being that my
CultureINfo retirn en-IE.

This is driving me crazy and really holding me up.

Any Ideas?

Thanks,
Clive.
Jul 19 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Clive <cl***@nospam.com> wrote:

<snip>
I noticed in teh registry that he Default user settings
were set to be "en-IE" etc. So I manually changed these to
have the same settings as a machine with English(US) date
and currency.

I still have the problem. The problem being that my
CultureINfo retirn en-IE.


That suggests to me that maybe although the *system* locale is US, your
*user* locale is Irish. Which OS are you using? In XP Pro under
Advanced there's a box saying "Apply all settings to the current user
account and to the default user profile." Maybe that could help you?

--
Jon Skeet - <sk***@pobox.com>
http://www.pobox.com/~skeet/
If replying to the group, please do not mail me too
Jul 19 '05 #2

P: n/a
C
W2K Server.

I have deleted all profiles in the hope that they would be
recreated and that they would use the new date setting but
it has'nt. Any ideas?

Clive

-----Original Message-----
Clive <cl***@nospam.com> wrote:

<snip>
I noticed in teh registry that he Default user settings
were set to be "en-IE" etc. So I manually changed these to have the same settings as a machine with English(US) date and currency.

I still have the problem. The problem being that my
CultureINfo retirn en-IE.
That suggests to me that maybe although the *system*

locale is US, your*user* locale is Irish. Which OS are you using? In XP Pro underAdvanced there's a box saying "Apply all settings to the current useraccount and to the default user profile." Maybe that could help you?
--
Jon Skeet - <sk***@pobox.com>
http://www.pobox.com/~skeet/
If replying to the group, please do not mail me too
.

Jul 19 '05 #3

P: n/a
C <c@nospam.com> wrote:
W2K Server.

I have deleted all profiles in the hope that they would be
recreated and that they would use the new date setting but
it has'nt. Any ideas?


Well, you'd presumably have to keep going with *a* profile to stay
logged in. What happens if you create a new user, log in as them, and
then run your test program?

--
Jon Skeet - <sk***@pobox.com>
http://www.pobox.com/~skeet/
If replying to the group, please do not mail me too
Jul 19 '05 #4

P: n/a
C <c@nospam.com> wrote:
I got another user to log on and it still did'nt work..


In that case I'm afraid I don't know :(

--
Jon Skeet - <sk***@pobox.com>
http://www.pobox.com/~skeet/
If replying to the group, please do not mail me too
Jul 19 '05 #5

P: n/a
"Clive" <cl***@nospam.com> wrote in message
news:04****************************@phx.gbl...
My PC is currently set to have English(US) dates and US
Currency.
When I check the Culture it returns "en-IE".
I still have the problem. The problem being that my
CultureINfo retirn en-IE.
This is driving me crazy and really holding me up.

Check your web.config file and {windows
directory}\Microsoft.NET\Framework\v1.2.3\CONFIG\m achine.config for the
<globalization> element because you can set the default Culture and
UICulture from there.

Jul 19 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.