By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,985 Members | 1,863 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,985 IT Pros & Developers. It's quick & easy.

BUG : Deployment Launch Conditions - Help

P: n/a
Jo
I am having a real problem with the Launch conditions in VS .NET and can
only come to the conclusion that it is a bug.

It states quite emphatically in the MSDN that Launch Conditions WILL be
executed in the order added. This statement holds true if every Condition
has a InstallURL value set. but not if there is no InstallURL value.

For Example :
I want to check that W2K exists on the target machine before installing SP4.
So, I add a Launch condition to check if versionNT=500.
I leave the InstallURL Blank as you are supposed to if you do not want the
user to continue and just display the OK button to terminate.
This works fine by itself

I add another Launch condition which check for SP4 viz. ServicePackLevel >=4
which has a InstallURL to enable me to install SP4 if it does not exist (ie
sp1, 2, 3 is installed)
As soon as I add it it jumps the queue and trie to install SP4 before even
checking in W2k is installed. ???

Add a MDAC Check with option to install and it executes after the SP4 check
(good)
remove the SP4 Checks InstallUrl (ie quit if SP4 or greater not found)
and MDAC jumps the queue.

This is a problem as I do not want to put a installURL in for W2K Check as I
don't want to install W2K (or the app) if the user is running W9x or NT or
XP and I definately don't want to install the SP if W2k does not exist
(granted that the SP install will moan, but too late!)

Things I have tried :
Launch condition addition in sequence of supposed execution ( no good)
Alphabetical Naming sequence, any addition order (no good)
Alphabetical Naming sequence with the correct addition order (no good)
Physically Editing and Swopping (in notepad) the entries n the .vdproj file
(no good)
Adding the W2K check into the default Framework Check section (which happens
before anything anyway) (no good)

Not that it makes a difference but the application I am building a package
for is written in C#...

Any Help on the matter would be greatly appreciated.

My Systems (tried it on all of them) :

All have the following Software : (and one JUST have this software, nothing
else so its nice and fresh)
~~~~~~~~~~~~~~~~~~~~~~
W2k SP4
VS.NET Architect edition
..Net Framework 1.1 (version : 1.1.4322)
Microsoft Development Environment (version : 7.1.3088)
Microsoft Visual C# .NET 69586-335-0000007-18303
Microsoft Visual Basic .NET 69586-335-0000007-18303
Microsoft Visual J# .NET 69586-335-0000007-18303
Crystal Reports for Visual Studio .NET AAP50-GS00000-U7000RN
IE6 sp1 (required by the VS.NET install)

All the VS.NET stuff is the latest that came with the 2003 MSDN
subscription.

Different Hardware
~~~~~~~~~~~~~~
Compaq P4 2.1GHz
512Mb DDR Ram
40GB HD

Dell Laptop P4 2.4GHz
512MB DDR Ram
40gb HD

Celeron 2.3GH
512MB DDR Ram
80GB HD


Jul 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.