By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,952 Members | 1,937 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,952 IT Pros & Developers. It's quick & easy.

Server Application Unavailable

P: n/a
I downloaded a security fix from Microsoft, using
Windows update, on Wednesday night, 20-Aug-2003.
The next time I tried to use IE to bring up a local
web site, I got a "Server Application Unavailable"
error when it tried to access an .aspx page.

When I looked in the C:\WINDOWS\system32\Logfiles\W3SVC1
directory, the newest log included the following line:
01:14:30 127.0.0.1 GET /WebSite/main.aspx 500
which indicates an internal server error (error 500).

Everything was working fine before I downloaded the
update. Does anyone have any ideas?

By the way, how can I tell which patch I downloaded?

Thanks,
Daniel
Jul 19 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Hi Daniel,

As I understand, the problem is:

After installing the Windows Updates, we started getting the following
error message when we try to run any asp.net web application on the web
server :

Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web browser
to retry your request.

Administrator Note: An error message detailing the cause of this specific
request failure can be found in the system event log of the web server.
Please review this log entry to discover what caused this error to occur.

There are some similar reports for this issue. Currently the resolutios are:

1. Change userName attribute to SYSTEM in the <processModel> section of
the Machine.config.

2. Give the ASPNET account the permissions it requires:

1) Open Windows Explorer, navigate to \Documents and Settings
2) If the "LocalService" directory is NOT visible, you need to choose
"Folder Options" from the "Tools" menu. Then you need to ensure that under
the "View" tab, protected OS files are NOT hidden
3) Continue on to \Documents and Settings\LocalService
4) Right-click on the "Local Settings" folder, then select "Sharing and
Security".
5) In the "Security" tab, "Add" the "ASPNET" user, and make sure it has
"Read" and "List Folder Contents" permissions.
6) "Apply", "OK", .... etc until all windows closed.

Does it answer your question? If I have misunderstood your concern, please
let me know.

Best regards,

Jacob Yang
Microsoft Online Partner Support
<MCSD>
Get Secure! C www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Jacob Yang
Microsoft Online Partner Support
<MCSD>
Get Secure! C www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Jul 19 '05 #2

P: n/a
Great thanks to Jacob,

The first suggestion, changing the userName attribute
to SYSTEM in <processModel> of Machine.config
fixed the problem.

By the way, I am running XP Pro using a dial-up connection
to my ISP.
For XP, the Machine.config file is in the
\WINDOWS\Microsoft.NET\Framework\<version>\Config folder.

Again, thanks to Jacob,
Daniel
-----Original Message-----
Hi Daniel,

As I understand, the problem is:

After installing the Windows Updates, we started getting the following error message when we try to run any asp.net web application on the web server :

Server Application Unavailable
The web application you are attempting to access on this web server is currently unavailable. Please hit the "Refresh" button in your web browser to retry your request.

Administrator Note: An error message detailing the cause of this specific request failure can be found in the system event log of the web server. Please review this log entry to discover what caused this error to occur.
There are some similar reports for this issue. Currently the resolutios are:
1. Change userName attribute to SYSTEM in the <processModel> section of the Machine.config.

2. Give the ASPNET account the permissions it requires:

1) Open Windows Explorer, navigate to \Documents and Settings2) If the "LocalService" directory is NOT visible, you need to choose "Folder Options" from the "Tools" menu. Then you need to ensure that under the "View" tab, protected OS files are NOT hidden
3) Continue on to \Documents and Settings\LocalService
4) Right-click on the "Local Settings" folder, then select "Sharing and Security".
5) In the "Security" tab, "Add" the "ASPNET" user, and make sure it has "Read" and "List Folder Contents" permissions.
6) "Apply", "OK", .... etc until all windows closed.

Does it answer your question? If I have misunderstood your concern, please let me know.

Best regards,

Jacob Yang
Microsoft Online Partner Support
<MCSD>
Get Secure! C www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.
Jacob Yang
Microsoft Online Partner Support
<MCSD>
Get Secure! C www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.
.

Jul 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.