By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,946 Members | 741 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,946 IT Pros & Developers. It's quick & easy.

Web Setup Projects

P: n/a
http://support.microsoft.com/default.aspx?scid=KB;EN-
US;Q324906&


-----Original Message-----
I'm trying to create a Web SetUp Project for a web
application my team recently developed.
I was able to get the setup project to compile but not
install anything.

Then I reached a point where I could get it to get half
way through the installation before it would give me a
permissions error.

Then I added all of the local users of my machine to the
C: drive and gave them all full control (I did this at theadvice of a senior member of my team).

The next time I ran the setup project I got these two
errors: "The system cannot open the device or file
specified" and "The installer has encountered an
unexpected error installing this package. This may
indicate a problem with this package. The error code is
2755."

So I thought that it was because of the user/permission
changes. I removed all the new users I had just added
and tried to run the installation again. Still the same
two errors. I removed the setup project from the
solution and deleted it from my hard drive and created a
brand new project in the solution, when I tried to run thenew installation I still got the same errors.

I don't know what I did to cause these errors, nor do I
know how to fix them.

I searched Google for articles pertaining to this error,
but the only articles I found were related to issues with
off-the-shelf software installs, they had nothing to do
with VS.NET setup projects.

I have since rebooted my machine and re-added the local
users with full control. However, this didn't solve my
problem.
.

Jul 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.