By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,677 Members | 1,060 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,677 IT Pros & Developers. It's quick & easy.

Can someone explain what "Server Busy" dialog is?

P: n/a
Sometimes when I try to close my managed C++ application, the following
dialog displays in Win 2000 Pro:

The title of the dialog is "Server Busy".
The message is "This action cannot be completed because the other program is
busy. Choose 'Switch to' to activate the busy program and correct the
problem."

I don't know why this is displayed. I would prefer to disable the display
of this message if possible. My app needs to be able to close in an
unattended environment, so I need to prevent any messages requiring user
interaction.

Can anyone help me on this?

--
-----------------------------------
Ken Varn
Senior Software Engineer
Diebold Inc.
va***@diebold.com
-----------------------------------
Jul 19 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Is there anyway to set a registry setting so that the "Switch to" selection
is made automatically?

--
-----------------------------------
Ken Varn
Senior Software Engineer
Diebold Inc.
va***@diebold.com
-----------------------------------
"John Timney (Microsoft MVP)" <ti*****@despammed.com> wrote in message
news:eI**************@TK2MSFTNGP12.phx.gbl...
I have no idea what your app does nor how to fix it for you, but this used
to (and likely still does) come about in windows when a client was talking
to an automation server (like excel from a VB client) and the server lost
focus. It would complain because it was expecting to do something and did
not have the focus any longer as control had switched back to the calling
application prematurely.

--
Regards

John Timney (Microsoft ASP.NET MVP)
----------------------------------------------
<shameless_author_plug>
Professional .NET for Java Developers with C#
ISBN:1-861007-91-4
Professional Windows Forms
ISBN: 1861005547
Professional JSP 2nd Edition
ISBN: 1861004958
Professional JSP
ISBN: 1861003625
Beginning JSP Web Development
ISBN: 1861002092
</shameless_author_plug>
----------------------------------------------

"Ken Varn" <va***@diebold.com> wrote in message
news:uS**************@TK2MSFTNGP09.phx.gbl...
Sometimes when I try to close my managed C++ application, the following
dialog displays in Win 2000 Pro:

The title of the dialog is "Server Busy".
The message is "This action cannot be completed because the other program
is
busy. Choose 'Switch to' to activate the busy program and correct the
problem."

I don't know why this is displayed. I would prefer to disable the

display of this message if possible. My app needs to be able to close in an
unattended environment, so I need to prevent any messages requiring user
interaction.

Can anyone help me on this?

--
-----------------------------------
Ken Varn
Senior Software Engineer
Diebold Inc.
va***@diebold.com
-----------------------------------


Jul 19 '05 #2

P: n/a
I wouldn't think so.............if this is the cause its usually causede by
a flaw in the client apps logic

--
Regards

John Timney (Microsoft ASP.NET MVP)
----------------------------------------------
<shameless_author_plug>
Professional .NET for Java Developers with C#
ISBN:1-861007-91-4
Professional Windows Forms
ISBN: 1861005547
Professional JSP 2nd Edition
ISBN: 1861004958
Professional JSP
ISBN: 1861003625
Beginning JSP Web Development
ISBN: 1861002092
</shameless_author_plug>
----------------------------------------------

"Ken Varn" <va***@diebold.com> wrote in message
news:OE**************@TK2MSFTNGP12.phx.gbl...
Is there anyway to set a registry setting so that the "Switch to" selection is made automatically?

--
-----------------------------------
Ken Varn
Senior Software Engineer
Diebold Inc.
va***@diebold.com
-----------------------------------
"John Timney (Microsoft MVP)" <ti*****@despammed.com> wrote in message
news:eI**************@TK2MSFTNGP12.phx.gbl...
I have no idea what your app does nor how to fix it for you, but this used
to (and likely still does) come about in windows when a client was talking to an automation server (like excel from a VB client) and the server lost focus. It would complain because it was expecting to do something and did not have the focus any longer as control had switched back to the calling application prematurely.

--
Regards

John Timney (Microsoft ASP.NET MVP)
----------------------------------------------
<shameless_author_plug>
Professional .NET for Java Developers with C#
ISBN:1-861007-91-4
Professional Windows Forms
ISBN: 1861005547
Professional JSP 2nd Edition
ISBN: 1861004958
Professional JSP
ISBN: 1861003625
Beginning JSP Web Development
ISBN: 1861002092
</shameless_author_plug>
----------------------------------------------

"Ken Varn" <va***@diebold.com> wrote in message
news:uS**************@TK2MSFTNGP09.phx.gbl...
Sometimes when I try to close my managed C++ application, the following dialog displays in Win 2000 Pro:

The title of the dialog is "Server Busy".
The message is "This action cannot be completed because the other

program
is
busy. Choose 'Switch to' to activate the busy program and correct the problem."

I don't know why this is displayed. I would prefer to disable the

display of this message if possible. My app needs to be able to close in an
unattended environment, so I need to prevent any messages requiring user interaction.

Can anyone help me on this?

--
-----------------------------------
Ken Varn
Senior Software Engineer
Diebold Inc.
va***@diebold.com
-----------------------------------



Jul 19 '05 #3

P: n/a
John Timney (Microsoft MVP) wrote:
I wouldn't think so.............if this is the cause its usually
causede by a flaw in the client apps logic


From my experience this is mostly a flow in the server app...

The message will come up, if the client calls an sever and the server does
not respond.

--
Greetings
Jochen

Do you need a memory-leak finder ?
http://www.codeproject.com/useritems/leakfinder.asp
Jul 19 '05 #4

P: n/a

"John Timney (Microsoft MVP)" <ti*****@despammed.com> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
I wouldn't think so.............if this is the cause its usually causede by a flaw in the client apps logic


Or both. A simple example: if WinWord used as an OLE server decides to
display a modal form (like to ask for confirmation about merging the
normal.dot style or something like that), no OLE client will be able to
proceed until the modal form is humanly dealt with.
This could be called a mistake in the installation of WinWord, but it can be
a problem quite hard to deal with...
--
WildHeart'2k3
Jul 19 '05 #5

P: n/a
Your client app may hang since it is waitng for a response from the server.
There could be some flaw in the server's logic which will cause the client
to hang. Or some operation is taking longer than expected in which case the
client will eventually close.

"Ken Varn" <va***@diebold.com> wrote in message
news:O4**************@TK2MSFTNGP12.phx.gbl...
Thanks for the info. This really helps.

One more question. This problem seems to occur when my application is
trying to close. If I disable these dialogs, will it just hang when trying to close or will it actually close?
--
-----------------------------------
Ken Varn
Senior Software Engineer
Diebold Inc.
va***@diebold.com


Jul 19 '05 #6

P: n/a
Hello Ken,

By using the method in the KB artilce, the application won't hang since you have set the timeout value. When the timeout
value expires, the call will return.

Thanks.

Best regards,
Yanhong Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

--------------------
!Reply-To: "Ken Varn" <va***@diebold.com>
!From: "Ken Varn" <va***@diebold.com>
!References: <uS**************@TK2MSFTNGP09.phx.gbl> <eQ**************@TK2MSFTNGP09.phx.gbl>
!Subject: Re: Can someone explain what "Server Busy" dialog is?
!Date: Thu, 31 Jul 2003 08:42:38 -0400
!Lines: 61
!Organization: Diebold Inc.
!X-Priority: 3
!X-MSMail-Priority: Normal
!X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!Message-ID: <O4**************@TK2MSFTNGP12.phx.gbl>
!Newsgroups:
microsoft.public.dotnet.framework.clr,microsoft.pu blic.dotnet.framework.sdk,microsoft.public.dotnet. general,microsoft.public.
dotnet.languages.vc
!NNTP-Posting-Host: 204.151.249.23
!Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA06.phx.gbl!TK2MSFT NGXA05.phx.gbl!TK2MSFTNGP08.phx.gbl!
TK2MSFTNGP12.phx.gbl
!Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.sdk:7072 microsoft.public.dotnet.general:102991
microsoft.public.dotnet.languages.vc:26718 microsoft.public.dotnet.framework.clr:7520
!X-Tomcat-NG: microsoft.public.dotnet.general
!
!Thanks for the info. This really helps.
!
!One more question. This problem seems to occur when my application is
!trying to close. If I disable these dialogs, will it just hang when trying
!to close or will it actually close?
!
!
!--
!-----------------------------------
!Ken Varn
!Senior Software Engineer
!Diebold Inc.
!va***@diebold.com
!-----------------------------------
!"Leana" <je******@cadsindia.com> wrote in message
!news:eQ**************@TK2MSFTNGP09.phx.gbl...
!> Search MSDN for ID: Q248019 which could help you.
!>
!> You should be able to stop these message boxes with
!>
!> AfxOleGetMessageFilter()->EnableNotRespondingDialog(FALSE);
!>
!> AfxOleGetMessageFilter()->EnableBusyDialog(FALSE);
!>
!> or you could increase the delay period using
!>
!> AfxOleGetMessageFilter()->SetMessagePendingDelay(nDelay);
!>
!> "Ken Varn" <va***@diebold.com> wrote in message
!> news:uS**************@TK2MSFTNGP09.phx.gbl...
!> > Sometimes when I try to close my managed C++ application, the following
!> > dialog displays in Win 2000 Pro:
!> >
!> > The title of the dialog is "Server Busy".
!> > The message is "This action cannot be completed because the other
!program
!> is
!> > busy. Choose 'Switch to' to activate the busy program and correct the
!> > problem."
!> >
!> > I don't know why this is displayed. I would prefer to disable the
!display
!> > of this message if possible. My app needs to be able to close in an
!> > unattended environment, so I need to prevent any messages requiring user
!> > interaction.
!> >
!> > Can anyone help me on this?
!> >
!> > --
!> > -----------------------------------
!> > Ken Varn
!> > Senior Software Engineer
!> > Diebold Inc.
!> > va***@diebold.com
!> > -----------------------------------
!> >
!> >
!>
!>
!
!
!
Jul 19 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.